Z Limit Switch Failure?

image Ok, I’m looking for a little bit of help, please! I did send a request to support, but I figured I would put this out there to the forum to see if there is anything I can look into in case it takes time to hear back from support. First of all, I have an early XL with a version 2.3 control panel, the HDZ, touch probe, and bit setter. Tonight, while initializating my machine for the first time in a week, it went to the back right corner like it normally would before making all kinds of cringeworthy noises. After about 5 seconds I was finally able to shut off the machine at the power switch. I wasn’t sure what happened, then I saw that I had an error that said GRBL failed, homing error, pull off didn’t clear. Then it gave me a Z limit switch error. After looking at the limit switch, the little pin had been sheared off and the switch was crooked, a bit up in the error. I repositioned it and tightened it down to try again, and I got the error again and the z axis just plunged down an inch or so without doing anything else. After some searches here, I tried to check my switched on the control panel by pushing each one and checking to see if they lit up. I cannot see anything light up when I push any of the switches. I tried to look somewhere beneath them and see nothing. What might I be doing wrong? Also, if it is a switch or multiple ones, where can I get replacements? I will say that I got a new laptop since the last job I ran, and the new version of carbide motion it picked up was 4.28, whereas my old had 4.17. Do I need to do something to reset up the machine with the new laptop? Thanks for any help you guys can give! image

No, install Carbide Motion and Carbide Create and thats it.

Sounds like your Z Switch is triggered all the time. Open Log by going to settings -> Open log, inbetween all the lines that comes flying here there will be a report of change on the limit switches when you manually activate them, test one by one and you should see a result in the log.

If the limit switches are active, this will also be displayed in Carbide Motion on one of the tabs, but i cant remember which one.

If you have a multimeter, this also comes in handy for testing.

Im not surprised if support has been in touch with you already and solved this issue! :smiley:, if not they will most likely send you a new switch if that turns out to be the problem.

Let us know how it turns out or if you need some help.

1 Like

Thanks for the help, I think this helped me make some progress before going to bed for the night. I still can’t find anything on the control panel lighting up when I push the switches, but I did open the log and was able to see some lines that appeared to point toward the x and y axes when I pushed those switches, and nothing seemed to happen with the z. I’m hoping that means that switch failed and I just need to see if I can get a new one form carbide. I did swap the y and z switches at the control panel and it did at least send the z axis back up to the top before crashing into the switch. All signs pointing to a switch? Thanks again for the help, you’ll allow me to sleep much better-these types of things keep me up all night if I don’t have at least some idea of what’s going on before I get to bed, ha!

Yes the arrows are pointing at the switch. If for some reason support is not supplying a switch, they can be purchased here and many other places.
This requires soldering as it does not come with connected wires and connector as it does fromC3d.

Sounds like you better get a new one, but please do post a picture of this when you have time.

Have a good night :slight_smile:

1 Like

Thanks again for the help, and here is the image of the switch. Support was all over it like you mentioned and is sending me a new switch, so hopefully this guy will be up and running again soon. I’m still a bit gunshy about something happening again, but they also mentioned to resend the machine configuration since I set up a new laptop (https://docs.carbide3d.com/support/carbideupdater/#carbide-motion-v4). It sounds like maybe it’s more of a “sure” thing to do vs a “have” to do, but I’ll go ahead and do that as well once I get the new switch installed. Thanks again for your help. I’ll report back once the parts are in to make sure it worked.

4 Likes

I have exactly the same issue installing HDX. I will ohm out the switch to see if it failed. Seems like too much of a coincidence. We’ll see.

Very interesting, let me know what you find out. I’m still a bit worried about installing the new and it happening again. I’m not sure when the new one will make it here, but I’ll test it and report out as soon as I get it. I suppose I need to hope that the last switch failed before it was touched by the HDZ, hence allowing the crash. Otherwise, I have something else going on that popped up out of nowhere.

i also have the same problem , fitted the HDZ UPPGRADE then got exact same error, im convinced the z switch got broke while fitting the hdz but need to get replacement, im in uk , any idea who would I contact to find out? would I contact customer support on carbide 3d’s actual website?

Yes, if you haven’t already, contact support@carbide3d.com and we’ll work out how to get a replacement switch to you.

Thanks for the help from everyone in support (Will and Adam) as well as Kenneth in this thread! The Carbide 3d support team sent me a switch very quickly-I received it today, installed it, and everything works as normal now! Thanks again for the help, guys!

3 Likes

I removed the switch and checked it with an Ohm meter and it is defective.

Carbide sent a new switch. I had already sourced one, so now I have a spare. I also had to put a block of plastic w/ two way tape on top of the z axis carriage because the homing/limit switch was not being engaged. It is about 3/16” tall.

2 Likes

That’s interesting, I wonder what is different. Must be tolerance stack up on the HDZ because mine engages just fine…the only issue with mine must have been that it failed before the machine homed.