Z limit switch not being recognized when homing

I have a Shapeoko 3 XL grbl code 0.9

When I try and home the machine the Z axis is not responding when it reaches the top. I had a faulty switch and did replace it thanks to Carbide. I have checked the switch and cable with a multi meter and all checks out. Just the board isn’t receiving the command when it hits the switch.

Any know issues with the board, Only had it a few months.

Here my $$

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=40.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=1270.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=80.000 (z max travel, mm)

Not sure about why your Z limit switch is not working, but you need to set your max travel ($130 and $131). Yours are set to default SO3. Your X is about twice that if you have an XL.

Does the Z switch trigger an alarm if you press it during a carve (not during homing process)?

Great thanks I changed it in the setting on the Carbide motion guess it didn’t up those.

On the Z trigger, no it doesn’t trigger an alarm, The X and Y do trigger an alarm and I can watch the GRBL code run but the z is doing nothing.

Try swapping the wiring and see if the Z switch will trigger if plugged in to a different connection (see if the problem follows the switch). It could be you wire from the switch to the board or it could be a faulty board.

I moved the Z cable to X and X to Z. I get the switch to trigger on the Z now and X no go.

Sounds like a bad cable. Do you have a continuity tester or a multimeter to check the cable?

Guess I said it wrong,

when I switched the Z and X cable switch cable.

I got a response from the Z switch which is responding the board just fine.
The X cable was plugged into the Z pins on the board, which produced nothing when pressed.

So it sounds like a board, cables are fine I did check the Z cable already with a mult meter.

I am wondering if there is a setting in the system that turns it on and off to accept commands. Guess that might be homing, hmm