Z losing zero setting

to elaborate: the idea here is to isolate the BitSetter probing sequence to see if it alone introduces an offset.
so try:

  • zero Z anywhere on a flat surface
  • send M6T201 in the MDI: the machine will prompt for a tool change, let the bit where it is and hit resume, the machine will go and probe the BitSetter
  • after this is completed, jog manually back to the surface where you zeroed, and check whether when you reach the surface (carefully) you are close to Z=0.00
1 Like

Ok I did that in MIDI and put in the 1/4 “ bit as prompted. It went to bitsetter and recentered.

I went to my project and jogged to rapid position “6 mm over zero” and it was right on

I am trying to replicate the issue but it is working fine at the moment. However… when it happens again, what file do I need to better assess the problem?

The most helpful to troubleshoot would probably be the log traces I mentioned before, from the Log window (Settings pane, then click “Show Log”). If you can leave it open while using CM, whenever this happens again it will be a simple matter of clicking on “Copy All”, and pasting that in a text file, and posting it here for a look. If you can also keep very detailed notes of the steps you took, that will help a lot.

Alternatively, I would be curious to see if you can reproduce the problem if you add a step to your workflow: click on “Load new tool” juts before starting the job, leave the bit as it is, hit resume, let it probe. It’s normally unnecessary, but if the problem goes away then it will provide clues.

1 Like

The only causes of this which I can recall seeing on the tech support queue are:

  • changing a tool without using the interface
  • a tool slipping in the collet
  • the router slipping in the mount
  • lost steps against top stop due to excessive retract height
  • an intermittent connection along the ground path due to a damaged wire, wrong choice of grounding connection point, or storing the ground lead in such a way that it will touch the BitZero (they both use the Probe input)

If you can come up with a repeatable workflow which has the wrong result with a current or beta version we’ll do our best to look into things.

If you have an intermittent result and can capture the log and send it in to us we’ll do our best to look into things with you.

1 Like

I will post when the issue happens and I get the log.

Thanks to all for the help so far!!

1 Like

Ok, so it happened again. Since the last time, I have had it happen a couple times. The first couple times I did not have the log open, but this time i had the log open. I have attached it - The log should show the last cut that happened. I set zero and when it started it was coming down fast, and i knew it was not right (the machine slows up just before cutting), so I paused and stopped it. I checked the z and sure enough it was off by -0.3.

The work piece was about .75" thick. I have checked to make sure the router and collet were in place and not moving. They seem fine. The ground wire does not appear damaged and is grounded on the machine as it always has been. The retract height is not coming near the top.

1 Like

Z Issue.pdf (522.5 KB)

2 Likes

I’ve had this happen to me several times as well. I have double checked everything mentioned above and it still does it. I gave up on touch probe and have been manually setting X,Y,Z, selecting tool changes with my first tool, and then I rapid to “current Z +6mm”. Sometimes its fine, sometimes its not. I’ve learned I have to do this process 4-5 times for each start up, i got tired of a 90-vee plunging straight through 3/4" material into my wasteboard. All this btw leaving the same bit in there for the entire process (I dont use touch probe with V bit). It has something to do with bitsetter, not saying its bad or anything, but something is weird. I just assumed it was something I was or was not doing and figured it was user error, and learned to repeat the process over and over and over until I’m confident it wont happen again. And I watch closely with hand on E-stop button just in case. I will post my log when it goes it again. I will to and replicate it tonight.

My “old” process
Turn on Machine, it homes and comes to front for tool change, I leave that tool in there, (201), it goes to bit setter, i jog machine to probe X,Y,Z, it does so with out a hitch (Yes i have probe set at proper location, yes I have the correct tool selected when I am probing), I load file, and start job, it ask for a tool change, again, I do not touch the bit, it goes to setter and starts cutting, straight through my material. I did not have this issue when I first got the machine, but I’ve been having the issue for a few months now. I figured it was maybe a glitch in CM so I updated to most recent version and that didn’t help.

Thanks, I’ll try and have a look. Not sure what I will be able to conclude but worth as shot.
Could you also upload the corresponding G-code file you ran please ?

I don’t own a bitsetter, but have had this problem numerous times-typically after running a file with a lot of deep cuts or a long bit, then switching files to a second operation that does not require a bit change and, thus, need for re-zero Z (theoretically).

I’ve narrowed it down to two likely culprits: Z belt slippage or bit movement due to incorrect bit tightness. Typically, it is the former. As was stated, if the Z carriage runs out of room when moving to the top (too high settings in your CAM toolpath settings), the belt will slip. It does not take but a tooth or two to really mess up the next set of cuts if you don’t re-zero every time between files (even if you don’t change the bit). This could happen on the first cut as well if your machine lifts too high when moving to the start point. I’ve found that when slippage happens, it is rarely, if only barely, perceptible to the operator.

Greetings,
I am experiencing the same z axis zero issues and have assumed incorrectly that its something I am doing wrong. Its something the machine is doing randomly.
In this operation my goal is to remove the extra material from an inlay revealing the inlay at the same level as the rest of the material.
This is the sequence of the operation.
Mount Project
Insert 1" cutter
Set XYZ zero
Rapid to current XYZ, then 6mm above Z zero. All Checks out.
Load File to remove .163" of material over entire project. (Its a cutting board)
Start Job
Follow prompts to insert bit. I leave the bit in.
Machine measures tool length at Bit Setter.
Set RPM
Machine gouges about 1/8" into board. COMPLETELY RUINING THE PROJECT! This is total Z movement of about .288"
At this point I try to figure out what I’M doing wrong so I reset the z axis zero again. Thinking I must be missing a step.
Restart the same file.
The machine repeats the 1/8" gouge. so I stop the machine.
Reset the Z axis zero again and restart the machine.
The cutter passes about 1/4" above the zero I just set.
Completely frustrated and frankly deflated over this as I have ZERO confidence that I can load a project in this machine and not have it completely ruined.
I will check the items listed in this thread to make sure its not a mechanical issue.
Please let me know if there is a solution to this issue and the steps to correct it.
Thanks,
Don

Hi @Donzzi,

At that precise moment in the steps you describe, did you use the “Change Tool” button in the user interface and follow the prompts, or did you just install the 1" endmill in the router and proceeded to zero?

is your 1 inch cutter a center cutting endmill? The spoil board surfacing bit I use is a 3 cutter Whiteside and the center is open large enough for the Bit Setter button to fit inside. To use this tool with the bit setter I have an auxiliary cap super glued to the bit setter to provide a large enough platform for all 3 wings to engage the bit setter.

2 Likes

Good point Lester,
It is a spoil board cutter but I have the bit setter slightly off center so one of the blades hits it.
Julien,
I don’t think it prompts for a specific tool so I install the one I know it needs. It then touches off on the bit setter. I zero XYZ. When I start the job it prompts for tool required and . I do not use the “change tool” button because it prompts for a tool.

Good Morning,
I used the tool change button last night and ran the skim program and it worked perfectly. I now am wondering what the difference is between the prompt that appears when you connect the machine and the user interface change tool button.
On another subject how do I get the element library for design work. The window opens but there’s nothing in the library.
Julien,
Thanks so much for your speedy response and help with my issue!
Don

1 Like

Good morning Don,

Glad to hear it worked. There should be no difference between inserting a tool when CM prompts for it as part of the initialization routine, and inserting it after pressing the Change Tool button. In both cases, the tool then goes automatically to get probed at the BitSetter, and CM should then have a proper Z reference established.

[warning, digression ahead] However, there is always the possibility that at some point you would unintentionally insert the tool at a different time without CM knowing. Say, you initialized the machine, it came to the front, you insert a tool, it gets probed, then you set the zeroes. And you later realize you have the wrong cutter installed. At this time, there is no reason for CM to start any prompt, so if you forget to use the Change Tool button, the end result would be that you install that new cutter while the machine and CM are idle, but it does not get probed. And the machine still has the zeroes established with the previous endmill. So upon starting the job, the machine will go to the BitSetter, probe the (new) endmill, compute the length difference from the latest probe operation, and adjust the Z zero accordingly…but at this point the Z zero is incorrect since you changed the bit. There are other similar variants for things to go wrong if you ever insert the tool without “telling” CM you did (i.e. without using the Change Tool button, and outside of an explicit prompt to do so)

Now, there have been a few cases (like earlier in that thread) where the workflow seems to be fully correct and still the problem happens, but it is really difficult to troubleshoot remotely because so many elements are involved (the details steps taken, the file being used, the way zero was established, the integrity of the connection to the BitSetter, …). If you ever come up with a repeatable way to make the BitSetter fail while being 100% sure you followed the right workflow, I would be very interested, but for now there has been no evidence of a software/hardware bug.

On the latest versions of CC, the design elements have been removed, they are now available online at:

https://launch.carbide3d.com/

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.