Z suddenly plunges too deep

Was trying to create a simple box out of some 2x4. 1st attempt made it through the first half of the box, part way through the second did a sudden plunge when moving down. Researched the forums, tightened the z axis belt. Second attempt did the same thing on the first half of the box. Tightened a little more, had the same problem on the 3rd attempt. Attached is a pic of 2 and 3. It was cutting like a champ until it decided to go crazy on me. Any other thoughts? Thanks.


1 Like

Are you sure the endmill isn’t coming loose?

What software is generating the G-code?

Did you preview it?

1 Like

Wasn’t the endmill. This project created in and G code generated with CC. Simulation looked fine, although noticed that when the sim was flipped upside down it looked like the bottom wasn’t there. I disabled a layer at a time and it persisted, so guessing it’s software artifact. I can provide the file if needed. Thanks.

Please send the file in to support@carbide3d.com and we’ll look at it.

Bit of a shot in the dark, but are your Z-axis V-wheels possibly running off the end of the tracks? As in the machine is plunging beyond max Z? Bet all kinds of weird things could happen. If so try a longer bit or chucking the bit up with more stickout? I’ve lost Z depth (belt slip), but never gained any.

Edit: The simulation bottom is always hollow, or at least it always has been for me.



Good to know Dan, thanks. Not sure about the V wheels, but something worth looking at. Will, I will send the file this evening after work.

fwiw i am wondering if my machine is hitting the homing switch and thus homing at a different height than when the job started. i don’t know this for a fact - but i’m going to make a post about this later.

did the router come loose? i had something similar happen today - and i wonder if the router slipped.

i have had the endmill slip before - that has happened to me. human error on that one.

how i wish CM had a preview function.

can i drop gcode into CC and preview it there? i run the simulation on RhinoCAM but it would be cool to see that repreated in CM prior to running a job

1 Like

To preview G-Code, please use one of the programs listed at:




1 Like

Hitting the limit switch in the middle of a job should stop it retracting but not ‘rezero’ the machine. I would have guessed slipping bit, belt, or sliding off the rails. Is the router positioned at the bottom of the mounting collar?


but that doesn’t tell me how CM is interpreting it.

that’s what i’m interested in. seeing what CM will do before it happens.
i dunno - maybe i;m being too picky. maybe seeing it in chilipeppr would be sufficient.

i would def vote for this type of feature to be added to future versions of CM.

A preview is likely in the works but with so many other tools already doing it I don’t imagine it’d be a high priority.

1 Like


FYI: I have the same problem, and chased it for weeks. I finally figured it out to be that the Z axis, on retract was losing its sync with the stepper motor because (sometimes) a large chip (MDF and/or metal) was getting caught between the v-Wheel and the rail.

I didn’t really fix it, because I think it would take covering the wheels, but what I did was lessen the Z retract between cuts from 10 or 12mm (Carbide Create’s default) to just 2mm.

I have been looking for covers similar to this to permanently fix the problem:


Rich, that would make alot of sense. These are the deepest pockets I’ve created and the 1/4" endmill was kicking out bigger pieces. Also, it wouldn’t happen at the same depth each occurrence, so probably not software related. I’ll lessen the z retract when I try again next time and see how it goes. Thanks!


1 Like

i’m getting build up of pink foam on the belt / wheel - i did wonder if i was getting slippage there. hmmm.

I don’t think Slippage is a problem in general (V-Wheels slip, Belts don’t).

My case is where a large particle gets jammed between the wheel and rail (with the Z going up) and the motor stalls for a moment which throws off the calibration (since this is an open loop system). This means that the Z is not off 1+ mm and will now go lower (1+mm) into your work part. Sometimes it was off as much as 10mm, and it made scrap faster than the speed of dark.


hmm. i got furry bits caught up in between the belt and the tensioner - so i dunno. the v- wheels i’m not worried about. i def get some slippage though - manually jogging - loses a couple mm on any given setup, setting the zero etc. not a biggie - i’m really trying not to mill deeper than 1.75 inches, after that it seems the machine is likely to have issues with the dust boot and such.

I did this once. I had a part with a 1/4" hole in a basin like your part, and I was using some douglas fir. When it bore straight down with the 1/4" bit to create a 1/4" hole, the wood heated up, and the wood clamped down on the bit while being extracted. This made the belt slip even though it was not loose, and then it tried to move to the next area, even thou the bit was still in the 1/4" hole. My solution was to make the hole a 0.28 inch hole, to avoid the swelling hot wood condition. This typically only happens when boring deep straight 1/4" holes near maximum depth. By using 0.28 hole, the bit wobbles around in many circular motions in steps and stays much cooler.

PS I really doubt the belt is slipping (if it’s fairly tight. These Stepper motors only deliver 18 pounds of (magnetic) down force before they (the motor) slips.

1 Like

Oh! After the bit clamp down condition happens, the Z axis is minus some dimension, and the following cuts are too deep.

The point is, a 1/4 bit boring down to maximum depth in Douglas Fir will heat up nearly red hot, and the bit will be difficult to extract, causing belt slip or motor slip. Even with a hand plunge router you have to plunge in steps to maintain bit coolness and perform chip extraction.

1 Like