Z zero off? By about 21mm?

Hi there. All of a sudden when I set my z to a particular height by setting z zero, THEN when I do a rapid to z plus 6mm, it goes to more like z plus 25mm or so? Any ideas anyone?

My bit ero version 1 also stopped working a couple of weeks ago too. Related maybe?

Which Z-axis do you have?

What Z-axis are your Machine and Grbl configurations set up for?

Go to Settings, open the Log window, go to the MDI and send $$ — check back in the Log window, what is $102 set to?

How are you setting zero? Please review: Working With Homing - Carbide 3D

Thank you so much Will. Checking all of this tomorrow. I so appreciate the help here.
I am using the bit zero version one, thought it seems there is only a drop down for version 2 in settings?

Shapeoko Z-Plus, I installed about 60 days ago or so.

I have xxl

Okay so I decided to remove my version of carbide motion from last November and reinstall the latest one from the carbide 3D website.
Everything now seems to work perfectly with the exception of the following two items

  1. My bit zero version one worked he first time I tried it but then does not work and probe failed again
    This is pretty weird as it works first time and then stopped working again

  2. So it appears I do not now have any problem with setting the z zero the rapid command to go to zero + 6 mm does not seem to be accurate
    It goes to z 0 plus .236

Guess this does not matter

I will keep you posted if I have any other issues but I wonder if this is anything to do with the fact that I’ve just started using the v-carve desktop?
As usual thank you one and all for helping what a great community to be part of

So if you set zero at an arbitrary height, somewhere in the middle of the Z-axis range, and then immediately click the ‘Z-Zero + 6mm’ (or however it is labeled) button, it does NOT move up 6mm?

1 Like

I might be misunderstanding, but 6mm = 0.236".

3 Likes

Yes indeed. I read my calipers wrong. I am sorry

Thank you to everyone. I actually learned a lot. I am so thankful.

2 Likes