Another Limit Switch Error

Hi I’ve bought a second hand Nomad and can’t even home the machine.
I have moved he parts on the rails, switched it off, unplugged the cables, uninstalled the software with no joy, I can’t use this machine.
The file I’m using is the wrench tutorial file.
Is here anything else I could be doing wrong?
Can someone perhaps advise me on a really simple file to try please?
Is there a video demonstrating how to reset the hit switch ect?
I am unable to use version 4 of the software so having to use version 3 despite using a windows 10 64 bit laptop.
Please help I’m going crazy.

What happened when you tried?
What makes you think it’s a limit switch issue? Are you seeing an error message?

The file you load has nothing to do with your ability to home/jog/control the spindle.

1 Like

First thing I would check is that the machine is showing up in device manager. When connected to the computer, it should show under “Ports (COM & LPT)” with a meaningful identity-- mine is “Nomad 883 Pro”-- even if the machine power is off, as the USB to SERIAL interface on the controller is powered by the USB cable. The controller will not respond until the machine is powered. (I am not sure if all versions will ID themselves as a device with the machine off, but it is an Arduino, so I would expect the same behaviour)

If the Nomad is not showing up, check that the cable is not bad and that the USB port on the computer is good, and all of the connectors are unbroken.

If the machine shows up, you might want to try connecting using a terminal program (PuTTY, MS terminal, whatever). The selection should be SERIAL, 115200 baud rate, 8 bits, 1 stop, no parity. The controlled does not echo back when you type, so you will want to enable local echo.

When the machine is powered, you will get the GRBL version ID, and with GRBL0.9, ‘?’ should get you a line of status information (I think 1.1 is the same). $$ will get you a multiline response with all of the GRBL variable values. ‘$’ will give a command list. If the GRBL version is 1.1, you need to use CM4. For 0.9, CM3 (IIRC… double check the docs)

If you get no response from the controller, check the internal wiring. If the controller responds well, try ‘$X’. This should unlock the controller. Try ‘$H’ to run a homing cycle. Before doing this, with the machine OFF, move the Z down a little (I carefully rotate the screw to do this), and the X and Y as well, should you so desire. The Z homes first.

You should get an ‘ok’ response (or other message). I am not sure what you will get if the homing cycle fails.

Beyond this, the possibilities expand, so more details are needed, and you might want to contact support.


Hi, yes it comes up with the error message when I try to home the machine.

Maybe you could provide more info if you want the community to help. So far the responses have been longer than the description of the issue.

1 Like

What is the error message? It is still not clear that CM is even seeing the machine or that it is properly connected (and showing in device MGR)

1 Like

We have a basic article on this at:

and c.f.,

If that doesn’t help, let us know the specific error message and a step-by-step of:

  • what you did
  • what you expected
  • what actually happened

to and we’ll do our best to help you through this.

Actually one response has been longer that the original message.
You have to bare in mind I’m a new user I will reply in detail shortly.

Here are some screen grabs of the information I am getting in the software

1 Like

Please update to CC417 — that will show the state of the homing switches

Or you can remove the back panel and see the lights.

I suspect a homing switch is stuck on – let us know what you find out and if you need a switch, let us know at and we’ll get that to you.

Hi thanks for the reply.
So to confirm, the machine is plugged in both to the mains and in to the computer, the computer happily acknowledges it’s present and it shows in the windows device manager.
When I click on the motion software on the jog tab to home the machine, after pressing this box I get the limit hit switch box pop up.
I’m not sure why but I can’t use the version 4 software as I get a grbl error so I had to use version three, version three acknowledges the machine is connected.

Okay, your machine has Grbl 0.9 and you’ll have to use Carbide Motion 3. If you want to update to Grbl 1.1 and use CM4

but you’ll need a working Z-axis homing switch — check the switches by pulling the back cover off the machine and seeing which switch is still on — if powering down and moving that axis off the switch doesn’t help let us know at

When you say back cover do you mean the back or the bottom as they appeared to be a button on the bottom, in either case there appears to be a fault.
I installed the v4 beta as suggested and got a GRBL fault, I will post a pic.
So I reinstalled version 3 and actually got some progress and the machine measured the tool,it went to spin and cut out then showed the same hit switch error as before.
I have attached a couple of pics to ensure I have looked in the right place.
May I ask if the person who sold the machine would have been aware of this fault as they said the machine works fine?

Carbide Motion 4 won’t work with Grbl 0.9 — you have to update.

Unfortunately you have an older board which doesn’t have discrete lights for each switch.

Most likely the damage to this switch occurred during shipping / relocating the machine.

Please let us know at and we’ll do our best to work through this with you.

Does updating mean having to flash the machine if I wish to update?
Sorry but I don’t understand what I need to email you for?
Do you mean to get a new switch?

Yes, you have to update Grbl 1.1 if you wish to use CM4.

I believe need either a new switch, or a new board — we’ll work this out on the support e-mail.

I’ve spoken further to the person who I bought it from and they have said the machine is only two years old and was literally working the day before I collected it.
Surely this must just be a software error of some kind?
Is my cutting area correct for example?

The possibilities here are:

  • machine is on a switch — resolve by moving off switch as noted at:
  • switch is stuck — resolve by pressing / releasing switch until it frees up
  • switch is broken — resolve be replacing
  • board has a short caused by an errant bit of metal — resolve by (carefully) vacuuming off board / otherwise resolving short
  • board is bad — resolve by replacing

Let us know at and we’ll do our best to work through this with you and get you the parts you need.

I think I am doing something wrong in the software, I have managed to reset the hit switches but one I go through the homing process and click measuring tool I get the move cutter options, then I load the job file and after a few seconds of movement I get the hit switch problem.
Is there a test file available I can use to test this as it seems I’m going beyond the boundaries and this is setting off the switch error.
This really should be programmed into software to stop this from happening its ridiculous.

Yes, see: