Anyone using XXL with Fusion 360

Are you retracting too high and losing steps? Pretty common if you have a G28 in your program.


You can pick up the files here!Aq45vfPzPdC1jTdHYo70sCLD6jTr

its retract height is .2

Do you have G28 set?

That’s most likely the issue.

Edit: Just looked at a file of yours. Remove the line G28 G91 Z0

yes But i have tried it both with and without no difference


Which setup and toolpaths are we talking about here?

Is it setup1 you’re trying to run?

FYI, initial thread here

the 2 2D pockets in setup 1

Julien my apologies I have posted on so many boards trying to resolve this. I dont remember. I’ll try and not double post in the future

Doesn’t taking that line out stop it from retracting when it homes?

No, it moves Z to the G28 location you set.


The pickup pockets on the front of the body and the neck cutout?

(I presume you deliberately set the neck cutout to be deeper than the model when you overrode the depth in 2DPocket6 ?)

Can you describe your series of actions to start the machine up, zero for the workpiece and start the job please?


You have two different length tools specified for the operations in Setup 1 but they all have tool number 1 for the post processor so you won’t get any tool change prompt and even if you have the bitsetter it won’t re-zero.

1 Like

Without looking at the file myself, this looks like the answer. Especially since you are having an unexpected depth difference of .75" which is the difference between the first and second tool “1”

1 Like

What post processor are you using that inserts TLO commands? Z-zero would remain the same for the job.

1 Like

That’s true, I don’t do TLO with my Shapeoko. I was in my work mindset. We have a machine with an ATC. TLO does not apply in this situation.

1 Like


I set my zero at the mid point and at the edge. I set the Z height to .01 from the stock. Hit Zero all then run the job. My workflow is the same pretty much for everything. I also tried a test piece Same SVG square inside a square. The inside squares is .125 deep I set Zero ran. The CC version worked fine, didn’t change zero, loaded another stock piece and ran the Fusion 360 version and it went deeper than it should have.SO I am eliminating mechanical issues. It has to be something in the Fusion gCode or offsets in Fusion. So frustrating since this isn’t rocket science. ITs not like I am a novice at graphics software I used to do Graphics for a living and I write and design software as my day job now.

I generate the g code in Fusion and select the Shapeoko post process

I use Fusion exclusively and have never had this problem you are describing.
If you select a pocket why are you then setting a negative depth, fusion knows the depth. Id this a 3d model or are you just trying to put toolpaths on 2d geometry

You would be better off using adaptive clearing vs 2d pocket, then come back with a finishing pocket

1 Like