BiSetter malfunction?

I have the Shapeoko 3 xxl and the Shapeoko 4 pro xxl. The bit setter on both, BOTH, machines does not work as it should. I’m (almost) positive it’s user error, but I’m lost on a solution. I’ve tried everything I can think of.

Issue: I run a 1/4” endmill (example - it could be any bit) tool path, when it’s time to change the bit to the 1/8” endmill for that tool path (or any bit - just using as example), it barely touches the surface OR it goes way too deep. Every. Single. Time. Both machines.

Both machines motion properly, no weird noises, no odd movements, no odd errors on screen. Nothing out of the ordinary I can see that would be an obvious problem.

Please…please, what am I doing wrong?

EDIT This is the bit setter not the bit zero. I apologize for the mistake. It’s been a long day.

There are two ways to position a BitZero, for probing at a corner, or for probing a single axis, see the instructions and:

1 Like

The BitZero has two versions. The current one is V2. Both have a lip around two sides. If you are probing Z only then the lip sits on top of the surface. If you are probing the corner then the lip hangs over the side. When you choose which type of BitZero you have (V1 or V2) that is persistent in Carbide Motion. So be sure you are choosing the correct version in CM.

I used to have two Shapeokos. One SO3 XXL and one SO3 XL. If you are using the same laptop/computer to run both machines you must send the config every time you hook up. If the XXL was used last then CM thinks you using an XXL. If the last machine used was the XL then CM thinks that is what you are using. So if you used the XXL last and use the XXL again you do not need to send the config but it is better to be safe than sorry. If you have two different models the BitSetter is in different locations on an XXL and an XL. So in addition to sending the config you must re-calibrate the BitSetter each time you change from one machine to the other. If you are using two different computers this does not apply. However you cannot swap computers without resending the config and calibrating the BitSetter location.

@WillAdams this was supposed to say bit setter not bit zero. I apologize.

@gdon_2003 this was supposed to say bit setter not bit zero. I apologize.

Most BitSetter problems are the result of changing the bit without CM ‘knowing’ you changed it.

Do you ever change the bit without hit the ‘change tool’ button first?

The other time things reliably go wrong is if the bitsetter is disabled then re-enabled. You must reset Z Zero in that case.

1 Like

@mhotchin That could be. I’ve disabled and re enabled these things a few times due to frustration. Finally decided to start asking for help. Thank you. I’ll give this a try and get back to you.

@mhotchin as for the 3 xxl, I think the issue is that I had to find the z zero separately. It’s supposed to find x,y, and z during the corner probe but it was not finding z. I ran the corner then ran a separate z. I ran a quick test and it seemed to solve the issue.

I’ll test the 4 tomorrow.