Bitrunner V2: Spindle doesn't start after bit change

Hello Community!
Title says it all. After Carbide Motion requires a bit change, my router will stop. I change the bit, the router then moves to the BitSetter. After measurements, the router doesn’t. Everything else works perfectly.

I have a Shapeoko 3 XL and I use Aspire. I save the GCODE with the Shapeoko post processor.

Thanks!

Is the enable pushbutton plugged in and active at that time?

1 Like

Yes it is. Although it isn’t recommended to do so, I tried to do it without shutting anything… To see if it would work.

Maybe double check that your file has a M3 command after that tool change (with a value greater than 1000) ? I don’t see why there wouldn’t be though.
If M3 is there, and RPM is greater than 1000, and everything is plugged in, and spindle enable button is lit…then it should start, especially since it stopped the router (and therefore started it correctly the first time?)

1 Like

Thanks! I will try in the morning and keep tou posted.

Here is where there is a tool change. I have a M6 line, but not a M3 line.

Could this be my issue?

Yes, what post-processor are you using?

It should be “Carbide 3D Shapeoko” under Edit | Select Post Processor EDIT in Carbide Create.

image
I am using “Shapioko (inch) TOOLCHANGE” post processor.

Any idea where I can find the Carbide post processor?

Didn’t realize you weren’t using Carbide Create, see:

**My BitSetter is working great. No issues at all. I recently purchased the BitRunner. Everything works OK. The router will start automatically at the beginning of the job and will stop at the tool change. When I change my tool, and hit “RESUME”, it moves to the BitSetter, mesures the new tool, but then, the router doesn’t restart. **

Please send that file in to support@carbide3d.com as well as photos showing how your BitRunner is wired up and what the setting is on your Spindle Remote if you have a v2 and we’ll do our best to sort this out with you.

Thanks You! I will do this this PM

Missed that you’re using Aspire — please test this functionality w/ a basic file in Carbide Create first — if it works there, then send the matching file from CC (both .c2d and .nc — for Aspire, send the source and the G-Code as well) and also let us know which post processor you are using.

Ive ran in to something similar using vcarve and it was because i had rpm set to zero. Make sure your tool in aspire has a rpm setting.

1 Like

That’s what I though also. I have checked and it does have a RPM set.

The issue is really that the SHAPEOKO Post Processor for Aspire is not generating a M6 line in the GCODE.

That’s why the link I posted notes one needs to either edit that post processor or source one which is so enabled.

Problem Resolved! I found and downloaded a Post Processor (same name) but it must have been updated. Now, everything works!

Thank you guys for your time!

3 Likes

I would like to note: use the Shapeoko MM post processor. Using the inch may cause some errors. :slight_smile:

1 Like