Vcarve Pro and Post Processor

@Beaucejim Can you try the one I posted a few posts below the one you quoted?
I missed that you used the original version.

I see the mm version being updated, do you have an inch version also updated or are you waiting for the bugs to be ironed out? I’ve been using the inch version but my Bitsetter should arrive Friday if it is not delayed.

Do you mean the grbl mm file?

Yes, that one…

I’ll do some testing tonight, and then I’ll probably throw them on GitHub. I’m losing track.

1 Like

Alright, I’ll try it. . .

1 Like

Still not tested with the BitSetter.

EDIT: Tested the Grbl mm TC…works with the BitSetter as hoped. It will ask you to turn on the router after probing the BitSetter.
They will also correctly list the first tool in CM.


Thanks I will test after I’ve received the Bitsetter. Unfortunately, I’ve had a small mishap and I’m on crutches so it will take a bit longer to get in the shop.

I see what you did there. :wink:

Hope you’re ok…crutches are no fun in the winter. Get better soon.


Hey Neil, just wanted to let you know your macros and pp are working well with CNCjs and the bitsetter in VCarve Pro 10. Thank you for your hard work!

Oh yeah, lovin’ the triple tap, super accurate.


I can report that the new PP also turns on and off the spindle via gcode also. The first version didn’t restart the spindle after a tool change. That is of course if you have the add on equipment for auto spindle control via gcode .


Just want echo the others/ Finally got to use the new PP @neilferreri put together. It work awesome.
Thanks a ton man!

1 Like

@neilferreri I downloaded the newest file and tried to install in VCarve, it said error line 7

I did not have this problem when I loaded the last one. Maybe I’m doing something wrong.

When do you see that error? I don’t use V-carve much, but I’ve never seen something like that.
Are you just putting the pp file in your posts folder?

I get the message when I try to install the post-processor using the menu in VCarve. It asks me the file I want to install, I pick the file where I downloaded it.

This happens to me almost every time i move a new post to the mypost folder. The only way i have been able to resolve it it to uninstall and reinstall VCarve. Its a pain! I also noticed if you edit a post from that folder, not even change anything. But just save it it will give this error for every post you save from then on. Till you uninstall.

1 Like

Hmmm… I’ll look into that later. Did you try just copying the file into the folder?

No I didn’t, I use the menu function. I will look at it, maybe I have to remove the old one before I install a new version

I’d like to find a solution that does not require uninstalling and re-installing VCarve.

OK, I found a tutorial on installing PP for VCarve that does it by manually copying the file into the PostP folder and I did. I will not be able to test tonight.

Neil, Just to be sure I did not mess up, I did a right-click on the Grbl_inch_TC.pp file on Github and saved it on my computer, I don’t see a download icon. I notice the file is bigger (105kB) than the rest of the PP (5kB), since I don’t get stuff from GitHub often, maybe I did not import the right thing and it is messing things up.