Bitsetter fails more and more frequently

I put this in unsupported because I am using a non-carbide3d controller, with non-carbide3d macros. And CNCjs. It’s been working fine for a year or so.

My Carbide3D corner probe works great.

My Bitsetter has progressed from sporadic failures to 90% failures. Regardless of cutter size or configuration. It fails when running Initial tool and New tool.

The button is free in the bushing. The limit switch triggers manually. See what happens when probing:

Try as I might, I can’t reproduce the flicker manually even when dropping Z by .001 mm increments.


EDIT: Butsetter, lol.


I have no idea if this would help, but it is something to try. This weekend the button in mine just came loose (poped up out of the housing). I took it apart (3 screws) and the inside was rather simple. Put it back together and it worked great.

Maybe take a look inside and see if anything looks off? Probably a long-shot but it’s not much effort.

A weird one @Griff! Are you getting a probe error on these?
Which controller? How do you have the probe and ButSetter hooked up?

When it does the flickery thing, if you manually depress the button does the LED light normally?

i.e. is it bit height or button malfunction?

Something else is going on because it’s not retracting or continuing…the probe error means it didn’t reach the probe in the specified distance.

1 Like


XPro V4

The breakout board from C3D…I think. It’s been awhile.


Which, based upon my shaky understanding of how a prox switch works, suggests a software error(?) haha, me diagnosing software errors, pay no attention.

1 Like

The switch should light up regardless of software. The led will light up as long as it’s powered and there is metal close to it.
This sounds like an electrical problem. I’d start by checking wiring, then eliminate the splitter PCB from the equation, then try a different prox switch.



But, the switch lights 100% of the time when manually pressed. Except during a failed probe, when the led stutters.

I’ll see if I can find another prox switch.

Is it repeatable?
Can you try making the probe distances longer?

Changes in BOLD:

G38.2 z-10 F40 ;“dial-it-in” probes
G4 P.25
G38.4 z20 F20
G4 P.25
G38.2 z-10 F10
G4 P.25
G38.4 z20 F5
G4 P.25


What length(s) of tooling are you using when you have trouble probing?

I had a weird issue like this when my aligator clip also touched my normal probe… that sort of “shorted” the bitsetter and the result was not pretty.

worth checking if your Z probe is not making contact


Yup…eliminate it from the list of variables. Along with the splitter.

1 Like

the splitter board touching the enclosure and shorting that way… also a fun but known failure mode indeed


FWIW, when I installed my BitSetter/BitZero I wrapped the loose adapter board in a length of “Ranger band” (a cut-off from a bicycle innertube).


Oh man, that brought back some memories! :smiley: Nothing I can talk about here! :smiley:

Exchange the switch with a known good switch, THEN start troubleshooting if there is still a problem.


No clip, spindle is grounded.

Standard, 1 1/2” to 2 1/2”. Printed a case for the board.

Will try this later today.

1 Like

and just to make sure, your Z probe is for sure not making contact with anything metal?

(reason I’m asking is that the Z probe and the bitsetter are basically wired in parallel, and the way “touch” is measured is by the resistance across the two wires into the board going very close to 0… any kind of short will also cause that same behavior)

1 Like

Appreciate the input, def a thing to check. Z probe in a plastic pocket stuck to wood😊, double insulated if you will.

“Wow, it worked”…to quote myself haha. At least thru 5 cycles so far. Will keep you posted.
THANKS yet again @neilferreri!

1 Like