BUG - Windows screen scaling & font rendering

Projects that are opened on computers with different screen scaling settings do not render the same.

My ‘main’ computer (desktop) renders at 100% screen scaling. My portable (Surface Pro) renders at 200% screen scaling. Both are the recommended and default settings.

I noticed this because I’m using two computers, but you can repro this just by changing the Screen Scale and restarting CC.

Fonts render differently depending on the screen scaling:




This topic was automatically closed after 30 days. New replies are no longer allowed.

I wasn’t able to replicate this on my machine:


Carbide 3D_150.c2d (480 KB)

which views as expected when initially created at 150% screen scaling:

(there is text, and a copy of the text converted to paths)

quitting, changing to 225% and re-opening CC and that file yields a similar appearance:

This could be a problem with font versions, or platform differences, or font versions/implementations (I specifically chose one of the fonts bundled w/ Carbide Create) — could you post a file? (it may be that it was fixed in an update)

OK, so after digging around, maybe this isn’t a problem. I can repro the bug with this one file.

It’s a V6 file, and it seems to have some problems with it since if you double click on the text, it brings up the text properties box, but with default text instead of the actual text.

I made a simple V7 file that worked OK.
Rat Ring.c2d (2.7 MB)

Font handling changed between v6 and v7 — sizes are different due to the different text objects used.

I know that text could change size depending on CC version (V7 could show a different size than V6).

For this file, using only V7, if the screen scaling changes, then so does the size of the text.

When I open this text it shows as:

If I close Carbide Create and change the scaling to 225%:

It’s still the same size, to 3 decimal places.




It’s like there’s a maximum size, going bigger than that doesn’t change.

OIC. The size doesn’t scale with the scaling, it’s correct at 100%:

and 125%:

but then jumps to the wrong size at 150% and is that size thereafter:

Shades of a bug in Quark XPress where text might or might not fit in a text box — that was an expensive learning experience for a company I was working at.

Will test further and file a bug report.


This topic was automatically closed after 12 days. New replies are no longer allowed.