Carbide Copper holes off of PCB

So, my first test with milling a PCB this AM started OK - traces and footprints are located where I expected, and the Z offset seems to be perfect. But when I switched to my 0.9mm drill to start on the holes, the spindle went into outer space. Looking at the Carbide Copper preview, the holes aren’t anywhere near the traces, and the scaling is all wrong. It even drilled outside the 4x6" stock size that I gave it.

I’d be willing to bet that somehow it’s scaled 25.4x, and it’s milling in mm but drilling in inches. But I only see one place to set the units in Carbide Copper, so I don’t get how they can be different.

Any thoughts?

Assuming your PCB package is exporting Excellon drill files, these can have varying number of “decimal digits”. You may need to adjust this in your PCB CAM before importing to Copper to get the correct factor of 10. In Eagle this would be EXCELLON EXCELLON24 or EXCELLON26 etc…

I’ve not received my Nomad yet so I’ve not been able to try Copper yet, but I have witnessed this when viewing Gerbers and Excellons overlaid in Gerbv.

I may try that, but Carbide provides a “” file to use when creating the export from EagleCAD. So I figured that it would set all of the units and sig digs correctly. But maybe a different Excellon export will do the trick until they edit the settings file.


Take a look at this post from a Cadsoft employee back in '16 , the problem is not unknown.

1 Like

Thanks - I did manage to get everything to line up if I manually export the drill as “EXCELLON_33MM”.

@WillAdams I think this is a bug in the interface. Even though I used the CAM file provided, and selected mm as my units, only the top copper and perimeter codes were set to mm. The Excellon for drills was exported incorrectly.

Also, another bug - Since my traces were cut correctly, but now I need to drill holes, I re-exported with the new format, and saved files separately. My goal was to just run the drill file. But when I did, the spindle never turned on, and the bit crashed hard on my copper. Not sure why this happened - the first run, when all files were combined into a single G-code, the spindle came on (although it drilled off in outer space).

Is this something that can be addressed soon? I ordered bits in mid-Feb, got them yesterday, and I’m still not making PCBs as I had hoped.



Please write all that up and send it in to

OK, but to get me moving - is there a “backdoor” way to force the spindle on? I tried turning it on in the JOG menu, but it shuts back off when I run the drill file. Can I insert a G code instruction or something to make the spindle turn on at the start of the drill file?

Circling back with a solution…
@WillAdams tagging you to let you know I emailed support. All others, see below for workaround…

Using the CAM file I downloaded didn’t work (described above). But manually creating the export with Gerber 274X (for top copper/pads and board outline) and Excellon_33mm for drills & holes did the trick. So for anyone having trouble milling boards created in EagleCAD (and maybe just if working in mm) try these settings.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.