Carbide Create 400 Beta

(Rob Grzesek) #1

The details are at:

https://carbide3d.com/blog/2019/carbide-create-400/

This should be the first of many updates in the coming months. (The next one should even make @RichCournoyer happy, even if only a little bit)

6 Likes

(William Adams) #2

FWIW, I really wish that asymmetric scaling of text had not been added — far better to use a typeface family such as Univers which has a suitable width/weight, or, if supporting it, limit it to only typefaces which have a weight axis such as Myriad (and add support for Multiple Master fonts).

For folks who are curious about the underlying typographic reason for different fonts being different sizes when set to the same nominal size see:

EDIT: very, very glad to see the improvements to the curve tool — makes things a lot more workable now.

Will there be a formal definition of the file format?

1 Like

(Julien Heyman) #3

“look for lots of changes in the near future”
Come on, please give us a glimpse of the release roadmap, no one will judge if you don’t stick to it perfectly :slight_smile:

0 Likes

(Nathaniel Klumb) #4

Or at least an informal one? Anything that makes it more convenient for me to update the Inkscape C2D import extension and MergeC2D utilities would be appreciated.

Of course, if updates to Carbide Create make it so you can import an additional file or files into an open workspace, the MergeC2D utilities would be rendered obsolete. I for one would welcome that project becoming superfluous, as the feature would benefit all users of Carbide Create. (The Inkscape C2D import extension will still have its strong use case.)

2 Likes

(Dan Nelson) #5

FWIW I gave the new beta a try a couple nights ago and it seemed to work really well (for drawing at least, I didn’t actually carve anything). The whole GUI seems a little snappier, like it doesn’t bog when editing/adding tool paths. This could all be my imagination, but it “felt” better. I still use Vectric VCarve desktop for most of my stuff, but sometimes I like to use CC for some profiles outside the 24x24" Desktop limit. Never can have enough tools!! Good work guys!

Dan

2 Likes

(Rob Grzesek) #6

Thanks Dan. We had to make some internal changes for the “Aztec Calendar” files and I think those changes ended up helping out a lot overall. VCarve is a great program but we’d like to keep making CC better so that you don’t need to use VCarve anymore. (That’s going to take some time but we’ll keep at it)

@ClayJar - Regarding the file format, it’s not a big change but the control points for curves are different now and they actually match the way SVG paths work. CP1, CP2 are now the control points that lead into the current point, not the control point immediately before and after the current point as it was prior to 400.

@Julien - You can always check out what we’re working on at https://carbide3d.com/carbidecreate/unstable/ . I suspect we’ll have an export to SVG before too long and more options for text shaping.

4 Likes

(Peter H) #7

Hi, I do not know if this is the right place to highlight a bug in the 400 beta.

It seems as if CC400 is not able to save changes in the tool library. Her is what I did:

  • I use Windows 10 64bit
  • open CC 400
  • create a rectangle
  • add a tool path (outside)
  • edit tool library and add a new endmill
    Type: flat
    Description: 4x11 ebay
    tool #: 1
    diameter: 4mm
    flute length: 1mm
    flutes: 2
    OK
  • new endmill #1 is at the end of the list
  • close dialog
  • select “#1 - 3.999 mm End” as tool
  • close dialog with OK
  • Save project
  • close CC
  • open CC again
  • open project again
  • select toolpath
  • selected the tool path and open it by double cklick
  • Tool which is shown is: “#1 0.157in” (even if mm is selected)
  • click on “Edit” for the tool
  • In the pull down list there is no tool #1 anymore, only the default ones
  • Click “Edit Library” and got the same result, no tool #1

I did this 3 times with the same result.

0 Likes

(William Adams) #8

I was able to add a similar tool — do you have write access to the file?

Try 401 which is available as Unstable?

https://carbide3d.com/carbidecreate/unstable/

0 Likes

(Peter H) #9

Ok, now the funny thing.
I tried again, this time I used the tool #13 which is created if you add a new tool.
I start CC 400 with admin rights. Same thing.
I had a look into the registry after closing CC 400:
HKEY_CURRENT_USER\Software\Carbide 3D\Carbide Create\tools
@ByteArray([
{
“angle”: 0,
“corner_radius”: 0,
“diameter”: 4,
“display_mm”: true,
“flutes”: 2,
“length”: 11,
“name”: “4x11 ebay”,
“number”: 13,
“overall_length”: 0,
“uuid”: “{24167ef0-2da0-4a38-9bf4-41f4740ff4cd}”
}
]
)

So tool is in there.
Starting CC again without loading any file, creating a rectangle and adding a toolpath.
-> #13 is not in the lib, even if i saw it in registry before.
Now I closed CC without saving the project

@ByteArray([
{
“angle”: 0,
“corner_radius”: 0,
“diameter”: 5,
“display_mm”: true,
“flutes”: 2,
“length”: 11,
“name”: “5x11 ebay”,
“number”: 14,
“overall_length”: 0,
“uuid”: “{67b8e3f2-ee30-4dfb-b0e5-a001340973a3}”
}
]
)

#13 is out, #14 is in.

0 Likes

(Peter H) #10

With 401 it works as expected.

1 Like

(William Adams) #11

That’s great to hear!

We’ve been trying to test 401 and have a fair number of bug reports thus far — any testing / observation folks can make would be welcome.

0 Likes

(Luc) #12

I have not tried 401 yet but I understood that in the new version 400, if you wrote some text at 1.5in high, it would be consistent between two separate lines of text but it isn’t the case when I try this in 400. Did I misunderstand?

Edit: 401 works fine, I was able to write two lines at 1.5in with the actual same text height great!

1 Like

(Luc) #13

OK this morning I opened the file I had created in 401 and I cannot edit the toolpaths I had created; they will not open. I can disable them but can’t open the toolpaths to check out the cutting info. Has anyone experienced this issue?

0 Likes

(William Adams) #14

Please send the file in to us at support@carbide3d.com — I had that happen with one file and we could use more examples for the developers to look into.

0 Likes

(Jerrod Zachary Williams) #15

Has anyone had problems with the z axis when beginning a job? After i set my zeros and go to start a job, the first thing that happens is the axis tries to run up past the limit switch, skips a tooth on the belt and then stops. This happened two times in a row.

My zero was set well below the limit. And my retract height, at the usual 10mm, was also well below the limit.

I could be doing something wrong but i am not sure as to what.

0 Likes

(William Adams) #16

Usually such issues are mechanical: https://wiki.shapeoko.com/index.php/FAQ#Mechanical

0 Likes

(Jerrod Zachary Williams) #17

I hadn’t had this issue before the 400 beta. My instincts tell me the new beta software didnt mess with the hardware.

0 Likes

(William Adams) #18

Please post the .c2d file and the generated .nc file here or send them to us at support@carbide3d.com and we’ll try to look into it.

The vertical movement is defined by Job Setup (gear icon) | Machine | Retract Height — which needs to be less than the travel of the machine from top of machine working area to surface of zero.

0 Likes

(Jerrod Zachary Williams) #19

I understand about about the job set up and retract height. I have never had this happen to me before.

I will send the files when i have more time (Today is Mother’s day).

thx for your efforts

0 Likes

(Luc) #20

File sent to support

0 Likes