Carbide Create 431 install problem

Hello all. I just downloaded ver. 431 and installed it. when I first ran it I received an error msg. Procedure Entry Point GetSystemTimePreciseAsFileTime could not be found in Dynamic Link Library KERNEL32.dll

I am running windows 7pro on an alienware desktop.
any help with this is greatly appreciated.


Please try build 432 at:

1 Like

That worked great. Thank you

1 Like

Not for nothing but I just had this same problem. @robgrz you guys may want to remove build 431 from the Carbide Create Download as the error will not allow the program to actually open. Not a good look.

The problem is specific to Windows 7, which is EOL in 123 days or so.

Anyone running Windows 7 should be planning for this and ready to shut down any machine running it which is networked in any way.

lol… Funny. I think I still have a windows xp laptop around here that I still use occasionally. So I guess C3D team was just ahead of the curve by releasing software that cannot run on Win7. Unfortunately the download page still shows this as useable for Win7. Just revert it back to 430 or update it to 432 on the download page. Why any company would want to market free software then it fails to work?

1 Like

I am not defending software that does not work but in defense of Carbide 3D there are a lot of variables in producing software. They include Operating Systems, software updates or lack of current software updates, customization by customers and a lot of other things completely out of the control of Carbide 3d. There is clearly a work around to these issues with Windows 7. I used to work in support for Oracle and I can tell you there are so many variables that a software producer cannot cover every situation there is that is available. However I feel Carbide 3d tries to do the right thing and seem to fix issues rather quickly. Windows 7 is ancient and should be updated before the end of life. After the end of life there will be no more updates and makes your machine a target for bad things to happen and those bad things affect everyone on the internet potentially. As the old blues song says " If you want to be boss you gots to pay the cost". So if you want to play in the CNC Game there are certain costs and responsibilities you must keep up with.


anyways… the point being made for those that took the time to read: version 431 fails to load properly in windows 7. All the 400 versions prior to 431 and the version after it, worked on windows 7. The page where you officially download the so-called stable version shows 431 as the version available and the system requirements still shows windows 7 as being an acceptable operating system. Creating software is difficult - no question about it, especially free software. No one was arguing that point. And yes, there are things that will be completely out of Carbide 3D’s control. Again, no one was arguing that point either. The situation in question though is completely within Carbide 3D’s control and ability to resolve. The version available to the public (unless of course they have fixed it within the last month) does not work for windows 7. They have the ability to rectify that easily by either posting an older version or making the last beta the stable available for the public. But in any case, it was a suggestion for the company to fix a small issue that seemed pretty straightforward to solve, but instead it appears to be ignored, and the only replies are: windows 7 is antiquated and its the user fault for not upgrading their laptops. :grinning: :man_shrugging:

Hi I cannot find Build 432 on your download site as recommended by Will Adams.


Since I posted that, we’ve updated the unstable testing version to 433 — it should still run in Windows 7:

Thank you Will



that did not work it came up with missing .dll files errors. I have located the file and installed it but still no go. i am running windows 7

regards paul

For missing DLLs please see:


i uninstalled the program and reinstalled and i now get this error.

Carbidecreate.exe Application error

The application was unable to start correctly (0xc000007b). Click OK to close application.

i have also done as below.

How do I fix error 0xc000007b?

How to Fix Application Unable to Start Correctly Error (…

  1. Method 1. Restart your computer. The first thing to try is restarting Windows. …
  2. Method 2. Update .NET framework. …
  3. Method 3. Enable Administrator rights. …
  4. Method 4. Reinstall the app or game. …
  5. Method 5. Update Windows. …
  6. Method 6. Run ChkDsk. …
  7. Method 7. Reinstall DirectX.

Restarting again

Try a new account with admin privileges?

If that doesn’t work, contact