Carbide Motion 414 Worse Than 412


(Stephen Kidwell) #1

So I noticed maybe last week or the week before that Carbide Motion 414 was finally released and that it was showing that it fixes the G91 errors, which I was prior fixing by posting a job specifically in metric. So I figured great this is good news.

I installed it and in the period of using it for 1-2 weeks I have had at least 15 software crashes like COM port errors saying the machine is basically disconnected to starting a job fresh this bright monday morning to once I hit the button to continue after the Tool Change menu of starting a job it says “Limit Switch Hit” and closes it out…

Maybe I am crazy for staying on the CM train because I like how easy the interface is to understand and there most alternatives have a learning curve I just don’t want to take the time to learn but this update has made life harder. Anyone else having issues with CM 414? Any fixes you found?


(William Adams) #2

If you can find a repeatable crash, please send in the file in question and instructions on triggering it to support@carbide3d.com and we’ll try to have a developer look into it.


(Tom Holgate) #3

I am having the same issue. It doesn’t give me an error it just shuts down Carbide Motion. I went back to the older version and have no issues.


(Stephen Kidwell) #4

Where did you find the old version to download? I had thought about doing that myself.


(William Adams) #5

For folks who didn’t save the installation archive, here is a link to Build 412 in a Google Drive:

https://drive.google.com/open?id=1iYoC_mdqoBEIUGvAg0Fedi3msyqebdVo


(Temujin Kuechle) #6

Is there a Mac version of 412 available? thanks.


(William Adams) #7

Yes:

http://carbide3d.com/dl/cm/stable/CarbideMotion-412.dmg


(Temujin Kuechle) #8

Thanks, Adam. I appreciate your archiving the CM files.
It turns out that I had to erase the older version, not just leave it in the trash, to reinstall and get CM 414 running.
I also restarted the XXL again. It seems to be behaving.
I hope to get it running this week.


(Tom Holgate) #9

Has anyone figured out this issue? Going back to 412 has worked. But what is happening with 414 issue? I tried my other laptop with the 414 and it also just shuts down with windows trying to resolve the issue. No alarm code generates on Windows 10 or Windows 7.


(Rob Grzesek) #10

I just went through the code changes for the last year and there’s nothing changed in the serial port / COM port handling at all so there’s shouldn’t be anything that triggers additional disconnects.

The only real change in 414 is the fact that G2/G3 arcs are evaluated when the gcode is loaded to make sure that GRBL won’t choke on them when they’re sent down.

So here’s my question:

  1. Is anyone having a repeatable crash when gcode is loaded? ( This could happen if there’s a bug in the new 414 arc code that we missed)
  2. Are there any other repeatable crashes that you’re getting that can be triggered reliably?
  3. If you’re seeing that CM “Just shuts down”, what exactly was happening right before that?

Finally:
If you’re on a Mac and get a crash, please generate a crash report and send it to us to review.

We’d really like this software to be a bulletproof as possible so if there’s a bug we can duplicate, we’ll do everything we can to eliminate it.

-Rob


(Stephen Kidwell) #11

Well oddly enough ever since I posted this article I have not had any issues since. I am still on 414 but the issues I was facing was the system will disconnect and show 3 error messages, one of which was the bad serial or com port. I will post a screenshot of it if it happens again.


(Stephen Kidwell) #12

Ok go figure. Why does this always happen to me… SMH! I JUST posted I have not had any issues since but I start my first job of the day and boom:


(Stephen Kidwell) #13

It is also worth noting I fixed this above issue by doing what I always did with version 412 and selecting “millimeters” for the Unit measurement when posting from Fusion 360


(Neil Ferreri) #14

What post are you using?


(Luc) #15

I’m still using 4.12 on my Mac and there is a minor bug that occurs when I load a new file after one that has been used to carve another part. I load the new file but the name and info do not change on the screen until I go to run the new job. The new name appears in the run file window. If I return to the load file window, the name will have changed.

As a result, you are not sure if the file has loaded without exiting the file window and go to the run window. Maybe this is by design but it bugs ME.

Since apparently nothing but the arc has changed in 4.14, I will probably have the same issue with the new version.


(William Adams) #16

You can right/control click in the window and choose reload (or refresh?) and it will update.


(Luc) #17

OK thanks, there is a workaround but I wonder why this is not done as part of the load command routine. Maybe I’m weird but I expect, as a visual confirmation, that the new name appear when you load a new file.


(Stephen Kidwell) #18

So I fixed that last issue by using millimeters for the unit measure in Fusion 360 and the job completed successfully. I went to jog the machine to load a new end mill and make some cutouts and I found this


(Stephen Kidwell) #19

and this is what I see if I hit Connect To Cutter if I DO NOT power down the CNC and power it back on first. If I turn it off and on it comes back with no issue:


(Rob Grzesek) #20

Can you send me that gcode?