Carbide Motion 505 Beta

We just uploaded the next big revision to Carbide Motion, Build 505, to:

We tried to keep the UI as close to the 400 series as possible but all of the UI code is brand new so it might be a little wonky still. We’re no longer using the embedded web interface like the 400 series so this version should be more responsive and more maintainable going forward.

The biggest immediate benefits:

  • Better touch screen jogging on Windows
  • Unlimited gcode file size
  • Settings page should be more clear and bug-free
  • Persistent UI units (inch or mm, in the Settings page)
  • Faster start-up
  • Updated Shapeoko configuration makes the machine much faster.

Other than that, the function should be almost identical to the 400 series.

Be careful running this build and keep your hand on the power switch until it’s well-tested.


Awesome update Rob! The speed is nice.

However, the “load new tool” button seems to be unresponsive in the Run section.


Do you have BitSetter enabled?

EDIT: Nevermind, I can confirm that the button broke at some point

EDIT 2 - 506 just uploaded for @Vince.Fab bug report


>> We’re no longer using the embedded web interface like the 400 series

This bit is awesome, this bugged the heck out of me – especially when using monitors with different resolutions

1 Like

A couple of things I noticed. (On 505)

  1. The load file dialog only allows for two file extensions, and of course I am using some other GCode generation tools that default to a different extension. Maybe you can allow a “.” search in the dialog as well? Leave the default to the 2 that are there already.

  2. My laptop wants to run at a 1920x1080 resolution with the “Size of Text and App” set to 150%. When I do this there are screens (at least rapid jog and settings) that do not fit on the screen and you can not scroll down to the non-displayed area. You are just locked out. (At least I was when the app was maximized)

  3. I liked using the gcode sending log while other operations were being run in Carbide Motion. This allows me to learn what the gcode commands really do… Now it is always on top of Carbide Motion and there is no way to stop and start the logging. It’s harder to use.


Can you share a screenshot? Hi-DPI and scaling have been a nightmare

1 Like

Here’s a couple of screen shots. No way to scroll to the hidden areas.

Got it. I’m not sure this one is something we’ll be changing in the short-term.

Because Carbide Motion is meant to be a “control panel” for the machines we make, we’ve scaled everything to be easier to view at arms length. If you have an additional 150% and don’t have a large monitor then it might be a problem because the application is effectively double-scaled. I think you might have to right-click on the Carbide Motion program icon and pull up the settings to disable the system-wide scaling for this app.

No Problem. Even with 431 I’ve been scaling back to 125% to get at everything. Any thoughts on issues 1 and 3?

#1 is something we need to discuss with support. We’ve got a very broad user base and I think we’re better off with fewer, very well defined extensions for gcode to keep confusion to a minimum. If you have another extension that is commonly used only for gcode then we’d be more likely to consider adding it.

#3 - The log should not be on top all the time, we’ll have to look into a fix for that.

Is 506 the active one to download? It still says version 505 currently.

Whoops- forgot to move it to beta. We’ll get 506 up tomorrow morning.


Hey Rob… I know you probably have heaps to do with CM using a new UI framework etc. But… if you could sneak in a tiny tiny modification such that the estimated duration (ie: 210 minutes) appends the ETA (ie: 201 minutes - 13:47) that would save me literally seconds of mental arithmetic (yeah, it’s minor… but hey, one has to ask :slight_smile: )

1 Like

Just curious. Are you using QT? I have some first hand experience in fixing a number of high DPI issues.

@robgrz I can confirm scaling issues on Mac, also look at X+ and Y+ on the jog screen. Problems go away when I go to full screen… so that’s interesting.

Also do you have a list of new hotkeys? num pad + - are not working for my Z.

506 is posted to

That “Time Remianing” field should be working on the “Run” screen. Are you looking for something different?

Yep, Qt. So far, we think everthing is working on the native code. QML and the embedded chromium window (both have now been purged from the code) scaled very poorly.

Do you have additonal UI scaling turned on in the operating system?

@robgrz Nope ‘default for display’ here’s two more odd things.

When Clicking Z+ with the mouse I had the software display the Z+ as persistently pressed with “Busy” flashing intermittently at the top of the screen. Z did travel in the + direction until it hit the limit switch. clicking anywhere in the UI released the Z pressed condition. I’m trying to replicate it so I can grab video but so far no such luck…

Also this is a bug. When I ‘zero all’ my Z will not zero. Here is the procedure to replicate it with pictures.

Set an arbitrary zero, then, Rapid to NE

Next move to another arbitrary position X,Y,Z in this case -35,-34,-49

Now go to Zero and you see this (EDIT Clicking clear offsets seems to work sometimes? ) :

After ‘Zero All’ the new coordinates look like this. I also get the same Z regardless of actual Z height.

Any chance we will get hotkeys for the rapid position points?

1 Like

Very good odds on many more hotkeys being added. What do you like as the hotkeys for rapid positions (other than the numeric keypad)?