Carbide Motion connection drop

Hey there, looking for some guidance. I have been losing connection with my machine during the middle of a job. It will lose connection, just stop in place. I hit the button connect to cutter and the error no grbl file and cutter cannot be found. I uninstalled and re-installed the software, have unplugged everything multiple times, blown out all of the ports with compressed air, and nothing. The computer I use is designated for my CNC only.

Anyone else having the same experience?

Write in to after doing an “air job” where you run the file w/o turning on the router or dust collection and no stock in place and zero set a bit high — let us know how that turns out and we’ll walk through this with you.

Check the brushes on your Router.
Is the machine grounded?

I had that issue on my SO3XL, new brushes in the router helped. Static electricity can cause this issue.

1 Like

Thank you I appreciate it

Static was the culprit for my issues. I got a new anti-static hose (expensive, but it worked) and grounded my metal cyclone dust collector housing which was located close to the controller. After that, I’ve had zero issues.


Static…have to ground dust collector properly.

I had the same problem and solved it without going through the hassle of grounding the hoses.

First, I made sure that my dust collector was on the left side of the CNC and ran both its and the router’s cord to an outlet off to the left. The CNC’s power and USB cords run off to the right, along with my computer, so the only cross-over point is where the router’s power cord enters its drag chain, which leads it directly over the data run.

Second, I added a bungie above the table to suspend the dust collection hose so that it doesn’t touch the left rail.

After doing those two things, I have not had a single dropout.

Good Luck!

1 Like

Thank you it’s appreciated

Thank you it’s appreciated. I have grounded the dust collector and hoses with copper wire. I replaced the brushes in the router and that fixed it


I followed this. Worked for me.

Grounding your Shapeoko - CNC Machines / Shapeoko - Carbide 3D Community Site

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.