Carbide Motion issues getting the Default Settings from arduino "SOLVED" but created a new problem

Ok, I am trying to fine tune my SO3 (ser# 508) and I used Carbide Create (not a create question) and design a .250 wide and .073 deep pocket. So when I load the gcode in motion, and then cut it, the .250 wide pocket is .490 (or there a bouts) in size. I have found out how to open up the log screen (press l) and then to open up the mdi prompt (press m). To get the data (default gerbal settings) out of the arduino, you then type $$ at the mdi prompt and press send. When I do that, nothing happens. I am on a Mac, OS 10.8.5 Running Version 2.0.350 Carbide Motion. I am just confused about this. Any help will be greatly appreciated.

@buhmiller, all I can say is those are the correct steps that I have used in my Windows installation of CM as of 2.0.349 (which I think corresponds to the 2.0.350 Mac installation).


Answered on the ShapeOko forums, where I suggested trying a different program, or computer if possible — also a cable? (Seems a long shot)

Might be that clearing storage on the Arduino or re flashing would help.

Be certain to contact so that they can be made aware of such difficulties and either document their solutions or know how to avoid them — they’ll need all the specifics of your system.

Thanks @Randy @WillAdams, I loaded Motion on my PC running windows 10. The “l” and “m” worked fine and displayed the default information.

@WillAdams I went back to my Mac and installed 10.9.0 (Mavericks) and tried it again and was successful. I think the issue was I was using a USB hub and the arduino didn’t like it. I went back to the partition that had 10.8.5 and had the arduino directly connected to the computer and I was able to get the default settings from the Arduino using the “l” and"m" commands. So as I have time, I will test with 10.10 and then 10.11 to make sure I can get it to work as I was having issues with 10.11 in getting the “l” and “m” commands to work.

I will test with 10.10 and then 10.11 to make sure I can get it to work as I was having issues with 10.11 in getting the “l” and “m” commands to work.

I’m running 10.11 (.1 and .2) on a desktop and a laptop and CM works fine - ‘i’ and ‘m’ commands too.


Thanks Mark. My issue now that I try again with 10.11.2 is that Motion Crashes Every time I start it or try to connect.

Now that machine was an upgrade to 10.11.2 as opposed to a clean install. I am doing a clean install on a test partition and will see what happens then.

The partition with a clean install of 10.11.2, motion crashes constantly. The partition with 10.10.5 was a clean install and Motion loads, I can connect to the SO3, but I can’t move the SO3 nor can I use the “m” command. I am going back to 10.9 and go from there.

The partition with a clean install of 10.11.2, motion crashes constantly.


My Mac Pro and MacBook Pro both run CM flawlessly.


Here is a short synopsis of the new problem.

I have had my S03 up and running and was in the final stages of getting it tuned up. I was using the beta version of Create to test and was able to design in create and then send to motion to mill. I was having issues with Motion crashing on my Mac Pro Tower running 10.11.2. So I was able to use my MacBook Pro running the same software 10.11.2 and was able to cut a test circle. The test circle I designed was .250 in in diameter. When it was cut, it was almost twice the size as designed. So I wanted to get the cutting correct, so I wanted to be able to find out what the default settings were, to make sure everything is correct.

So I found out about the “l” and the “m” command. I wasn’t able to get those commands to work on my 10.11.2 mac os machine, so I set up a hard drive with 4 partitions for 10.8, 10.9, 10.10 and 10.11 so I could create a clean install of each OS and then see which version it would stop working.

So 10.8.5, it worked fine (motion) , I could connect, and control the gantry, the “l” and “m” commands worked.

10.9.x same as above

10.10.x I could connect, control the gantry, but no log or mdi input

10.11.2 I could connect, control the gantry, but no log or mdi input

Windows 10, It connected to motion, controlled the gantry and “l” and “m” commands worked.

Then I went back to the mac machine and tested again and now motion still connects, but the log window says testing and no MDI prompt works. No control of the gantry, in any of the Mac OS versions and also in the windows 10.

The fan works when I turn the power supply on, the blue light comes on and then as soon as I connect Motion to the controller, a red light starts blinking. It only goes off when I quit Motion.

I am at a loss for what to do next. I have tried to re-flash the board, but I don’t think I connected as still nothing has changed.

I am open to suggestions on how to get my controller/S03 working again.



I believe you’ve gone above and beyond in testing. Please contact w/ your notes and they should be able to get you working.

Thanks @WillAdams, I should have stated, that the above new problem was sent as well to

I will report back as to what the problem was when I get it resolved.


I’m having the same problem. @buhmiller What ended up solving your issue? Thanks.

@aharner, please contact if basic troubleshooting techniques aren’t working.

Give them all the details of your computer setup, what you’ve tried, what you expected, and what actually happened and they should be able to get you squared away expeditiously.

@aharner I haven’t heard back from them yet. Once I hear from then and have a solution, I will post the results here.

@WillAdams, Thanks, I did email them everything last night, I was just hoping to get going ASAP. :slight_smile:

Since I posted I’ve noted some random CM crashes. Nothing I can pin down. Interestingly, none were during machining.

I did find a 100% crash - enter G20 or G21 in the MDI window.

In an email with Robert (on a related issue) he noted that he’s focusing on CM so we may see an update/fix soon.


I tried re-flashing my controller a few times last night. Nothing worked, but I did get an error code when I tried flashing with Arduino IDE. The code I got was:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x36

Then it repeated for 10 attempts.

It looks like there are a few common causes.

  • wire coming out of pin 0
  • wrong com port or board type chosen
  • driver issues with PC/Mac

I’m going to try updating all of my drivers tonight and give it another go.

Hi @WillAdams I have sent 2 emails 6 days apart and still waiting to hear back from somebody.


@aharner Any luck? I have sent another email to support and have not heard back from them yet. I tried flashing, but I used Hexloader. I will try the Arduino IDE and see what happens.