Carbide Motion will not open

CM4 fails to open on my laptop (new) with Windows 10.
I have tried to load it LOTS of times but keep getting the error message MSVCP120.dll.
The only other download on this machine is Carbide Create.
Any suggestions greatly received. I thought the download would be the easy bit!
At the moment my new XXL is just a very expensive paperweight!

Please see:

Many thanks.
It worked a treat, I managed to complete “Hello World” today, which may be baby steps for most on here, but a big confidence boost for me.
I’m sure that there will be lots more questions…….


I’ve tried all the options covered here at least twice, re-booted SEVERAL times after uninstall and re-install and still Carbide Motion still gives the error about the dll missing. Ran all the install exe as Administrator.

This laptop is a clean wipe back to factory condition on Win 7 Pro 64 bit. I also turned off the firewall as well as UAC setting.

Any other suggestions?

Try the instructions but grab the 2017 version?

it may be necessary to install the 32-bit version of the libraries by hand on 64-bit machines.[29]

Installed the 32-bit version (again) and it does not give the error about the missing dll but all it does is load a white screen with the CM icon and (10%) in the top left of the screen. Never loads and sits there on that screen!

Even tried the 2017 install and no change!!

I’m afraid that Windows 7 is no longer supported — it’s been EOL since 14 January — do you have access to a machine running 8 or 10?

I guess if I’m forced to I will…I hate to have a 2k boat anchor. Just does not make since seeing I had it running on another Win7 64-bit Pro laptop until yesterday when it died…And why would CM STOP working on 7 JUST because MS stopped supporting it just two weeks ago??? Did the programmers have CM check the date and say “Hey Win7 is EOL! so lets stop working”???

There are plenty of alternatives to Carbide Motion.

We are not trying to break support for Windows 7 — the problem is newer versions of Windows have different programming requirements which may need to be used, and if that interferes with support for older unsupported versions we can’t not support the current versions in the best possible way — if Windows 7 support breaks we can’t compromise on newer operating systems for its sake.

As @neilferreri noted there are lots of other programs which one can use which are less dependent on specific OS versions. Please see the list at:

1 Like

You are correct sir…Just downloaded UGS!

1 Like

I use CNCjs and occasionally bCNC when I’m not using Carbide Motion.

Thank you sir for the suggestions! I’ll check them out for sure!

Just a heads up. I picked up one of the Fusion5 Win 10 tablets that @robrob is using. Downloaded CM 431 and got the dreaded MSVCP140 fail. Attempted the Microsoft download as shown by @WillAdams to no avail. Still had the popup fail message. Completely removed CM and restarted tablet. Attempted to download the MS C++ first and tried a fresh download to no avail.
Just for shits and giggles, I grabbed the CM 428 download that was sitting in my downloads folder and re-installed it. I now have CM open on my tablet.
Time to set everything back up.



Maybe the Carbide folks should keep some known working old versions available on the site just in case others have similar issues? I know it’s in everyone’s interest to get oneh latest and greatest, but while things seem kinda herky jerky, it could be helpful to have historical installers linked in the changelog… just a thought.

Write in to us at and we can usually find older versions — we’d prefer everyone would just update though.

If I could have gotten it to work, I would have definitely loaded the latest build.

1 Like

An update to my update. :slight_smile: After perusing the community a bit more, I stumble across this little nugget from @NickT:

On a whim, I downloaded CM431 again, which of course gave the the fail notice of the missing MSVCP140. Went ahead and went to the link provided by @NickT, downloaded and installed. Guess who now has a functional CM431 on his tablet!

Also added a USB hub so I can use my Rii keyboard again too.

Thanks to all in this community for all the great advice and help.



To explain a bit on whats going on here… Microsoft decided to do us programmers a favor and developed these runtime libraries in order to help keep executable sizes down. Fine when disks were expensive, but not so much these days. What really happened is MS gave us something called “DLL Hell” as you are seeing in these numerous threads about various MSVCXXXX.dlls missing.
So if you write software with Microsofts Visual Studio, or use tools created with Microsoft Visual Studio then you need the specific version of the runtime libraries for the version of Visual Studio you are using. Same goes for any application you create, the user MUST, and I repeat, MUST have the very same version installed their system, or, you guested it… “DLL Hell”.

So what ends up happening over the lifespan of a Windows OS… You end up getting numerous versions of this runtime library installed on your OS to accommodate all the programs you have that are written using Visual Studio (or component in that executable).

It would be nice if the version number, MSVCP120, actually corresponded with the version of the RunTime library that it came from… so instead use MSVCP2013.dll… But that’s MicroSoft for you.

I have 3 versions on my 5 year old laptop.


That is nice to know info right there. Thanks again.