Carbide Motion Will Not Start

MSVCR120.dll error

Windows 10 Pro
AMD 3.6 G
8 G Ram

Carbide Motion 428
Carbide Create 449

I’ve been running the SO3 for about 2 weeks on a laptop without issue. I installed a dedicated desktop just to run CM.

Carbide motion installed normally but failed to start and opened the MSVCR120 popup. Read Software FAQ and found vcredist_x64.exe was already present in the apps & features. Uninstalled CM and vcredist_x86 and tried a full install again. Tried installing x64 and x86 from Microsoft DL Center. Same error.

Installed Carbide Create just to see. It opens successfully.

Have uninstalled/ installed CM several times. Tried using the the installers included with CC and the installers from Microsoft. Out of fresh ideas. I’m hoping someone can help? Thanks.

Does this help maybe ?

1 Like

Thanks. I started at the FAQ yesterday and have since uninstalled motion and both redistributable packages x64 and x86. No combination has worked yet. Carbide Create will open but not motion. Copied the Carbide Motion download off my laptop that I’ve been running Carbide Motion for the past week and moved it over to the desktop. Same problem.

Spent the entire day googling and searching the MS knowledge base and although I’ve tried a lot of things, I haven’t found anything that works…yet.

Make sure you are using the 2013 version only. MS will often point you to the latest, because MS has not certified VC++ 2013 Run time for use with Windows 10, however this should not impeded you from installing it. Also make sure you use the x86 version and not x64

A Happy Ending!

Finally got CM to load last night. Installed an update for the ADM Raedeon Driver. CM failed to load.

Uninstalled CC, CM and all the MS C++. Did a complete install and was back to the original problem, CC opens and a MSVCR120.dll popup on CM. Then I followed the software FAQ and dl the the VC++ from MC. Volia! Carbide Motion opened.

I have done the complete uninstall/install several times over the weekend without success. Could the video driver actually have fixed this? Thanks for the help Julien and Nick. I will be making sawdust later this morning.

1 Like

I believe that the newer versions of the Carbide programs use a different DLL package than the older ones — we are looking into this from our end and hope to have a resolution presently.

We’re in the middle of changing to a new compiler so the beta version of CM will use the 2017 redistributables like Carbide Create does now. You can try it at:

https://carbide3d.com/carbidemotion/beta/

1 Like

Same thing happened here but different fix. And I notice we are running the same processors.
Mine is the Hewlett Packard Pavilion desktop, 8 gig RAM, 2 TB HD w/4-AMD processors with built on Radeon video chipsets.
I tried a variety of things as well, even emailed in to customer support here at Carbide 3D. None of that worked.
I finally set the preference in Carbide Motion to emulate Windows Vista with service pak2 .

1 Like

I have to admit that after CM finally opened I was scratching my head. I didn’t think updating the AMD Radeon driver had anything to do with CM starting on not starting. After reading Mindless’s post, maybe it does. There’s a lot here I don’t understand. Thanks Mindless.

1 Like