Cut Depth Deeper than programmed

Thought I may have a Z height issue with the BitZero V2 and setting just the Z height, but now I’m not sure what is going on.

Used BitZero V2 to set the X,Y,Z zero on a test piece.

Set the piece to use a 1/4" end mill to cut a 1/8", 1/4", 3/8", 1/2", 5/8" and 3/4" slot.

As the slots were cut, the depths became significantly off. 1/8" started out being about right on. .25 was .28, .375 was .446, .5 was .593, .625 was .722 and .75 was .866

Attached pictures showing this. This issue did not start until I started using the BitZero V2. Not sure if it is a software issue with the upgrade to new version of Carbide Motion for the new BitZero, or if there may be some hardware issue with motor for Z axis? Any ideas?

1 Like

Which Z axis do you have and what is your $102?


First, what Z axis do you have, Belt driven, Z plus, or HDZ? So it seems that the further the Z axis travels the further off the actual distance is:
.125 = 0
.25 = .03
.375 = .071
.5 = .093
.625 = .097
.75= .116

I would lean toward that you need to calibrate for belt stretch. Of course it’s weird that this would start with the BitZero V2, belt calibration shouldn’t be effected by the zeroing method.
So two other questions:
What happens when you use the BitZero for X, Y, Z zeroing on the same stock but just jog the machine instead of cutting? If you carefully jog from the top of the stock going down the measured stock thickness does your end mill sit just above the spoilboard or do you have to stop at .625" because the end mill is at .722"?
Also what happens if you manually zero with just a sheet of paper and run the job again, do you have the same problem?

Also leaning towards something off with $102, since there appears to be a constant-ish ratio between actual depth and programmed depth (0.866/0.75=1.15, 0.722/0.625=1.15, 0.593/0.5 = 1.19, 0.446/0.375= 1.19, 0.2825/0.25=1.13)

But then again I doubt your $102 would be in the ~45 steps per mm ballpark that would result in those numbers.


I’ve got the Z-Plus leadscrew Z axis. Would the belts be responsible for anytthing with the Z axis if it’s the leadscrew and not belt driven?

I’m not sure what a $102 is. The GCODE files don’t have any reference to $102 in them anywhere.

1 Like

I’m not sure what a $102 is. The GCODE files don’t have any reference to $102 in them anywhere. Do you have any information on what that is?

$102 is a Grbl configuration.

Go to Settings, open the Log, then go to the MDI and send $$ to see what it is set to.

If you wish to change it separate from the default Grbl configuration send

$102 = <desired value here>

See: How to Calibrate for Belt Stretch - Carbide 3D

1 Like

$102 specifies the steps/mm required to move your Z axis; for a Z-Plus it should be 200. In Carbide Motion open the log window and type $$ in the MDI window and hit enter; you should see several values; find the one for $102 (you probably want to check $100 & $101 while you’re at it: they should be 40).


Here are all the values from entering $$ in the MDI with the log open:

$102 is 200
$100 is 40
$101 is 40

I have no idea what any of those values reference, but they seem to match what was expected.

[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F1778 S16000]

1 Like

Since your GRBL settings seem to be correct, I’m at a loss; unless somehow your lead screw has an incorrect thread pitch and that seem pretty unlikely. Probably time to contact customer service (if you haven’t already).

Highly unlikely. I’ve been using this for about six months now with no issues. This only started happening on the last project I tried to cut.

I have noticed that the plunge depth for drilling seems to have the same issue, where the bit plunges deeper than what is specified in the G-Code.

Is there a customer support e-mail I can use to send to?


We can also continue troubleshooting here in parallel if you’d like.

At this point I would be interested in doing a simple test: manually jogging 1 inch down (in the air) and measuring how much the tool actually moved

1 Like

Ok, I will try to go do this now and let you know what I come up with.

I assume I do this by setting the tool to a known height, then using the Z-Axis movement in CM, and measure with my calipers?

Yes, calipers will be perfect. Just jog over a long enough distance to minimize measurements error (but if there really is a x1.15 error there, it should be easy to see)

I used BitZero V2 to set the Z0 to my work surface. I then used the Jog to move it up .25, .5, .75 and 1 inch.

At each measurement, the tool was right on, so the machine seems to be working as intended.

So it would seem it’s something to do with a software issue with the G-Code?

I’m using Vcarve Desktop for my designs with the Shapeoko inch G-Code post processor selected. Would be happy to send the G-Code files in to anyone who could make sense of them.

Most likely it was a disconnect in how you have set up the file or set zero relative to the machine.

See: FAQ - ShapeOko

What happens if you do the test in reverse order? Do the deepest cut closest to the clamped location then move below to do the second-deepest cut (further from the clamped side) and so on… The workpiece may be flexing, being pulled up by the engagement of the cutter, this would be a good way to rule that out…


upload them here for a check just in case (but most probably they are just fine)

Couple of updates, but still having issues.

I updated CM to build 535. I am using Vcarve Desktop 10.512.

I move the slots slightly and re-calculated the toolpaths and re-did the slot cut and it seemed to work just fine.

I then went to the job I needed to cut, started it, and sure enough, it was almost all the way through the 3/4" board, and was going to try and do another pass about 1/8" deeper in to my waste board!

Issue is definitely still there but I’m wrestling with whether it’s software version related or something? It would really stink to have to go back and re-calculate all of the toolpaths in all of the products I’ve designed already :frowning:

Thinking I will try an older job I did that worked fine numerous versions of both Vcarve and CM ago, and see if it still works. Any other suggestions at this point? I’m out of ideas.