Disconnecting Issue with Shapeoko, wanted a little bit of advice before we start dropping $ to fix it


(Tom Kat) #1

Hey all,

New to the CNC space and just got a Shapeoko 3 locally.

We’re having trouble with the controller disconnecting after 30-60 minutes of cutting, and wanted to get a little bit of feedback from the community before we start buying special cables, isolators, humidifiers or a new hand router in attempts to chase down the electrical gremlin.

Support is being helpful with information, but due to the fact that we did not get the machine from an authorized dealer, I don’t think they’ll foot the bill for any replacement/upgrade parts to fix the issue.

The original support response included the following tips:

  1. arrange the AC cable for the router so that it doesn’t cross or be near any of the other cables < Done, and moved to different circuits.
  2. if you’re using a laptop, ensure that it is plugged in, preferably to a grounded outlet using a 3 prong plug if possible < Done, and we have tried two different laptops
  3. if you’re using a USB extension cable or unpowered USB hub, please directly connect the machine using a shorter than 6 foot USB cable — if your cable doesn’t have a toroid (metal cylinder often molded into the end of the cable) and you have a cable which has that feature, try it, if not consider adding one or getting a cable which has that feature < We’ve cycled through a few USB cables, but none with tyroids.
  4. try a different USB port, esp. if you have the option to switch from USB3 to USB2 — if using a laptop try a good-quality powered USB hub — some laptops undervolt the USB ports to save power. < Added a powered hub and changed laptops
  5. if your router power cable doesn’t have a toroid, try adding one (note that what seems to be a toroid on a Dewalt DWP611 is actually an anti-theft device on all the ones I’ve seen) < Not done
  6. if possible, connect the router and the machine through a different circuit < done
  7. if you have a surge protector, please connect the machine through it < Done, and tried a UPS as well
  8. check the ambient humidity, if low, consider a humidifier < Live in a very dry climate, don’t have authorization to start messing with humidity levels in the space.
  9. if using dust collection, ensure that your dust hose does not allow static build-up, or is properly grounded < Not sure where how to verify/establish ground on the shopvac. Any recommendations? The device still disconnects eventually without the shopvac running, but seems to run for longer before doing so.
  10. Connect the machine with a galvanic isolator such as this one: (link) < Have not tried, would cost about ~$40

In another support email, it was suggested that I replace the carbon brushes on the router. I wouldn’t have a clue how to go about this, but my understanding is that the DeWalt router we have installed is new.

At this point, we have tried everything that could be done for free, and it’s time to start spending money on fixes. To those of you who have run into this problem, which of the paid fixes resolved your issue? Don’t want to spend any more than necessary as this is a makerspace machine.

Voltage from power supply and to microcontroller(s) was nice and clean at idle, while jogging, with router running, when switching router off, with dust collector/shopvac running, and while all of the above were happening simultaneously.


(William Adams) #2

Which board revision do you have?


(Richard Cournoyer) #3

All good stuff, but will add that early GRBL boards were notorious for disconnects and were replaced with Ver 2.4(no rev) to Ver 2.4d. Open the box, and read off the board rev.

See photo:


(Tom Kat) #4

It’s 2.3

Support has offered to sell me the newer board at a 50% discount ($67.50), which would presumably solve our issues. Not terribly excited to be replacing components that came with issues from the factory, but better than nothing.

Will probably try grounding/shielding the router and shopvac hose, if we see no improvements, we will order the new board.

Bummed about our first few experiences with the machine, but excited for the potential that it stands to bring.


(Scott Sroufe) #5

I’m sort of in a case like you but my Shapeoko 3 XXL is brand new (just got it a few weeks ago and one that had to wait for the controller which I got last week) and while surfacing my waste board the controller disconnected twice and the 3rd time the controller went out. A new controller should be here today and wondering what I should do to help with this problem unless it was a fluke?


(William Adams) #6

Please see: https://wiki.shapeoko.com/index.php/Electronics#Electrical_Noise


(Richard Cournoyer) #7

For me (now) the biggest contributor is humidity, or should I say, lack there of. Anything below 15% in my shop is going to give me a disconnect (when cutting wood).

My simple fix is a small pot of water on a hot plate (or in my case, an inverted flat iron) to raise the humidity is the fix. Zero issues once I’m above the 15% number. Hope this helps.


(Scott Sroufe) #8

Thank you for the link. Is the USB cable that comes with the newer Shapeoko’s a good one or would you recommend getting higher quality one?


(Scott Sroufe) #9

I ordered a digital temp/humidity monitor to let me know where I stand.


(William Adams) #10

We’ve been including this one:

Tripp Lite USB 2.0 Hi-Speed A/B Cable with Ferrite Chokes (M/M) (available from Amazon at: https://www.amazon.com/Tripp-Lite-Hi-Speed-Ferrite-U023-003/dp/B008VOPCGY )

6 ft. long, there’s a 3ft. long one as well which has helped some folks.

If there’s a better cable to use, we’d be glad to know of it. I have one old cable (Apple brand I believe) which has a metal braided sleeve to which I’ve added a pair of ferrite beads and it is very reliable, but I can’t find an equivalent contemporary product.


(Dan Nelson) #11

I didn’t see anyone mention it, but I know some folks have had luck by adding a ground wire to their router case.

Dan


(Chris buentello) #12

I had the same issues with my brand new shapeoko 3 xxl right out of the box, i followed the guidelines for EMI, ran my power cords opposite ways etc…, and i put copper tape on the inside of the controller cover/wraped the USB cord with it, and the power cord going into the control unit. Havnt had a disconnect since.


(Tom Kat) #13

That’s some serious shielding! Thanks for the advice everyone, I’m feeling quite a bit more motivated to track down and knock out the issue without spending a ton. I’m going to try the manual grounding + humidity fixes first, as they probably stand to make the biggest difference.


(Alvin Moses) #14

Is Carbide motion freezing, crashing? Are you getting error message on carbide motion?

Have to tried running a 75 minute job with router off/ no bit in it?

Have you put carbide motion on different computer, running an “air” job like above?

All power save features disable on computer?

Screen saver disabled?


(Matt Hilliker) #15

This issue comes up a lot when cutting mdf. When I surface a new waste board it happens almost every time. The only fix I have is to not use my dust collection that is attached to the machine and just babysit the machine with a separate shop vac. Make sure you wear a mask when you’re doing mdf. If this is occurring with other materials then I would think you have more of a technical issue.

Matt


(William Adams) #16

If using your dust collection is the problem, then ground the dust collection system.


(Tom Kat) #17

I went ahead and bought a new shapeoko directly from the carbide 3D web shop last night. If the issue persists after deploying it, I’ll update here. The other machine will likely receive the sparkfun controller kit, which appears to be much more carefully thought out. We will also use the older machine as a test bed for modifications as well.


(Gary) #18

Why do you believe the sparkfun controller to be better thought out then the shapeoko?


(Miles Baughman) #19

Could it be as simple as the computer going into sleep mode?


(Yves Cayer) #20

I also had the same issues, and just running the router power cord on a curtain rail away from the the stepper motors wires fixed all my problems and my shop is quite dry especially in this frigid winter and.
I’ve had my XL now for about 3 years and no issues (at least with disconnections)