Disconnection issues rears it's ugly head again

I was having disconnection issues earlier when I first got my Shapeoko. So I read this forum and followed these steps:

  1. I Plugged my router (Carbide Compact) and Shapeoko computer into separate outlets, my workshop has 20 amp EFI protected plugs. That slowed down the occurrences of the disconnects - but they still occurred, just reduced about 75% I’d estimate.

  2. So I purchased a “filter and power control unit” to plug my router in, like BitRunner but with a power surge protector built in.

  3. Then to make sure I plugged my Shapeoko computer into a Tripp-Lite Isobar 4-Outlet Surge Protector.

That worked for a time a little while… now I’m getting disconnects happening on every 2nd job at least.

I’m using the same computer - it’s a MacBook Air and my board version 2.4e (if i remember correctly)… I also have a that 3rd Party BitRunner plugged into PWR and GRD on that plugged to control the router.

Thanks in advance.

Usually if disconnects arise after a period of successful operation it’s worn carbon brushes.

Or, it could be low humidity.

How are you doing dust collection? Is your dust house grounded? The best thing is a ground from the router body through the dust shoe and hose to the same ground as the vacuum is running on.

If you continue to have trouble let us know at support@carbide3d.com and we’ll do our best to work through this with you.

1 Like

I just went through this with my unit. I added a grounded wire to the inside and outside of the vacuum hose from the router that runs all the way to the housing of my dust collection motor AND I ran another ground wire from the same set of wires to a dedicated ground on the 120v circuit for the router. I also have my Shapeoko inside of a dust cabinet that has plexiglass windows. I grounded each of the windows to the ground array that I built. I have had not disconnects…yet :slight_smile:


Hi William,

This problem is so frustrating now… it’s just getting worse.

What I did this morning was to clean and vacuum the entire shop and then installed my new proximity limit switches (one failed and I rigged it with a fridge switch) - they work great (one issue with the design - the new Z housing is slightly larger and the router doesn’t slide by it like it did before, so I added washers to the housing the holds the router to give it an extra mm). I cleaned inside the computer box too when i did the install… so no dust in there. I checked the router brushes - they are basically new, the machine has very little hours on it)… I then added the sweepy to my router, and plugged the vacuum to the router control box (basically bitRunner). The problem with sweepy (version 1 I guess - just notice there is a version 2)… is that on a 30mm deep box, it’s just too high to be effective when the Z axis is high at the beginning.

I live in Calgary - we have winds here that are called Chinooks, which means “snow eating wind” - they eat snow because they are warm and very dry - so it’s very dry here right now to stay the least.

So I did all that - and by the third drop, about 6mm down on z of a 27mm deep box, the computer loses it connection. This time it stopped the router via the BitRunner PWR and GRD pins, but it does both, the time of my original post, it was (the router) staying on.

Why is this happing… is it static build up in the computer… maybe I should try grounding the housing.

Sorry for the delay getting back btw.



Hi William T… I responded first before reading your post… if you noticed at the bottom of my last post, I was thinking that’s my issue as well. Thanks for confirming that before I even knew that you did.

Please write in to support@carbide3d.com

There are recommendations at: https://wiki.shapeoko.com/index.php/Electronics#Recommendations — we have a nice 10-step version we can send you from the support queue.

I live in Colorado and as soon as the humidity dropped I had the same issues. I grounded everything and that helped. If you look on youtube “Grounding Shapoko” here is severe good walk throughs. This is the one I liked the best. (https://www.youtube.com/watch?v=NEWVrtLWUuY)


I had some disconnect issues that I’m pretty sure were due to power consumption. I can use a lot of tools while my CNC is running but if I turn the planer on there is a good chance of disconnect. I bet that tool is a power hog and my shop is on one circuit.

1 Like

Thanks Scott and Brad…

I finally got it to go through 1 project without a disconnect, but it disconnected the first time through that same project but made it through on the restart. Oh… I lied, it made it through the very next one too without a restart, but disconnect on the third again exactly 1/2 way through - which is a great place for it to stop because I at least get one piece and it doesn’t start the next and wreck a board if I can’t get the zeroing exact (which is easier now that I have Tiger Clamps - they’re Grrrreat).

Ok… Since my last post I added a Tripp Lite USB (A to B) cable with Ferrite Chokes on both ends.

Scott… Calgary (where I live) and Colorado are very similar, both up at high elevations, I can’t wait until tomorrow and watch your video and try out the suggestions - thanks for that.

Brad - I have a 50 amp sub panel in my mini shop with 3 separate 20 amp plug breakers (3 sets of outlets on each - and they alternate throughout the shop, so no two running tools are on the same breaker if I don’t want them to be) (all with EFI, which may be a problem). There is also a 240V, 30AMP heater that runs off the panel, and two 15 amp breakers, one for inside and the other for outside lights (all LED lights - so they won’t even consume an amp between them). I don’t think power consumption is my issue, although I wonder if the EFI breakers weren’t a good idea to install, as I have read, other people seem to have them and have issues - I don’t recall them connecting that with their issue however. I have never blown a fuse in the shop. Thanks for the insight… I think maybe it’s the static the tools cause though - I do have two surge filters working, one on the router and the other on both computers (the Shapeoko, and the connect Mac/PC).

I’ll come up with plan 8,9, and 10 though as I watch that video.

Thanks again for everyones help.


Hi Scott… I watched the video - thanks again for that, and you’re right, it’s the best of the bunch.

I followed the instructions in the video, and hooked up my Z carriage up to my X rail (I have the regular size)… I used one of the bolt and nuts holding the springs (belt Z) and wired it to one of the bolts that the computer uses… I then wired my Y rail using one of the end bolts and running it along the rail to the X rail and across to that very same bolt holding the computer.

That made it better, still some disconnects.

I then ordered a static hose for dust collection (not in yet)… then I wired one more line, from the spring bolt and nut to the gap in the router holder, you know that 1/8 to 1/4 inch space, I bent my loop so it made contact and was like a spring and used one of the router holding bolts.

and… no disconnects yet… YES.


I hate that I have a machine that I can’t trust. The frustration level is through the roof. They need to send out processors similar to these third party processors that I’m hearing about. Until they do something like that I’ll be telling anyone who listens to look at other companies. Totally unacceptable.

Now the support group has completely blown me off. I am trying to get the CEOs email but no luck at this point. They need to come up with solid fix or refund our money.

You seem to have a strong affinity with Jeff E. He said pretty much the exact thing when chatting to you in the other thread. Friends?

Nope just the same issues and frustrations and a lack of good solutions. When you pay 2k for a tool you expect it to work I have worked for 20+ year as a Electrical engineer for Intel type companies as a Failure Analyst, Quality Systems Engineer and Product Engineer and can tell you right now this company has no closed looped correction system and no quality control system. If they did they would have fixed this issue and built a more reliable tool. All they are doing is throwing mud at the wall and hope it sticks.

When you ask for specs like what temp range or humidity range the tool should operate in you get zero responce.

Remarkable. I do NLP for a living and this is an interesting statistical anomaly.

mynamejeffJeff E: They sent me the A/C filter and ground cable as well. The ground cable was actually broken when I un-boxed it. lol. But the A/C filter seems to have helped. I’m happy that I’m running for now but I hate that I have a machine that I can’t trust. It’s so un-reliable and it destroyed well over $1000 worth of work pieces this holiday season. The frustration level is through the roof. They need to send out processors similar to these third party processors that I’m hearing about. Until they do something like that I’ll be telling anyone who listens to look at other companies. Totally unacceptable.

scottjrittScott Rittenhouse: I hate that I have a machine that I can’t trust. The frustration level is through the roof. They need to send out processors similar to these third party processors that I’m hearing about. Until they do something like that I’ll be telling anyone who listens to look at other companies. Totally unacceptable.

Exact same words in bold.


Then they should exchange my machine for one that works they say they fixed this in the PRO. Then prove it exchange mine for one that has been fixed or refund my money.

Yes I did copy his post because I feel the same way!!!

I want Carbied3D to stand behind there product and make good on there warranty. At this point it is a paper weight and support is not replying to me. I am pi***ed right now. They can fix my issues or refund my money.

Your ticket is still open — we don’t seem to have received anything from you on support about whether or no the USB isolator worked or no which is likely why it’s still in limbo.

Please send in a new e-mail which notes which of the 10-step items you were able to do (and which you were not and which you feel did not apply) and esp. note that you have installed the USB isolator and that it didn’t work for your situation. As well as the specifics of which spindle you are using. Include a photo of your overall setup, and detail shots showing your controller and how the USB isolator is plugged in.

We will do our best to work with you on this, but we need to have all the information on the support ticket.