DLL error when trying to run Carbide Motion

I’m getting a DLL entry point error when trying to run Carbide Motion. This is a new Mini PC running Windows 10. I get the same error with V3 and V4. Any idea what’s causing this? Am I missing something that the Carbide Motion install does not install?

Usually this sort of thing is fixed by: http://docs.carbide3d.com/software-faq/missing-msvcp120-dll/

Qt5Gui.dll is in the same directory as the app, so ought to work — check permissions? Do the install as Admin?

If these things don’t help, send an e-mail in to support@carbide3d.com (if you haven’t already) and we’ll get it sorted out.

Tried reinstalling using admin but that didn’t help. Still get the same entry point error. Also tried running the app as admin but still ended up with the same error.

Now I’m thinking this may be related to an incompatible version of the VC runtime environment. My next step is to uninstall Carbide Motion and all VC libraries that I see. Then I’ll re-install Carbide Motion and see if it installs his own preferred version of the VC runtime files.

Has that machine EVER run the software successfully? What build and version of W10 is it?

1 Like

The problem is with the c++ file… it was downloading and installing the wrong one… once I installed the (x86) version of C++, the program loaded properly.

See this thread:

1 Like

Tried installing c++ (x86) but that did not help. Still getting the same errors.

Hmmmm I am at a loss then. Hopefully someone can help you!

I bought this mini PC for something else and thought it may be a good fit for Carbide Motion. It’s Windows 10 and is fanless which means it should have a better chance at surviving in the garage. It didn’t work so I’ll go back to what does work which is BCNC on a Raspberry Pi.


I was travelling for the last few days. I saw your post on my phone. I had to wait till I got home to find my older posts that I put on the forum because I ran into VERY similar issues with a new, small PC tablet I purchased last December. I kept getting DLL errors. I never got any real assistance from Carbide 3D, but someone pointed me to this thread that got me pointed to my solution: Carbide Motion Startup Error

Basically, I searched on YouTube for a video from “Tom’s Hardware” that helped me find the fix. I had already downloaded and installed the 2013 Visual C++ distribution for Windows 64 bit, but the video said to get the one for 32 bit as well. Once I did that, the DLL errors stopped and Carbide Motion started working for me. Hopefully, it will work for you, too.