Error (1) error in line 20: arc endpoint error?


I’m getting the error as below on my windows machine, but not on my Mac (using the same files) - I’m running v 4.09 on both. Recently I tried installing an old version of CM 4.0.3 but am now back on 4.09. I also tried turning it on/off :smiley:

Copy of a file (but it’s doing it on all files)

4000 rpm (1019 Bytes)

I thing , you need to fix error file and new file , the older put into the box !.

You tried running it through another gcode sender by any chance? When I was working on the post-processors I found references to Arcs not being handled well in grbl, but there were conflicting reports on how real that issue was/is…

Please send that to — interesting error, probably related to differences in floating point calculation on the two platforms (which arguably, is why one should use integer math for anything which one wants to actually work reliably).

Well to confuse things more it was working with the same code last night and works flawlessly so its not the Gcode. Today I downgraded to 4.03 then back to 4.09 because I had issues with the $$ command since then I’ve been getting this issue in the windows machine.

Mac running Carbide motion is fine. I don’t understand UGS fully, I can’t work out how to jog the machine in that… I get command errors but can check $$ settings

You may have to update UGS to a version which works with Grbl 1.1

Ah I was running v 1.09. I will just end up using my Mac till it sorts its self out or there is an update

1 Like

If you can get the windows laptop situated give “GRBL Panel” a shot. I’ve been using it almost exclusively recently and like it quite a lot. Happily talks with grbl 1.1, though grbl will need some additional config to make sure soft limits and the like all work as they should.


Thanks, I might take you up on it some time. Right now I’ve just rolled back to 4.07 on windows which seems to work. However I’m using the Mac as my temp solution.

Just updated the firmware and Carbide3D and have the same error on windows 10. The same files had no trouble with v3.067, so I don’t think the files are an issue. I am using Fusion 360 and have tried files output for both the Shapeoko and a generic grbl.

The offending line appears to be:
G18 G2 X310.059 Z-1 I0.317 K0

Not sure if I am using integer math or not out of Fusion 360.

Let me know, trying to get production rolling asap

The problem w/ integer math is in Fusion 360, or maybe Carbide Motion — it’s not something which you can address.

In the past, the two fixes have been:

  • using metric for the CAM step in Fusion 360
  • turning off ramping in
1 Like

Using metric for everything, will try ramping. if version 407 is stable, will see if that works. The spare mac laptop I have won’t take the latest mac os, not sure if that works.

@WillAdams & @michael91208 - I’m also using metric.

I can’t work out why the issue would present on the same file overnight.

Same file, different carbide3d version.

Ramping is off, BTW.

The files work in Carbide3d version 3 (latest) but won’t load into version 4 (downloaded today).

Can I get build 407 somewhere? Its mentioned above that it’s working.

1 Like

407 fixed it, works fine. Must be something with the latest build.


I wonder is a new version of CM is coming out - I’m still out of action

I’m having the same issue with 409. 407 works for my files, but it means I can’t use the fancy new touch probe which arrived this morning :frowning: . Anyone hear any updates on this?

No I emailed it to CM the same time I started this thread and again the other day.

I tried rolling back and re-installing each version in order but no joy. It’s all fine till v09

Same problem when using Fusion360 generated files. I ended up installing both 407 and 409 ( chose different folder during installation) .I’m now using 409 for probing and 407 to run my files. It’s annoying , as you need to home every time you switch, but it works. I hope this gets resolved soon.

cheers, Alex