Fonts.....again :(

I know…lots of messages on this, but… I have tried everything that has been suggested but the font does not show up in CC?

I have 6 other Windows programs in which the font shows up, including Mind Map s/w, Open Office, ALL Microsoft Office programs, every program that I use on the computer that uses font choices, except for Carbide Create.

Any ideas? Anyone?
Thanks

Reasons fonts won’t show up in Carbide Create:

  • not installed for all users
  • not technically correct (must have space character, &c.)
  • not a text font — pi and dingbat fonts are not allowed in CC

If you’ll let us know the name and derivation of the font either here or at support@carbide3d.com we’ll do our best to assist.

First off, thanks for the quick response. Fantastic! Thank you.

  1. The font family is called: Liberation Sans. (I tried to copy the file directly into this response but the site doesn’t allow it, it says.)

  2. Font family works on other computers with CC

  3. Font is assigned to all users

  4. Font works in all my other programs on this computer that have font selectivity.

Not sure why it won’t show up in CC.

I did uninstall the font.

Uninstalled CC and reinstalled Ver 520

No change

Rebooted PC…no change

???

Thanks

Frank

I found, downloaded and installed the font on my iMac and it shows up in CC.

CC doesn’t list fonts alphabetically, so you might need to hunt around for it, but all my installed fonts - i.e. the one’s I’ve added myself - are at the top of the list.

I haven’t tried it on Windows, yet…

UPDATE: OK, so I tried in in Windows and I get the same as you - it’s not showing in the list in CC, but does show in other programs.

FWIW - and this won’t help if you don’t have access to a Mac - designing the project in a Mac using that font and then saving the toolpath will cut it correctly.

I have had some similar experiences, which I have put down to knowing nothing about Windows… in addition to being stupid. :wink:

I asked a question about font/typeface handling over at the Carveco forum and got an answer that may be useful for applying fonts to Windows/CC. It is straightforward on the Mac because all software knows where to look for installed fonts and does not care if they are open type or true type fonts.

Does Carveco Maker support .ttf and .otf font filetypes? – Carveco Help Centre

Most apps usually access fonts using an API call, which is why most apps are seeing the fonts. Issues about OTF and TTF fonts is not really pertinent. If you can install the font, the font is installed and available. If you can’t install it, you can’t install it.

The issue I think is that the cross-platform library used to build CC might be old or at least it only takes into account fonts installed globally. It’s might be doing something like scanning C:\Windows\Fonts instead of using the relevant API call.

Anyhow, fonts you install as your user end up in %AppData%\Local\Microsoft\Windows\Fonts and not in Windows\Fonts.

To install this particular font and use it in CC, right click on it and select “Install for All Users”.

Pictorially:

and then, the magic:

image

Note also that CC doesn’t sort the fonts by name, as demonstrated in the above picture, so keep looking in the list until you find it.

2 Likes

Yep, that worked for me - but it seems to be a bit of a kerfuffle particularly as they are installed for other applications, including VCarve, straight off the bat :thinking: