GRBL Error: Homing Failed, pull off didn't clear

Finished assembly of my Shapeoko Pro XXL yesterday. Had a few problems that weren’t to hard to deal with.

  1. Y axis reversed. Swapping the Y1 and Y2 fixed this.
  2. The Z-limit switch was loose, even though the bolt was as tight as it could be. Removed the bolt and placed a washer on it. Now Z-limit is snug
  3. Y-limit switch was mounted to high and the carriage bumped into it without triggering it. Adjusted it down so that the carriage just clears it.

Now it seems to initialize pretty well but I get an error shortly after all the steppers stop. Error = GRBL Error: Homing Failed, pull off didn’t clear. Checking CM showed Y limit switch still triggered. Sure enough, the carriage is still over the Y-limit switch. I did research the problem but didn’t see anything obvious. I then verified that the Y-limit switch is working by holding a pair of pliers up to it and seeing the led light and CM indicate the Y switch was triggered. Removing the pliers and both the LED and CM show the Y limit switch is off. Watching the carriage as it goes through this cycle I can see that the Y axis doesn’t back off after it stops. Seems like this is the cause but, to verify it is, I then placed the pliers up to the Y-limit to tell the system that the carriage is zeroed and then remove the pliers to indicate that the carriage has backed off. Same error still comes up.

Suggestions would be appreciated!


Please write in to noting you have a Pro, the adjustments you’ve made thus far, and photos showing how the homing switches are positioned and wired up/connected.

Thanks. I’ll get right on it.

Can you do the steps I’ve highlighted in this post here:

That way we can see what values are revealed through the $$ command in the MDI input box (with the log window open and ‘Hide Status…’ checked).

Basically I want to see if your “$13=0”, and then if your “$27=5”.

The $13=0 would mean your machine is set to millimeters, and the $27=5 would mean your machine should pull off 5 millimeters after homing. The $27 value may need to be increased, or re-set, to be out of the triggered range of the homing switch.

EDIT: Actually, I think the $27 value is always interpreted by the machine as millimeters (independent of the $13 setting), so knowing $13 isn’t essential, but it doesn’t hurt to know either…

Here’s the log. $27=3.0.
How do I try increasing it?
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]


In the MDI window type in “$27=5” and press ‘Send’ (nothing will happen, you won’t know anything has changed unless you do the ‘$$’ log process again to see the difference). And if it still throws the error try “$27=10”. Let us know if either of these values work for you.

That fixed it! I tried 5 and that worked the first time but not the second. I’ve moved it to 7 and that seems to work.

I noticed that I can’t bring the y out far enough to center on the bitsetter. Is there a setting for that?

Thanks for the help. Can’t wait to start cutting.

1 Like

Make sure you did the initial steps of sending your specific machine’s specs to the controller board, it is a process initiated through the ‘Settings’ page of Carbide Motion (version 517 or higher), the steps are described in the documentation for the Shapeoko…

Here is the page that lists the guides for the machines,

yours is an xxl, does it have a z-plus? If yes, then the steps are on page 66 of this guide (and if no, just select the appropriate choice from the dropdown menu, the rest is the same):

1 Like