GRBL Error: Serial Port: ResourceError

This is a new thread as the issue I had in an older thread is solved. The problem I am having now is I can connect and control my S3 using my Laptop (MacBook Pro 17", early 2011) running Mac OS 10.11.3, Carbide Motion 3.0.355, but when I try to connect to my Mac Pro Tower early 2008, running Mac OS 10.11.3, and Carbide Motion 3.0.355 I either get the “GRBL Error: Serial Port: ResourceError” or I the application opens up and then when i click on jog, the programs crashes.

See the 2 screen shots.

I will then force quit and try to open the application up and then the Icon for the application (CM) it just bounces and bounces but never opens up.

I will then restart the computer and will be able to open the application (CM) and then attempt to connect to CM and no luck.

Power everything down, then try resetting the PRAM. If that doesn’t work, and doesn’t help, contact support.

I am seeing the same thing, after getting everything working and actually running a job that I built it got half way through and quit responding.

For USB Disconnection, see: — if the suggestions there don’t help (or for a nicely formatted, numbered version), contact

I am a total loss for this. The problems I have documented above are on a Mac Pro Tower, early 2008 running 10.11.3 Mac OS, and Carbide Motion .355.

Now when I connect to my Mac Book Pro 17" Early 2011 running Mac OS 10.11.3 and CM .355. There are no problems.

The only difference is machines.

I don’t know, I guess I will run off of my Mac Book Pro.

Now to get her tuned up and start making some sawdust!

Thanks everyone for the help!


Has anyone found the cause or fix for this? My machine just started doing this a couple of days ago. It’s always around 95%-98% complete of a job, and I have to restart the entire job over.

I have went through the link above, and nothing helps. This error has never been there before, and there have not been any changes to the machine or the computer. The computer runs WIN 10 and ONLY Carbide software and AVG anti virus. No other programs are loaded on it.
If anyone else has been able to fix this, and could help that would be great, thanks guys.

Please check in w/ — they need to get all the reports of this sort of behavior so as to be able to address it.

Thank you for the reply Will. I have contacted carbide support previously on other issues and felt I would try the community of users this time.

I recently had what looked like a “USB disconnect” problem with my XXL. I read the wiki and did all the usual power stuff (UPS, etc), tried different software toolchains (Meshcam, VCarve), tried different CAD designs of the same part, tried different g-code senders (Carbide Motion, UGS), tried different computers. After enough combinations failed to eliminate the problem I figured out that it was not random but was always happening when the machine plunged to a particular Z height. No soft limit alarm or anything, no difference even cutting air – the machine would just stop moving with no user feedback at all. What had appeared random was in fact specific to the Z depth of the cut (with plenty of mechanical Z travel available), and was occurring in the Arduino based GRBL control board.

I lowered the Dewalt in the spindle bracket and it has not occurred since. I’m pretty sure I did try changing the soft limit Z during all of my debugging fun, but if it recurs at some point I’ll check that first.

Interesting to say the least @mpfreivald. Great observational details can often make/break debugging. I’d be scoping out the stepper lines and jogging around to said “position of doom” to see if there was something obvious… luckily, not a lick of connectivity or noise problems so far with my limited XXL operations (knock on MDF).

Curious if you guys have got anywhere? I did try re-positioning my cutter changing the Z position and still had the error.

I stepped away from the machine for a couple of days out of frustration. Hoping if I decide to stay with the Nomad a fresh attitude will help me find the issue when I return to it.

Unfortunately, I had this problem happened in the middle or the run.

I hope there is a solution for this problem

I have the same issue. Any solution out there?

Email so we can open a ticket and get it taken care of.


1 Like

Same problem here in New Mexico. I cannot shut down the dewalt router without getting the error. Sometimes get this during a job. Real pain because we are a production shop.
Emailed Jorge again today. Maybe a new board?

I’ve played around a bit with a multi-board setup (v2,2 & v2.3 CM boards) as I’m running multiple CAM standards (GRBL & ESTL). Since I’m using a “more prone to dropout” v2.2 CM board, I wanted to identify and mitigate the sources for USB dropouts.

In my experimentation with wire proximity, I can guarantee a dropout of comms if the Dewalt power cord is anywhere near any DC wiring (servo or limit switches) or gantry framing. Physically isolating DC and AC wiring will help mitigate the back EMF noise, as will grounding the machine and powering your router from another AC branch.

I have also run ferrite cores on all the wiring. With these steps I’m running this older v2.2 with extreme reliability.



Thanks, Jim.
William emailed immediately this morning… Sending a new board.
Ferrite cores… will get some.
Already using two AC outlets.
Dewalt power cord is isolated.
I do not know how to properly ground the frame. Any suggestions welcome.
Thanks, Jim.

The big thing in grounding the frame is to ensure a star topology to the central grounding point, and to avoid any loops.

I clicked the link. Whoo-boy. Is there a dummy’s guide to grounding?

Maybe I can run a copper wire from the SO3 frame to the ground connector inside my electrical junction box?


Where are you located? USA, your shop should be wired with a 3 wire system. Green is ground, so you can use that ground.