gSender from Sienci Labs - CNCjs based sender

I’ve come across a new CNCjs based GRBL sender called gSender.

Introducing gSender | Sienci Labs

Versions for Windows, macOS, and Raspberry Pi. It also has built-in support for Shapeoko. I have not tried it yet, but it looks promising. Has anyone else tried it?

3 Likes

I tried to try, for my Raspberry Pi, and gave up after an hour of linux-fu of trying to figure out why their “.AppIMage” format file would not agree to execute on my Pi (standard Raspbian distro). If someone did succeed to run it on a Pi, I’m interested to know.

1 Like

I have loaded the Windows 64 bit version on my BeeLink GK55 mini PC that runs my Shapeoko. It installed and runs OK. I have only tried to move the system around so far. It connects and homes and moves as expected. Loads gcode files fine and I do like their visualizer. The initial load time was really long, but subsequent runs have been fine. Lots of poking around is needed and set up for the BitZero and BitSetter still needs to happen, but it seems like this sender will work as well. I’m in the middle of another project, so I can’t play around yet, but I should be able to in the future. I’ll post my findings when I do.

Yes. I like where they’re headed. I’ve been in touch with the developers trying to make it more functional for us. Haven’t tried the recent update yet.

5 Likes

Did you try chmod a+x <filename>? Files on Linux aren’t executable by default so you need to make them executable. You might be able to do the same thing by right-clicking and changing the permissions in the properties dialog.

That’d be my first guess. The second would be that maybe you have a weird architecture, like 64-bit. In that case you’d need the arm64 AppImage instead.

2 Likes

This looks pretty cool. I am going to try it out this weekend.

I loaded it on my Raspberry Pi 3B last night and ran several jobs successfully. I had to turn off the visualization features because the Pi could not handle the graphics workload. Everything worked as expected. I will test some more tonight. I’d like to try a Pi4 but I can’t find a barebones one at a reasonable price. Everyone seems to be out of stock except for complete packages with stuff I don’t need or don’t want.

2 Likes

I’m going to start working with it (while waiting for @neilferreri to straighten them out :smiley: ) since their manual states the following feature:

Start from Line

This feature is handy in cases where:

  1. You only want to cut part of a project, not the entire thing
  2. Your job has been interrupted, so you need to resume from a specific point of the project

With this feature, you can start your job from any line in your g-code, by specifying the line number.

EDIT: And they seem to have addressed additional workspaces in a nice way:

Workspaces
Usually you would only have one origin or zero position for your project, therefore gSender will only save one zero. However, if you plan to do a series of projects that require different zero positions, or are lining up to do some more complex jigging or part batches, you may want to set up multiple zero positions all at once. You can do this by creating up to six different zero positions with the six workspaces in gSender.

2 Likes

I just installed it on my computer and set up was very easy. Connects, homes, jogs all no problem. I haven’t tried cutting yet but it seems promising. My only confusion is adding my game controller. It says to add a joystick, click this button, then click any button on the controller. When I do that I get no response from gSender at all like it doesn’t see the joystick. It’s a wireless Logitech controller that I know is connected as it works fine with Carbide Motion.

Has anyone been able to connect a joystick / game controller?

I’ve now been using gSender on several laser files with nothing but success. It takes CNCjs to another level; one that I can easily reach.

The built in macros work, but I’ve yet to test it using my router. I do know that I like the way it works on the zero block. I’m yet to determine if the offset for the XYZ zero is the same between their block and my C3D zero probe block.

I’ve found out that it doesn’t want anything in the gcode file but gcode, but then there are built in pre and post macros that take care of anything that I was putting into the gcode (thanks, Gary @wb9tpg .)

So far, its everything that CNCjs isn’t.

2 Likes

I finally found a Raspberry Pi 4 at a reasonable price and installed gSender on it and have run several simple jobs successfully on my S03XXL. I originally tried a Pi 3. It worked but I had to turn off all of the visualization stuff because it couldn’t handle the graphics work alongside the rest. The Pi 4 is handling simple jobs just fine with the visualization graphics on. This is my sender of choice now.

One thing I have found is that the gSender program does not where the initial M05 (Spindle Off) command is. If I move it above the G53 command then it accepts everything in my tiny sample project. This is with using CC 616 using the Shapeoko post-processor.

Using the GRBL post-processor removes the G53 command and gSender has no issues. But the GRBL post-processor also does not insert M6 command for tool changes. So ???

Anyone else seeing this and/or have some more suggestions?

My suggestion, @SLabuta , is to get on their forum. This is still beta software so they are anxious to hear about problems that we have. I’m seeing that they are responsive.

Yes… But it does not seem to be the M05 command anymore. It seems I am chasing something else. I’ll try their forum to see what the gSender team says.

Can you share your gcode?
I’m planning to really look at the update this weekend.

Hi Neil,

This is the gcode. Line 9 is where gSender has a problem. I think it’s the G53 command. I am not going to get to write them an error report today. Hopefully tomorrow.

Lamp1_gSenderTest.nc (26.1 KB)

Neil it looks like stuff I’ve been putting in the post-processor can be placed in pre and post “macros” within the software. I’m trying to find time to figure out whether I can move my offsets between my router and laser mounting, to gSender.

@SLabuta I’m not seeing an issue, but I thought I did the first time I ran your code. Weird. There’s no reason the G53 should be an issue. What version of gSender are you using?

Lightburn? They have an odd way of handling grbl right now.
Absolutely those $10 & $32 commands and work offsets could be included in macros.

Hi Neil,
I’m using the latest gSender. 0.7.3. After playing around yesterday it has confused me even more. I get the error every time when it’s the first gcode file I use after loading gSender. After gSender has been running other files for awhile it runs the suspect file just fine. I did submit an error report to them. I did not use their forum because new members can’t attach files. Here’s the files I sent them.
Lamp1_gSenderTest.nc (26.1 KB)
ModernDeskLamp_SBL.c2d (275.5 KB)