HDM making shaking noises

My HDM was making really horrible noises during the initialization cycle, I looked around and found a loose nut on one of the Y axis ball screws. I tightened it as per Carbide 3d’s instructions and waited a day for the loctite to cure, but it still makes this horrible jackhammer like noise when initializing and cutting.

Couplers are tight, screws are tight, tried oiling the screws and rails. No chips on the rails or screws. I was cutting aluminum the other day that was making more or less of a dust, but it doesn’t look like it’s inside any of the screws or rails. Does anyone know what the problem is?

Have you checked the bolts on the Y axis assembly? I had a very similar issue the other day which was actually quite dangerous, where the two bolds holding the sliders on the Y assembly together on the left side had almost entirely worked themselves loose. It may be worth unplugging the wires from the control board and manually moving the various axes to ensure the movement is smooth.

If that’s not it, do you have a video of what’s going on that you could share? Also, are you noticing poor cut quality/issues, or just the noise?

Video is up, I didn’t realize you couldn’t drop MP4 files so I added a youtube link.

All the screws are tight. It makes a really loud whirring sound when going backwards to reach the limit sensors, and a vibrating sound when the X axis does finer movements. Otherwise when jogging it sounds normal.
It also says that it couldn’t clear the limit switch half of the time when I try to initialize.

I was boring out a lot of holes for a fixture plate but decided to stop halfway through as it was getting late. When I initialized the next day it started making the sounds like in the video. I looked around and found a loose nut at the end of the left Y axis: HDM rear ball screw loose - #3 by Robthatguy

I tightened and added Loctite yesterday and tried to continue the operation today but same thing happened on the initialization cycle. I tired to continue but it was making the same vibrating noises when boring, so I stopped.

I feel like it could be a software/controller issue? It jogs normally and only seems to act up when either moving really fast or really slow. I want to try and completely reset the machine but I don’t want to lose the current zero that I have. Is there a way to save it?

Have you confirmed your limit switches are working properly when you home? It seems like the motors are missing steps or stalling due to hitting one of the physical limits. Carbide motion has a place where you can see when a certain component is activated, perhaps in settings.

Apologies if you’ve already tried this, but hearing that you are having homing issues makes me immediately think about the limit switch or switches failing.

No worries, all suggestions are welcome. I tested the limit switches using the screwdriver method, the red light turns on for all of them when I hold a metal object close to it. I think I’ll check directly with the software but they should all be working.

When I first got the HDM I also had homing issues but they seem to have gone away after the new setup interface was introduced, until now.

I just disconnected all the stepper motor couplers except for the Z, all of the axis move freely. I’m not sure how much friction there is supposed to be but there is a very noticeable amount on all the axis.

The X Does seem to have more friction than the Y, especially as it gets to the limit switch side where it takes more force to move.

Edit: A long time ago with the older software the rapid position function used to go completely haywire. Sometimes it would move in the complete opposite direction than what I asked it to jog to and ram in to a limit switch. It hasn’t done this since but I though it might be of use to bring it up.

Ok, I’m feeling pretty lost.

I just reconnected the steppers and now somehow it’s working normally again.

C3D has had a lot of connector problems. So check your connectors that in the female sockets are not coming loose and being pushed out. If you feel that the connectors are hot after running that is a clue of a connection problem. They are using some new connectors that I cannot recall the name of but connectors are always a point of failure on any connection. Push both sides of the wires at the connectors to make sure they are fully connected/engaged.

1 Like

I’ve recently responded to your ticket.


I’m surprised you haven’t reported back some good news yet! I had this same issue and was all to do with the nuts accessible the plastic caps on each axis. A little tweaking and my issue was no more. Got back 10nm torque from C3D support.

All the ball screw nuts were tight so I don’t think it was caused by the ball screws itself. I did a linear rail alignment as well as made sure that all the connectors were properly seated, which seemed to have solved the issue.

Oh yeah, awesome. I did the same thing at the time I tightened the ball screw nuts since I was tramming it anyway. Happy Saturday!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.