HDZ hits Z limit switch and doesnt stop

I started my Shapeoko today. Im installing a new wasteboard and decided to reset the settings. I set the system to the default XXL with HDZ.

During the initialization the HDZ hit the Z limit switch and didnt stop. When it hits the limit switch it keeps buzzing.

Any ideas?

Make sure you’ve sent the machine configuration per the assembly instructions for your machine: Shapeoko Quickstart Guide - Carbide 3D and that the configuration matches your machine and its accessories. Configuring a machine using Carbide Motion 5 and for 517 and later: Setting Grbl Configuration in CM 517 and later or see the ~14 min. mark of this video: Shapeoko Pro Assembly Overview - YouTube, for the Pro see: Sending Config Settings for Shapeoko Pro - YouTube and https://docs.carbide3d.com/assembly/shapeoko-pro/xxl/Shapeoko_Pro_assembly_guide_02-05-2021_v1_web.pdf

There is a basic page on troubleshooting the homing switches at: Home Switch Troubleshooting - Carbide 3D

There is also a Carbide 3D Answer video: Basic Shapeoko Limit Switch Troubleshooting - YouTube

For the new inductive homing switches: Troubleshooting: Proximity Switch Troubleshooting - YouTube and Adjusting: Adjusting the Proximity Switches - YouTube

Thanks Will.

I used this time to install the proximity switches i bought a while back. Everything working great with new sensors.

1 Like

So heres another problem I am running into now.

The Z isnt going down all the way. I reset all setting and sent configuration data. Attached is the screen shot of the settings i have. You can also see in the background the z axis level isnt even at zero and wont go down any further.

Worth noting that I have the HDZ.

I manually edited the Z dimensions to 120mm and its working.

Curious if the default Z travel is incorrect? Im running version 521 of CM.

The Z-axis Travel Dimension was wrong for the HDZ in some older versions — please update to a new version:


If need be, you can update the Travel Dimensions.

Thanks WIll. Ill install the newest and try again.

Where your travel dimensions read Z 95 - this should read 150.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.