HDZ & Suckit Ears X Axis Limit

Hi,
With HDZ and dust boot ears installed are there any recommended settings that helps to avoid the dust boot ears crashing into the left x-axis endplates?

I tried settings $130 to the value measured in x axis travel in CNCJS to avoid the crash. But the movement is not stoped at the value.

Did I thought the wrong way? Am I doing anything wrong?

In addition to adjusting $130, you need to turn on “Soft limits” by setting $20 to 1, and then it should stop at that value.

(Soft Limits are disabled by default in the GRBL configuration that Carbide Motion sets when you click “Send Configuration”, because CM has its own internal limits that it enforces)

1 Like

Thanks Julien didn’t know Carbide Motion has its own limits.

I will double check $20 and see if this works.

Is it a good idea to set a Maschine profile in CNCJS as well?

I am pretty new to CNCJS…

I guess it does not hurt to do it, but quite honestly before you mentioned it in this post I had not even noticed that this existed in CNCjs, and have been using it happily for a while now without any machine profile defined. It seems like it captures min and max X/Y/Z for the machine, maybe to enforce them in software inside CNCjs itself (like CM does) ? Time to ask our CNCjs guru @neilferreri for confirmation!

After some research in the release notes it looks like the machine profiles only apply to the 3D visualizer… But still a cool feature

1 Like

The machine profile in CNCjs set your soft limits also. Try changing one of your numbers and see if you can rapid out past that number. As long as you have your soft limits enabled it works extremely well.

I don’t use machine profiles in CNCjs (never saw the need), but are you sure it sets your machine limits? I don’t think it does. That sounds like a recipe for disaster if it starts changing your $130, $131, & $132 values for you.
As far as I know, it’s just to visualize the work area of your machine.

1 Like

I used the machine profile to set my limits. I never actually changed the GRBL settings myself.
At first I did not have enough travel for my Z, so I changed my Z in the machine profile, re-homed and all was well.

I just played with it a bit. As far as I can tell, the machine profile should have nothing to do with your limits. You’d have to manually change the $$ settings.

$20=1 did the trick thanks again Julien

After setting the limits in grbl everything works fine now. I also played a little bit with Maschine profiles and I also did not see any influence on the limits…

1 Like

Weird, It’s been a little while, but I’m sure I didn’t change the limits manually. Maybe the control has to be reset/restarted after the change is made to the machine profiles?

Jumping in here with the install Instructions The Ups & Downs - Installing the HDZ

I just got my hdz and in quickly reading it appears that it shouldn’t get close to the left side if you set up per instructions… am I wrong?

OK, I’m completely wrong about this. I just checked on my machine. Machine profile is just for UI display as @neilferreri said. Sorry

I have not actually checked but my understanding is that if you are using CM 4.17 that has the “HDZ” option in the configuration, indeed the internal software limits should ensure that CM does not let you get too close to the left (and right) side, even with dust shoe arms installed. The only limitation is that to ensure this, it limits the X travel to a narrower range than what the machine can physically do, so the discussion above about tuning $130 and using other G-code senders (like CNCjs) is more related to the case where people want to maximize their X travel, by manually jogging very close to the limit on the left, and setting the $130 parameter themselves in GRBL based on this.

Absolutely that’s the really cool thing about the shapeoko, you are able to tune such things and try to get the best performance out of it.

and i think i was able to jog the dust ears against the left x axis end with carbide motion too.

I, I agree with that, but first thing out of the box was how to keep from crashing z into endplates…

I am also experiencing this issue. I have an XXL with HDZ and have the Suck It Ears installed on their maximum installation position as I have the heavy duty 65mm spindle mount also.

Once homed, if you jog to the NW, W & SW position, the Z assembly collides with the left Y plate assembly. I beleive there is actually only approx 809.275mm of X travel when installed. Not 830mm as detailed in the settings tab for an XXL with HDZ installation.

It seems that another tick box is required to identify if suck it ears with HD spindle mount is being used!

I will have to manually override the max X travel for now - pending (hopefully) a new Carbide motion release.

Overridden the max X, Y & Z travel parameters, as well as enabling $20. The problem now is the rapid position icons - as these are hardlinked to X & Y locations which are outside of the updated parameters for X & Y it throws an error when out of of bounds.