Help - I'm "cutting air" again

Hi all - this happened once before, like the very first time I used it. I had the material thickness wrong and changing various settings fixed it.

Now today, regardless of how I set zero (manually or with the BitZero), it won’t make contact with the surface. I’ve tried several (6-7) attempts at different pictures. Thin pieces, thick pieces, warped wood - everything.

This piece is perfectly straight and measured thickness with calipers. Totally and helpless lost here!!

EDIT: Sorry, the gif won’t size correctly, but imagine it just hovering and cutting nothing.

Post the g-code file for a check. Maybe you had stock thickness set to “bottom” when you exported the g-code?

1 Like

Thanks - attached. (239.4 KB)

1 Like

The gcode is fine, can you describe precisely what steps you follow to set Z zero?
How high is the cutter hovering over stock top?
After you zero, if you job manually to z=0, does it match stock surface?
Are you using a BitSetter and if so did you remember to use “change tool” when you loaded the first tool after machine initialization? That would be my bet (you installing the tool without using the change tool menu)


Thanks Julien,

I’m putting the BitZero at the bottom left of the material, choosing the option for X/Y/Z probing, and using a #201 bit.

It’s hovering at least 1/4" or more over the surface.

I haven’t tried jogging to zero and see if it matches, but I’ll do that now.

Yes, changed tools after zeroing. I’m using a V to cut the project, so I keep having to switch between the #201 to probe and the #302 for the BitSetter.

Did you use “change tool” button in CM both when you loaded the 201 initially, and when you loaded the 302 before running the job? It’s quite easy to forget and if you just physically install the new bit without telling CM, this will throw off your Z zero


Hmmm… Good question.

I just went to X-zero (Zero+6mm I believe it says?) and it is measuring 16.5mm above the surface.

Manually jogging to zero then checking “Set Current Position” shows Z at -0.365

I suggest you try the following:
Power cycle the machine
Initialize machine (machine goes to bitsetter with whatever tool is installed then)
Click Change Tool, follow prompts to install 201
Probe with bitzero and 201
Run job: CM will prompt for 302, install it and continue, machine will go to bitsetter again and then run the cut.
This should work.


Will do - I’ll post back later tonight.

Thanks for everything!

1 Like

(I’ll be asleep, it’s midnight here, but others will follow up I’m sure!)


Ok, that didn’t fix it.

I went in and manually set the Z zero and now it’s making contact, but just barely. The stars are more like circles, and the writing is barely visible.

how confident are you that you got the “bit zero on top” versus “bitzero overhang” right?
(it looks like your zero is higher than the actual material)

One thing you can do is in the MDI screen type

G0 X0 Y0 Z10

which should put the bit exactly 10 mm above the material.
You can then in the jog screen take 1mm at a time steps down to see if it;s really 10

(once you get close be careful, you obviously don’t want to just drive the bit all the way through the material)


This is what it looks like

I’ll give that a shot.

btw once I had something like it, and it turned out the bit was a bit lose in the collet and got driven up into the router during the bitsetter probe… which then of course made it cut too high.


Ok, making progress!

This time I used the BitZero to set the X/Y/Z, then put the V bit in and manually set the zero for Z. Ended up being a bit lower, and of course, you can see it worked.

There is something off when the following happens: I use the BitZero with a #201, set X/Y/Z, run program, get prompted for tool change, switch to a #302, BitSetter checks the new bit, and the program runs.

Somewhere, somehow, in that process the Z zero is changing and I have no clue why.

Any thoughts on why using the BitZero/BitSetter combo isn’t working, but manually setting zero with the V bit is?

1 Like

how did you put the very first bit in? It is super important to use the “change tool” menu in CC before you do the original zeroing, instead of just putting the new bit into the router.

(btw those look like really nice clean cuts… so something went quite right there)


I turned the machine on and initialized it. Goes to the back right, does its thing, then it comes to the front center and says something like “insert tool” (I do and hit continue) and then goes to the BitSetter checks depth and returns to front center. Then I put the BitZero on the material and do the zero process.

Am I missing something here?

1 Like

nope that should be fine…
The most important thing is that it does the bitsetter measurement right before you use the bitzero.

So something is slipping most likely, @WillAdams has a checklist for that, but maybe something to look at next time, and see how much the bit that keeps changing sticks out of the machine… maybe use a sharpy to mark it just below the collet nut when you put it in… if that sharpy mark goes away into the machine… your bit slipped …


Thanks for the help so far, I do appreciate it!

1 Like