Help! Z Axis going crazy and grinding

Hi, I’m new to CNC and the Shapeoko Pro is my first. I got it assembled, made the newb errors otherwise seen on this forum (switched the L/R Y axis wires, Y limit switch was too high, etc.) but generally got it up and running and even made a few things.

Then, out of nowhere, I’m initializing the machine and the z axis starts to go crazy, moves up and down rapidly, sounds like it’s grinding, and does this.

The first time this happened I turned off the machine, turned it back on, and everything worked fine. Even completed another project. Then this happened again, and has happened the last few times I’ve tried to initialize.

Any help would be appreciated. Thanks.

Austin

I would check the Z axis wiring, looking for bad connections or broken crimps. It sounds like only 1 phase of the motor is getting energized causing it to cog back and forth.

2 Likes

Completely agree. That is definitely a phase of the stepper not energizing properly. Most likely a loose connection. It might be a bad wire though.

1 Like

Hey, I appreciate the help. I disconnected all the wires, made sure everything was loose, nothing is crimped, hit the connections with compressed air, and reconnected everything. After doing this it initialized properly, I was able to use the bitzero, and even got most of the way through another project. However, on the last pass it was supposed to take it did the same thing again and drilled down into my waste board.

It’s hard to look for other crimps because of the jackets on the wires, but I imagine if those aren’t pinched the wires inside should be fine?

Any ideas on how to workup or fix this? Also, I keep trying whatever random thing to fix it and then initializing and it cogs back and forth again, is that bad for the motor? I mean, i plan to keep it to a minimum, but should I actively avoid running the z motor unless I think I have a solid solution?

Again, thanks for the help, I really appreciate it.

I’d recommend you reach out to support@carbide3d.com. They will be able to help you out. If they can’t find the bad connection while troubleshooting, they may want to have you replace the Z axis motor power harness from the motor back to the board.

Do you have an ohm meter? If so you could try to ring out the harness while flexing each connection and slowly moving X & Y just incase the issue is in the wire and not at a connector.

If you can’t easily see the crimps it is hard to say that they are correct or not, without measuring them with a meter. They can feel tight but be crimped on insulation or only have a good crimp on the strain relief portion of the crimp.

3 Likes

I had the same thing happen on Saturday. I am reaching out to support this morning.

I did what LWSIV recommended (thank you, sir). Ohm meter showed continuity through all wires up to the motor. I switched z and x motors and everything worked ok. Then reconnected everything and its working fine now. With it being intermittent its probably luck at this point, and will recur soon enough.

Let me know what you come up with, I work from 6a to 6p the next 10 days and won’t be able to talk to support for a while. Good luck!

The crimps are what connect the pins at the end of the wire. @LWSIV was suggesting that there may be a bad connection there. That would be more likely than a broken wire (still possible) on a new machine.
You probably don’t need to talk to support. Link them to the video in your email message and they’ll take care of it.

I got a similar problem. I haven’t used the Shapeoko XXL in a couple of weeks. The last project I ran went fine. I fired it back up yesterday, created my file, made sure that I was zeroing out from the surface of the wood. Initialized the machine, it went to the home position just fine, reset itself. I rapid positioned to the Zero location, started my job. The Z axis went to the top position, grinded a little and then dove down to the start of the project. All the way to the wasteboard and not the top surface of the material. I double and tripled checked my file and all seems well. Reinitialized the CNC, just to be sure, went through the steps above again and same result. Do the homing switches go bad? I’ll double check all my cabling tonight, but nothing changed from the last time I parked the machine a couple of weeks ago.

@lcifers It sounds like your retract height might be too high.

2 Likes

I sent them the link to @ManBearPig video

I located what may be the problem. A loose wire from the back of the connector on the z-motor wiring. I pushed the wire into the connector as best as I could and this allowed me to initialize the machine properly.

The red arrow points to the loose black wire.

Please contact us about this at support@carbide3d.com

@WillAdams I have sent all the information to Fleming Valenzuela. Thanks.

1 Like

With power disconnected, give that wire a gentle tug. If it stays put, you’re probably good.

It won’t stay put. Carbide support is taking care of the issue for me.

As they do…

I had the same problem and it was the black wire also.

Hey, I tried gently pulling on the wires and as can be seen in the picture, for me the white one just came out without resistance.

I’ll contact support and report back with what happens.

Thanks for all the help

It also looks like your wire colors are not matching across the connector, be sure to mention that as well. Verify this at each connector for all axes, just to be safe.