Homing switches

Hello, just assembled my XXL and tried to home it. Followed all directions in owners manual and first thing it did was crash into a limit switch, using Easel I was able to jog machine in correct directions, back to Carbide Motion retried to home and z is randomly moving up and down then will stop randomly 1/4 inch from spoilboard or half way up. Homing switches all react when I put a wrench on them.

Did you send the correct machine configuration?

Please see:

Are you sure the machine isn’t on a homing switch when you first start it up?

Please let us know at support@carbide3d.com if you continue to have difficulties.

Yes did all configurations as Shapeoko 4 XXL, checked wiring multiple times. In Easel I can move machine in all of the correct directions. Z axis just does some weird stuff when I hit initialize in motion.

Does Easel initialize/home the machine?

What does the Z-axis do when you try to initialize/home the machine using Carbide Motion?

No easel does not home machine, Z will travel up and down repeatedly then either stop 1/4 inch from spoilboard or half way up axis. Sometimes il hit up z and it will go down other time it will go up when I hit up. Have no clue what is going on.

Don’t use Easel.

Send the machine configuration.

Then, verify that the machine can mechanically move so as to activate each homing switch.

Then, test each switch and verify that it signals as the correct input under Active Inputs on the Settings pane.

Then, verify that each motor is wired up correctly — remove the belts for the Y-axis and put some tape on the pulleys so as to more easily see their rotation and try to initialize — the machine should home the Z-axis successfully — does it? Once it homes Z, it should then begin moving both the X-axis and the Y-axis — does the X-axis successfully move and home itself? The Y-axis should rotate the motors until that axis times out — do the motors turn evenly and in synch?

Let us know what you find out at support@carbide3d.com

It hasn’t made it through Z homing so no idea on X. and Y I tried sending video but file is to large

I’ve done the machine configuration 6 times and no luck, belts are at 3 pounds, all wiring is correct according to manual and tags on wires.

The homing switches can activate with a metal tool but may need to be adjusted to trigger. With power off move your machine to the homing position. Power on but DO NOT INITIALIZE. See if the switches are showing activated. If not adjust the switches until they activate. The Z is a little harder but you can manually turn the leadscrew until the Z is at the top.

Use CM to get set up and then use what you want. Using CM will help eliminate the variables that Easel may introduce.

1 Like

Done all that, yes switches trigger when the y limit standoff is above switch, X triggers when near plate and Z triggers when it is close to switch

Try this.

move the gantry to the front of the machine and the Z assembly to the right side about 4 inches off the left rail.
Remove the cover from the main control board.
power up the machine no need to initialize it.
use your router wrench or anything metal and place it on the proximity switch.
You should see the following RED light on the proximity switch should light and the connector on the control board for that switch should have a BLUE light on at the same time.

If no red you have a problem with the wiring
If you have a red light but no blue you have a problem from the proximity switch to the control board.
could be as simple as the connectors just check the wiring.


All have red light, X and Z both show blue light on X in controll panel.


Check all the connectors and pins. Look for pushed out pins before you open the connectors. Open each connector and look for burned pins, pins that are pushed out. When you reassemble the connectors always check for pushed out pins.
You should check the connectors on the proximity switch too for the above.


Why are both Z and X triggering blue light on X in control panel? Y is good. Nothing with blue light on controller.

Also in Motion machine setting I get X pop up when I put a wrench on both X and Z, I get a Y when I hit Y switch.

Each axis has its own blue indicator light. If you don’t have a blue light for each axis you should check your wiring and make sure the hardness are connected the the proper terminal on the control board.

My opinion is you may have some connector issues

You should try ding this again and while moving the Z axis wiggle the connectors for the Z motor and watch and listen for motor or sound from the motor changing


Appreciate the replies, I’ve checked and rechecked all connections, labeled wires are where they are supposed to be according to manual and labels so I’m at a loss.

Please write in to support@carbide3d.com

Went through all connections, since my vision is longer great I used a magnifying glass at controller and there on z mother the white wire was sticking out about a 32nd of an inch pushed in and holy crap got my first homing cycle! Thanks brother!


That is great
Make sure you send a repair request to support and get a replacement harness you don’t
want that to happen again.