Hopefully my last Z issue

I noticed that Z is cutting off just a bit. If I use Bitzero it will cut above the surface. If I use the manual method it cuts at a .25 in deep, when I have the cut depth on the tool, and in the set up to .125 in. In the quick actions tab I hit the plunge to one inch above zero, and it stops at 1.5 inches. I am sure I have a z issue, but I am not sure how to right it.

Please note that the BitZero may be positioned in one of two ways when probing Z:

  • fully registered on the lower-left corner — this allows probing all 3 axes
  • fully on a surface — this allows probing for Z only

See the appropriate instructions at:

I appreciate the info on Bitzero, but lets take that out of the equation. The question was really geared more to why z is cutting deeper than what it is programmed for. I would think that these issues are connected. As stated above, I have everything set to .125 in deep cuts, but when cutting the wood, it cuts at .250, which is throwing everything off. It does this while doing a manual zeroing, not Bitzero. It also stops 1.5 in above the material, not 1 inch, like it is supposed to do in the quick actions. Is there a way to set z where is needs to be? I think it is off a bit, and I not sure how to calibrate it correctly.


When you manually jog the Z axis in the air by 1inch from carbide motion, does it move by a different amount ? If so, you may want to go back and redo the setup of your machine, making sure to select the correct Z axis type and resend configuration. It’s an easy mistake to make (people tend to confuse the original belt-driven Z axis, the Z-plus, and the HDZ)

1 Like

I originally did have the wrong machine selected. These knowledge people here helped me get that sorted out. I will try to jog it and see what the numbers show.

did what you said, and when I zero out Z on my bed and raise it to one inch, per Motion, the bottom of the bit, it 1.5 inch. So I went and did all my machine settings again, re initialize the machine. Repeated the process, and still it sits 1.5 inches above the surface.

Please provide step–by-step instructions for how you are securing your stock, setting zero relative to it, and managing all tool changes — a video showing the entire process would help as well.

to add on to Will’s request, it will help if you provide detail of exactly what you did in the settings. Which Z-axis type are selecting, and can you upload a picture of your Z axis ?

SO3 XXL with Z-plus according to this thread.

I am selecting the HDZ one.

In this case, since I am just testing z axis, I am placed the rod that comes with the Bitzero 2 to make sure I had a good flat surface. So I moved the gantry to a spot, and move the rod down to where it was flat on the board, not pressing into it, just lightly touching it. I then zeroed out the machine, and then I tried two things. The first way I manually moved the Z axis up, till z registered 1 inch in motion, and then I measured it. The ruler in this picture is 1 inch wide. The gap is 1.5. The second way I did it, was I used the quick actions, and let the machine move it to 1 inch above z, and the same result.


you have a Z-plus axis, not HDZ.

Same conclusion as the older thread @BrokenEndmill pointed to, where you had the same problem and fixed it by setting the configuration to Z-plus, not HDZ. It’s an easy mistake, but it cannot work properly if you don’t set the Z axis type properly in the configuration.

No, I checked all that. I made sure check it in both places. It is definitely Z, HDZ. In fact I did have it wrong, because the travel dimension for Z was 90 MM I think, and it switched to 140 when I selected the correct Z axis.

I would ask. When I went in to the travel dimensions, and selected the 3xxl, and then selected the HDZ, I went back into the settings, and when I went to Z again, it had the wrong then selected. Should it retain the HDZ when I leave and go back in, or will it always show the default selection?


there seems to be a misunderstanding: what you have on your machine is not a HDZ, the model of Z axis you have (as shown in the picture you uploaded) is referred to as a “Z-plus”, so this is what you must select in the settings. Ignore whatever Z axis type is shown when you go back in the menu. At the moment you select from the list, you must pick “Z-plus”.


I guess that is where the confusion is. I thought I was told it was a HDZ when I was trying to figure out what Shapeoko I had. I will adjust to that, and see if that helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.