How do I delete a toolpath on my MacBook Pro

I select the toolpath, press delete, nothing happens.

Depending on the specific keyboard layout it might be fn Delete or Backspace?

Hi, Mac does not have a backspace. Delete does not work

does press the fn (function key) and delete (the delete key) as I was trying to indicate by

fn delete

work?

1 Like

Are you using a mouse? If so right click and try delete from the menu.

1 Like

Another option is command x — it will delete the current selection if the focus is in the object in the drawing area, and it won’t disturb the contents of the clipboard since command c is duplicate, not copy.

Hey thanks, I was using the track pad. when I plugged in the mouse, the drop down menu offers delete.

I seemed like you said “CMD X” won’t disturb the contents of the clipboard?

Correct. In the context of using Carbide Create, if you copy (for example) a number from a text field in Carbide Create, switch to the drawing area, use the command x keyboard shortcut to delete something selected in the drawing area, then switch back to a text field in Carbide Create, command c will still paste the previously copied number.

(I tested this on my Mac to be sure it worked thus before posting it)

So, CC doesn’t implement standard keyboard shortcut behaviors that have been around since the teletype? :smiley:

Since the 1984 Macintosh or Apple Lisa, no.

Unfortunately, Carbide Create doesn’t support the pasteboard or copy/paste.

On my mac I press the right button of the mouse, and click delete.

Mac supports copy and paste. Command C for copy, Command V for paste, Command X for cut.

In Carbide Create?..

1 Like

You know, I did have an issue copying and pasting. I’ll double check tomorrow.

I’m afraid Carbide Create doesn’t support the standard copy cut and paste commands fully.

They work for text/numbers in the parameter fields, but in the drawing area, copy duplicates, cut deletes, and I don’t believe paste works.

Please see:

I tried this morning and it works just as will said. Command V does nothing.

1 Like