In Need of Help

Hi everyone. I’m Kelly. I bought my XXL Pro and after waiting on a friend for a few weeks to come help me get it set up, I gave up and built it myself. Now I’ve been waiting to get him over to help me do the set up and work with me on the design software and to no surprise I’m still waiting. I’m in the Clinton Township, Mi area. I don’t suppose there is anyone in the area that would be willing to help me out is there? I just ran all new power in my garage, insulated it, hung drywall, bought an ac/heat unit, dust collection, a laptop and a few other toys. I hate having my new machine sitting out there not being used.

What difficulty are you having?

Did you do “Hello World”?

Have you tried watching the videos:

and seeing if the first 5 projects are a good fit?

Or, if you’d rather written instructions:

If you have any difficulties, please let us know, either here or at and we’ll do our best to assist.

1 Like

I’m very new to the cnc world. I’ve been watching the tutorials and all the Youtube videos that I can find. I’m more of a hands on learner. I just seem to get a better understanding when I’m taught while actually doing the task. I bought the cnc with the understanding that my buddy was going to help me out but he has proven to be very unreliable.

We will gladly do our best to assist.

While the machine en toto is complex, if you break it down into individual components things are far simpler.

Similarly, complex projects can be done based on an assemblage of discrete aspects — but start w/ something simple, in some piece of scrap, make the workholding easy (just clamp at the four corners) and try things out.

Build on successes and learn from failures and problems.

Let us know where you get stuck and we’ll work through it w/ you.

Thank you. I’m sure I’ll figure it out over time. I thought I was going to have trouble building the cnc but the instructions proved to be very detailed and made it possible for me to not only build myself, but to have fun during the process.

1 Like

Welcome to the Shapeoko Family!
I too have the same learning aptitude. But I am one who can’t stand waiting on others. I just go for it on my own and proceeded very cautiously.
This site has been very helpful in whatever questions I have come up with. Now I even find myself being able to help others here.
I don’t know where Clinton County is in MI, I am in northeastern Indiana myself. Allen County to be specific or more precisely Fort Wayne.
Since you are on this site now, I am sure you are well on your way to completing your first project. I hope you post it for all of us to see.
Best wishes!

Clinton Township, and its on the north east side of Detroit. I recall another member living in that area.

I’m in Algonac, right by Anchor Bay Drive. I’ve only had my HDM for a couple months, but it’s been busy. I’ve been in the CAM / CNC business for… a really long time :smiley:

Send me a PM, and I’ll try to make some time to come over & get you over the first couple hurdles.

Be Well


That would be great and much appreciated. I’ve put a lot of time, sweat and money into getting set up and to have a friend keep letting me down has been pretty disappointing. I’ll PM you to see if we cant set something up. Thanks again.

I hooked up my computer to the cnc, went into Carbide Motion and clicked “Connect to Cutter”. Keeps giving me an error saying cutter not found?

There is a basic page on troubleshooting connection issues at: Can’t connect to machine or jog - Carbide 3D

Things to check:

  • power supply plugged in — it lights up after being plugged in and stays lit with a steady light?
  • power supply connected to machine and switched on — the in-line switch is small and easily missed (try toggling on/off a couple of times) SO4/Pro — machine power switch is switched on and lights up?
  • machine boots up, controller lights up with power, lights flicker on/off, motors lock?
  • machine connected to computer using USB — computer registers USB device? red/green/white lights on controller begin to blink signifying USB communication?
  • How is the USB connection being made? 6’ or less is recommended, and poor quality adapters cables are known to be problematic
  • Are there any conflicting devices in the USB Device Tree? Even a pair of Bluetooth speakers can conflict
1 Like

Power is plugged in, switch is toggled to the on position, power button on the front of the machine is on and lit up, usb that came with the machine is connected. I uninstalled Carbide Motion and reinstalled it. Still getting same error.

Please contact us at

Let us know that you’ve seen the above list and also let us know what is showing for USB devices.

All of my power connections are good, green light on the brick is on and steady, blue light on controller is on and steady and the blue light on the front of the machine is on and steady. USB is plugged in and my computer sounded signally it recognized something being plugged in. But my computer will not recognise the controller and can’t find a driver that will. I had someone log in and go through my computer from their computer and he is saying that he thinks the chip in the controller for the USB is bad.

Try plugging another device into the USB port on the computer and see if it recognizes it. Like a wired mouse or USB memory stick. If that works try another USB cable if you have one.

Open up the Device Manager and look under Ports (Com & LPT). Turn the power on to the machine and see if you see Shapeoko 3 (Com 7). It might say another Port If its not there the driver for the Shapeoko is not loaded or it doesnt see the device. Maybe bad controller board

Right Click and go to Properties. Then to port settings.

I’m not sure what the correct port settings are but mine says
Bits Per Second 9600
Data Bits 8
Parity None
Stop Bits 1
Flow Control None

I connect to mine with Putty using


The com port seems to depend on which USB port I use?? (I thought they were dynamic)

It sounds like the PC is not finding the driver when it gets plugged in. Which OS? I had to install the driver manually on Windows 7. I’ve since upgraded to windows 10 and it all worked perfectly.

1 Like

I have windows 10 on my laptop and we were trying to install the drivers manually. I tried all of the usb ports on my computer and got the same result. Im going to screen shot the image you sent me and send it to my buddy. He’ a computer and cnc guy. I appreciate everyone trying to help. Great community.

Hey guys. I appreciate everyone’s help with the issues I was having getting my machine up and running. Turns out it was shipped to me with a bad control board. Once I talked to a tech at Carbide on Monday, they determined it to be a bad board and shipped a new one. Received it today and my machine is up and running. Did my first which was a Corian cutting board. Program ran fine until the last pass on the cut out. My bit loosened and ran into the table. Lesson learned. I’ll be back out there tomorrow to experiment some more. Thanks again for the help.


The Carbide Create learning videos are very helpful so are Chris Powell at Full Steam Designs. You tube can be your friend. Start small and very soon you will be on your way.

Here are some of my projects, this is after a year of using the same machine.
Best of luck! Tom


That is very nice work. I did a simple half inch thick Corian cutting board for my first project. Just a basic rectangle, handle hole, 3/4" rounded corners. Everything ran great as far as cut speeds, pass depths, etc. As it cut, i just apparently didnt have the collet tight enough and the bit worked its way out of the collet a bit and on the last pass when the Z dropped for the final cut…into the table it went. Being new to the cnc world, im not discouraged. I expect to make mistakes. Im just going to learn from them and press on. Thanks for sharing your work.