Initial install GRBL Error: homing Failed, Couldn't find limit Switch

Im setting up my Shapeoko XXL for the first time. After I run through the setting I click the “Initialize Machine” button. The Z- Axis starts traveling down. After a few seconds it stops and I get the error.
I used a suggestion from another forum to put a piece of metal over the limit switch. The light does not come on when I put the metal in front but it does when I put it under it. So the switch is getting power. This is the switch that was pre installed.

Did you send the configuration corresponding to your machine/Z axis ?

Hey Julien, Yes I sent the Configuration after I Chose Shapeoko XXL and then Z-Plus Lead screw. In the Manual its states the Z axis will move up( the positive direction) but mine moves down. Also no matter where I manual put the Axis the light doesn’t come on. Only when I hold the router wrench under the Homing switch.

i got it. Had the wrong machine picked… Thank you

1 Like

i am setting up my xxl pro for the first time and i don’t get any movement only GRBL switches not found homing failed.
image

There are several options for choosing your machine in the settings. Mine isnt the Pro but once I had the correct one picked it worked for me…

i picked the xxl pro

Please contact us with the specifics at support@carbide3d.com