Is there a method to test stepper motor strength?

I have been running into lost steps lately on my x axis stepper. It’s not the belts slipping it’s the motor loosing steps.

These are known good files and speeds and feeds. Yes they are on the fast side but I’ve been running like this for 6 months.

Is there a simple way to test motor torque. The holding power does not seem strong enough to me

1 Like

I’m not sure I see a reason for the stepper to lose torque, generally steppers and drivers work until they don’t work any more.

It could be that friction is building up somewhere and using up stepper torque?

I did inadvertently test holding torque whilst testing deflection and stretch, but this is really not the sort of thing that the Carbide support folks are going to recommend that you do to your machine…

This has been done before, answer was about 18lbs force I believe;

The other way to do it would be to hold the Z carriage back with the luggage scale and step away from it, still not particularly good for the motor or belts though.


Many many years ago I built a small dynamometer to test my x, y and z motor’s torque. (Single motor axis, was 18 lbs, dual motor was 36 lbs). I use the luggage scale (photo) for the measurements. It worked great. I’ll look for a photo of my setup…

A bit crude, but it worked like a charm:


knock on wood, I think I have it fixed. I was wrong about the motor slipping and not the belts, went to tighten (more like over tighten) the belt and I was having issues so I pulled on the belt and it snapped, Im thinking the steel cores broke and the rubber was stretching back on me.

Chinesium back up belts are on right now working on a cut, so far so good, Ive made it further than I have all day working on the same piece of wood.

And I spoke to soon.

Well I think I have over looked a basic item.

Looks like I wore out a a mama 1/4” down cut bit for the first time. Put in another one (longer bit but other wise the same, except not worn out and nearly new) and no more issues(yet)


Recommend you power off your Shapeoko and move the machine slowly, too fast and you get emf force, from front to back and side to side. The machine should move smoothly and with about the same force all the way front to back and side to side. If you have mechanical issues they will show up in the cutting because you are having to overcome the mechanical issue as well as move the axis.

1 Like

read above, It was a worn out bit

1 Like

Well it I’m not sure if it was the bit. Seems to still be having issues. Went out and bought brand new Bosch 2 flute bit. Cutting .23” doc. It’s. 1/4” up cut. 18k rpm.

I normally cut at 180ipm with my amana bits. I slowed this down to 100 ipm and was still having last steps on x axis. So I ran it at 30 ipm and it doesn’t loose steps but it’s not smooth by any means. Very jerky on the x axis. V wheels are tight.

This is frustrating.

The larger motor linked above is interesting. What are the specs on the drivers on the carbide board? Wil it overload them ?

If your machine has recently changed it’s behaviour then it shouldn’t be necessary to upgrade, just to revert it to normal performance.

Is it only in X that the machine misses steps at this feedrate?

Try a cut in Y right up close to one of the Y axes (you will get ~ 1 motor strength there instead of double), if you can only go, say 1.2x faster on the Y then the X and Y motors are behaving similarly.

Everything below should be prefaced with “call support and work through it” as the first option and these options as what one might do if too impatient and lacking in care for your warranty…

If you do have notably less holding power on the X axis, the pull on it with a luggage scale method works but be careful, when it slips it’s sudden. This would tell you whether you have belt slip, pulley slip on the motor shaft (draw the line across them) or the stepper is slipping.

Belt slip you can hear the teeth slipping over, the resistance drops a lot whilst moving and it stops abruptly when the belt re-seats.

Pulley slip you won’t hear any tooth or stepping noise.

Motor slip you’ll feel the judder and probably hear the motor making it’s missed steps noise (like when you accidentally rapid into a solid object) and the resistance is still quite large when moving.

It could also be that the Carbide power brick is EoL and going low-volt when the current draw is large (Ideally a voltmeter to watch said voltage, but that would likely be a warranty voiding, support person upsetting suggestion so I won’t say it).


The weird thing is that it does not do it consistently. I can run my roughing operations using a 1/4 down cut bit (amana) at 180 ipm, .25" doc @ 18k rpm and it will be fine 90 percent of the time.

I can switch to a compression or up cut bit running much lower feeds and loads and it starts missing steps, this even happens with 1/8" compression bits cutting through 1/2" baltic at 40ipm. sometimes it will do it after ~14" of cutting, other times it will make it through 4x 24" cuts then be halfway through the 5th and it misses steps and ruins the piece is cutting out. I do nested manufacturing mostly, So multiples of the same product from one board.

Then I had a bit come loose on me the other day and it was cutting through 1/" baltic and nearly nearly my entire upper waste board(3/4 mdf) before it started missing steps

It only seems to be on the x axis. I have not yet found a way to tell if its belt slippage or motor slippage.

this is just so frustrating, I need this machine to carry me through the next year or two when I should be able to build a real shop with a 5x10 ball screw machine.

This is a video of it running very jerky as described previously, this was a very low use bosch 2 flute up cut bit cutting through 0.23" of material at 30ipm, 18k rpm.

1 Like

Well it doesn’t sound very nice.

If you just use the jog / rapids to move left / right and fore / aft does the machine move smoothly and sound smooth in both X and Y directions without load?

It moves in all directions smoothly without load. Here is a video ox x axis rapids

I think that’s the same video as before?

yes it was, fixed it

1 Like

Right, that sounds happy enough, importantly it sounds like the stepper is running normally.

Have you drawn the marker line across the X pulley and motor shaft yet to see if that’s holding position consistently?

So it’s possible you have an intermittent problem with the motor or driver electronics but only when under load, might be the driver getting hot and limiting current (not sure if the drivers on the Carbide board do that).

Or it could be that the windings in the X stepper are damaged in some way, how hot is the X stepper running compared to the Y steppers?

1 Like

I’ll run another cut tonight and get some answers. Heading out the door now for dinner at my brother laws.

Ok I lied. Just got home. Will have to wait until tomorrow night to try it.

It occurred to me that given the history of your original fault with the VFD, the persistent EMI issues on the USB connection and now this that the controller board and PSU may well be common suspects…

1 Like

Yep I’ve been saying that. I’ve said it to support once or twice when talking about the emi issues and have never gotten anywhere.

Should have some brand new amana bits in the mail today to run some files and see what happens.

Sadly I’ve got a long history of wtf events with this machine.

1 Like