I've just scared myself!

OK, so I finished putting my XXL together last weekend - and even produced the ‘Hello World’ sample - and, having returned from a week away working, I thought I’d tidy up a bit, but now my XXL is doing a strange thing and making a worrying noise - and it hasn’t been touched since Saturday.

I turned on the laptop, connected the USB and started CM, and went straight to initialise - and this is probably where I went wrong, because the XXL went through the motions but when it to the back right hand corner, it stopped moving, but the motors kept turning, making the awful sound. I turned it off almost immediately, but it does this every time I try to initialise it - even if starts at the bottom left hand corner.

What have I done wrong? Do I need to run ‘Settings’ every time I start the machine up, or did I not complete something properly when I did close it down last week, so it doesn’t know where it’s at?

Thank you.

Mr Desperately Scared!

Check to make sure your limit switches are working. Look back in your setup instructions for how to check. It sounds like the machine isn’t sensing when it’s getting to the limits of it’s travel.

Simple fix.

And get used to that noise…you’ll hear it again :slight_smile:


I’m probably being a bit dim! I can find the bit on how to fit them, but not where on how to test them!

Should I redo the settings?

It certainly worked last weekend, though :anguished:

And that noise is scary :scream:

If I had to guess, your X limit switch is too high. If you push it up as high as it’ll go (as the instructions tell you to), it’s too high to sense the metal plate. This happened to me when I upgraded to Z Plus with the new proximity switches. Move it down so it’s closer to the end plate. Mine is less than 1/8".


I’m really sorry, but I can’t even relate what you’ve photographed to my machine.

This is what I see…

It looks like your X proximity switch is mounted incorrectly (your first pic). Here’s a pic from the ZPlus upgrade instructions:

The switch needs to be vertical, with the wire coming out of the top. Then adjust it so it just clears the end plate when jogged to the right.


But then I found this. Looks like there are two variations of X mounting brackets. Maybe somebody with the earlier version can chime in. I think that with your version, the switch needs to be moved farther to the right so it senses the plate before it crashes.


@NewToThis Peter: If you jog along your X axis until the carriage gets really close to your “Y” rails, you should see the light on the sensor light up BEFORE you make contact with the rail. If it’s not lighting up, you need to shift it out closer to the Y rail. You might also test to make sure the sensor is still seeing metal - put a pair of scissors or a screwdriver against the sensor and make sure the light lights up.

If it ran last week, but not now, might something have come in contact with the sensor (maybe the chain chase?) and pushed the sensor back? If you think that’s the case, you might want to contact support and ask for the newer mount. It just seems like a safer location.


There are two different ways to mount the X-axis switch — the instructions show an old way for previous kit iterations, newer kits use a different mount which goes in this other direction.


Is that your router power cord draped over your Y2 rail?

If your homing switches aren’t activating it will make that sound as the machine tries to find home, same sound as an obstruction. A router power cable hooked on something, or even a drag chain that has dropped below the bracket, They can all stop machine from moving.

One of my favorites lately is an errant scrap that is sitting behind one of the y plates. My machine likes to push those to the back and then jam up.

1 Like

In cm there is a screen to see the condition of switches when activated or not activated.

You can push the older switch to see if it activated or on proximity a piece of metal near the switch activated. There are also lights on control board that change when switch is activated.


Hi guys,

Thanks for your responses - they’ve been really helpful!

ScottsdaleSteve: The proximity switch is installed as per the provided instructions (and I did check!), which is consistent with the LH of your two images. The provided instructions are dated 03/27/2020 Version 5.0 (same as the onlive version - at the moment!)

GJM: I tested the proximity switches with a screwdriver, and the LED lights up when it gets close to the sensor. I’ll take a loser look at the ‘Home’ area and the LEDs on the proximity switches a bit later, but I haven’t done anything other than the ‘Hello World’ test project!

WillAdams: Thank you.

David.Curtis: That is the router cable but, again, it’s been installed as per the installation guide (although, to be honest, I don’t like it being there). The drag chain on L1 slipped off the guide and got caught behind it , and made the same noise when it ‘Homed’ after the ‘Hello World’ project, and Support advised me to tighten the retaining screw. I’ll need to run another project to test it, but it seems more secure now.

I was actually wondering if, when I design the dust extraction system, it should extract from the top of the (scratch built) cabinet, and feed the router cable from the top?

gdon: I’m still learning my away around CM, and haven’t yet worked out how to get to the Jog screen. Do I need to load a project before I do? I need to look at that, too.

Again, thanks for your comments - and patience :+1:


I recently upgraded to the proximity switches and the first time I homed, it tried to go past the Y rail (on the right) and I heard “That sound”.

What I did to diagnose it was to go to the jog menu and to keep clicking the “Move Right” button until the carriage made its way over to the Y rail…I got to the end and I could see that the LED did not light up. I loosened the screws and lowered the sensor (I have the one that sits vertically) until the light turned on and tightened it up. That was all it took. If your LEDs are lighting up with the scewdriver, I’m pretty sure your issue is something very similar. Try using the arrow keys to jog the carriage over and observe the LEDs. I think you’ll find your problem.


You can’t jog until you’ve homed the machine, so use the MDI to move the machine around when powered but not initializes — switch to incremental mode simplify this.

1 Like

I wonder how I was able to do it then. I couldn’t have done it by hand with the machine turned on, and the lights wouldn’t have lit up if I did it with the machine off. But I did it- and I didn’t use the MDI, for certain (Have never actually done that).

So maybe I just watched while the machine homed and saw that the light didn’t go on? I don’t remember doing that.

OK, sorted!

There was nothing obstructing the ‘Home’ location, the limiting switches worked with a metal screwdriver and when the gantry moved towards the, er, limits on the X and Y axes. The Z axis wasn’t a problem.

Initialised the XXL and it went ‘Home’

I had no idea why it started working (or stopped making ‘The Noise’) - until it did it again, but this time I noticed the plug on the router cable (which hasn’t been plugged in yet) was caught at the front of the Y2 axis!

And you definitely can’t jog the machine until it’s been initialised!

Thanks, everyone :+1:, especially you, David.Curtis, for noticing my schoolboy error!


If we were all to admit all the different ways we’ve managed to crash our machine or obstruct it’s movement with things that shouldn’t have been there, well, we’d be here for a long time.

You’re not on your own :wink:


That’s definitely a favorite of mine too! A block of wood, a dust boot, a tape measure, a game controller - they’ve all been “in the way”!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.