Large time difference with different end mills

So, this is very strange. I’m trying to cut out a bitmap image, a fairly complex piece of artwork. When I hit the “Carbide Script”, it recommends using the #102 ball-end mill.
Well, thinking that the roughing pass would probably work better with a flat end mill (wider “footprint”, more material per pass), I changed the roughing pass tool to the #101. And, after a very long computation pass, I got an estimated cut time of… 300hrs!?!
So, without changing anything else, I re-ran the path generation, but this time left the ball-end mill in place for the entire operation. And got an estimated cut time of 168 minutes.
Even stranger, even though the Inch/Min speed was the same in both profiles, when I tried running the slow NC file, the first passes along the top of the stock moved much slower than running the same pass with the faster NC file. This seemed so strange to me, I tried it both ways twice, just to ensure that I wasn’t imagining things.
So, have I just stumbled over a basic CNC concept in my ignorance, or is there something else going on?

Can you post a screenshot of your toolpath screen?

And one thing you may want to use is a free simulation program called OpenSCAM. Load both files and see what’s going on. I’ve found that it is pretty accurate, both in terms of the result and the machining time.

Sure thing. I actually encountered a different problem while running the “fast” file, which is rather disturbing.

So, I just used the default parameters for “Wood - Hard” as shown (I’m actually cutting relatively soft wood, but I figured reducing my chipload couldn’t hurt).

During the top levels of the cut, you can see that the cutter made several departures in the X axis outside the machining area. Since the 0-point for the entire cut was set at the front left corner of the milled rectangular area (well inside the edges of the wood), and I used that same corner in the Stock setup, this really should not have happened. A quick scan through the NC file shows no negative X values large enough to account for these departures.

And, at the 19-20% completion mark (according to CarbideMotion), the cutter suddenly jammed down in one of the deeper cuts. I checked the collet, and it was still completely tight, so the cutter didn’t slip. Scanning through the NC file, there are no apparent sudden Z jumps that might account for this. And since all the heavy cutting was already out of the way, I don’t see how the feed rate could have caused the spindle to suddenly stall. It’s almost as if the spindle just stopped on its own, but there are no anomalous M-codes in the NC file that would have commanded that.

And thanks, I’ll look into OpenSCAM (geez, that’s a… poorly-chosen acronym. I get what it means, but this is why marketing departments don’t let engineers name products. :grin:)


that sounds a little bit like the problem that i have been experiencing in the past. Sudden unexplainable movements of the end mill on the X axis. I just posted something about it again to my existing thread because it happened again this morning with a very uniform material (Renhape) and a very short and easy job.

see here

I’m a noob at this, but a couple of thoughts.

75ipm is, in my experience, too fast for wood. I have been cutting maple hardwood and the fastest I can use is 40ipm. I also reduced the plunge rate to 10ipm, and that combination seems to be working well. So I wonder if the feed rate is causing the cutter to skip?

I also see that your step over is too large which is resulting in those waves in your stock for the roughing pass. I would change that to something smaller - 50 or 75% of the cutter diameter.

Last thought is that are you sure you’re using the .125 end mill bit for roughing? I only ask bc I know a few cutters were sent out mislabelled. I was actually using a .063 ball cutter on my first few cuts, thinking it was a .125 cutter. Not that it’s the solution here, but it may be part of the issue. And may also explain the ridges in your roughing pass.

I’m sure folks a lot more experienced than me will chime in now, but hopefully I helped a little!

Btw the ridges can be removed by unchecking the ‘Surface Angle Limit’ checkbox. I had the same issue and Jorge figured that out for me :slight_smile:

Okay, I’ll reduce the feedrate and stepover, and uncheck the Surface Angle Limit, and give that a go.

Oh, and yes, I’ve confirmed that the cutter is .125, and a ball end.

Well… I turned the feed rates down to 40in/min for the Roughing and fine passes, and down to 20 for the Pencil Finishing pass. And I stopwatched the early long straight cuts of the roughing pass, and the speed was right on what it should have been.
I didn’t have any of those uncommanded X-axis departures, but after digging the first piece of wood out of the scrap pile and looking much more closely, I think those marks were actually splinters being ripped away, rather than the Nomad going off-path in the X axis. The second try I zero’d further in from the edge of the stock, which might have also helped, but I’m guessing it was most likely the reduced feed rates. Which is a relief, b/c I’d hate to think the Nomad was randomly making excursions off path.

However, I also unchecked the Surface Angle Limit box, but the long ridges along the X-axis are still there. And the the “head” and “chest” of the seahorse look like they had roughing passes made through them. If I load up the original bitmap in MeshCAM, those areas have the same Z height as the back and tail, so it’s not simply a matter of those areas being flatter. I dunno, could I have somehow generated a level of detail that was unattainable?
Then there’s what looks like a single rough-cut pass right down the center of the seahorse, going from head down into the center torso before stopping. Really not sure what was going on there…
(wow, walk about drifting away from the original topic)

What step over value are you using for the roughing pass?

Ditto. It looks like your roughing stepover is too high. Generally, I’ve heard half the tool diameter is a good starting point. Recently, I read this on CNC cookbook which suggests 1/3 -1/10 your tool diameter.

The “ridges” are what other people have been referring to as “cusps” which are what’s left where the ball-mill doesn’t reach.

So, I think you’re ready for your first job with a tool-change :wink:

What you may want to do to improve your results is to first do roughing with the 1/8" flat end-mill, and then do parallel and waterline finishing with the ball-mill. It will allow you to use a larger and deeper step-over during roughing (say 80% of diameter), shaving some time out, but still let you get a smooth engrave on the seahorse.


Ironically, that was actually what I was trying to do when I ran into the original problem that kicked off this entire thread – the mysterious massive increase in cutting time estimation when using a flat end mill for the roughing pass. Guess I’ll see if it recurs. :stuck_out_tongue:

That does bring up a question I’ve been wondering about, though: just what exactly happens when the NC program hits a tool change? I’m guessing that the Nomad stops and pops up an “insert tool X” message like it does at the beginning of each NC program, but as you said, this’ll be my first time.

As for the stepover value, I’ve been wondering just what that does – now that I finally took a moment to look it up (, it now seems blindingly obvious. I guess the default StepOver value for the roughing pass doesn’t take the tool selection into account. I’ll keep an eye on that, now that I know.

SkyeFire, the Nomad will stop and say “Insert tool # then click here” or similar. It then measures the new tool length and continues. That is some kind of macro triggered by the M6 command.

The default stepover value is set in the individual cutter definitions. There is no distinction between roughing and finish stepovers (they default to the same single value) so you might need to keep an eye on the stepovers if you use the same tool for roughing and finishing. The tool selection dialog box has an Edit button, so if you are always resetting the stepover (and waterline stepdown, which is a separate setting) for a particular tool you can change the defaults for that tool.

Okay, so, I think I figured out the time discrepancy from the original post. If I select the #102 mill for the roughing pass, the feed rate defaults to 5in/min. If I select the #101 ball-end mill for the roughing pass, the default feed rate is 75in/min. Yikes! So, I re-generated the NC program twice, once with the flat end mill for roughing, once with the ball end mill for roughing, but deliberately making all the other settings identical (there are some substantial differences in the default parameters for Plunge, Pass Depth, and StepOver, as well).
With the flat end mill for the roughing pass: Time estimate 3414 minutes.
With the ball end mill for the roughing pass: Time estimate 3803.

So, my problem from the first post was simply that I wasn’t watching how the various motion parameter were changing when I switched cutters.
Now I’ll set everything manually, and give the actual cut a whirl! Thanks, all.

Well… that’s different. Using these settings, I found that the behavior of the roughing pass was very different this time. Rather than the 2D “raster” pattern carving out the entire rectangle occupied by the cut path that I had before, this time the roughing pass pretty much trimmed out the outlines of the seahorse. I’m guessing this is more than just my selection of cutters – I must have changed some other setting without realizing it. Something about machining down the top of the stock, perhaps?
Anyway, here are the settings:

And here are the results of the roughing pass, while the Nomad was waiting for me to change tools. I’m not sure what that oval behind the seahorse’s back is from…

As an aside, I wonder about the ragged edges on some of the outer perimeter cuts. I didn’t have that issue before. Could my feed rate be to low, now? The wood is the same.

So, a funny thing happened during the Finishing pass.

I’m not sure what’s up, but on every perimeter-tracing cut where the cutter needed to approach the stock from the right, it wasn’t making contact – I could see a sliver of air between the cutter and the surface it was supposed to be cutting. Edges approached from the left seemed to be fine, possibly cutting a bit heavy (judging from the noise levels).

So, I’m wondering: setting issue? Something in my NC file? Or could I have hit a “hard spot” along the way and shifted my X-axis by a step or two? I have a hard time I could have an impact that hard without stalling the spindle or breaking the cutter, not to mention in pine plywood at only 35in/min.

Anyway, here’s a video clip showing what I’m talking about. I’ll post a picture of the final result when it’s done, assuming it finishes successfully…

Did you level your waste board? Perhaps the reason it’s off is because your material isn’t level.

As for the odd slot it machined, run the gcode file through OpenSCAM. I use it all the time. On some engraving work I was trying, it said it would take 2 hours - turned out there was an image way off my machining surface that I didn’t see, but it was clear as day in the OpenSCAM model. In easel, I used an older file and changed the machining size so there was a complex image that was there, but I just couldn’t see it

Well, the odd slot is definitely in OpenSCAM. I just can’t figure out where it came from – I’ve tried cutting this image several times now, and this one looks nothing like my previous attempts.
As for the X axis “walking”, no, it’s not the wasteboard – once the Finishing pass got into its “raster” phase, I was able to watch – the cutter was definitely biased to he right, relative to the cuts made by the Roughing pass. The Finishing cuts kept crossing the “valley” around the seahorse and cutting into the outer perimeter, but only on the right side. I’d hate to think that the X axis had drifted, but I can’t see any sign that the stock moved, and I’ve cut these same boards, at much higher feedrates, in the past without any stock motion at all (using the double-sided tape).

Hi there @SkyeFire, a number of thoughts:

  1. You have set the global parameter “machine geometry only” which is likely why it’s not clearing the field of the surrounding stock.

  2. You probably have a pixel or two of slightly different value out to the upper-left of your seahorse’s back where it’s digging that extra area out. You’ll want to clean up your image to prevent that.

  3. I’m a bit stumped as to the finish-pass behavior, can you post the NC code and your original image? It looks a bit like you’ve done Y-axis clearing rather than X, which isn’t what’s shown in your settings.

  4. It may be that you’ve got y-axis backlash, rather than X. With the
    machine on, see if there’s any play forward/backward in the table,
    as it’s a known issue that a batch of units shipped with thinner
    belts than the clamp was originally designed for, so it’s possible
    that there could be play in your belt-clamp on the y-axis. If that’s
    the case, then it’s just a matter of putting a shim in behind the
    belt in the clamp, which is something one of us can walk you through
    if needed. I suppose it’s possible that the same could happen to the
    X-axis, so you could check for backlash/wiggle in the X-axis as well
    with the machine on and the gantry centered.

  5. You may want to un-check “use parallel roughing” and instead use “climb” roughing in the pine, to get better chip-clearing with less tear-out.

  1. Yeah, I suspected it had to be something along those lines.

  2. That’s really puzzling – I’ve imported this image into MeshCAM several times, and never gotten that strange extra hole before. There’s no pixels in that region, as far as I can tell.

  3. I could be misunderstanding, but during the time that I observed this behavior, the cuter was “terrain following” the rough cut in full-length X-axis passes, “rastering” its way across the Y-axis of the model cut. The settings I’ve shown are screenshots taken while I was generating this NC file.

  4. No noticeable backlash. I can flex the Y axis a bit if I really push on it, but there’s no “deadband” that it bounces between the ends of – it’s more like I’m bending the drive train a bit if I really push on it. And it snaps right back to where it started (as far as I can tell) when I take the force off. I couldn’t get the X axis to wiggle at all. But I should probably dig out a dial indicator and set up an axis test for certain. Also, next time I run a cut, I’ll pen-mark the stock vs the wasteboard, which should make it evident if the stock is moving at all.

(hm, can’t upload an NC file, only image files.)