Machine parameters are invalid when measuring tool

I finally opened my Nomad today. I downloaded and installed Carbide Motion. I was getting the “Switch Hit Limit” error but with the help of this forum I realized it was because I had moved the table manually completely forward to install the wasteboard.

When I try to jog the machine, one of the steps is measuring the tool. I’ve read in this forum: A) That maybe the tool is not tight enough B) That the machine is not properly ground.

I don’t think B is my problem. I am connecting to it from a laptop. Any pointers?

I have to express that I am feeling a bit disappointed now More to come…

Ok, as I finished writing this, I went back to the machine and the error message had disappeared without any further intervention … Not sure what to think …

I remember that error from a long time ago, I can’t remember how or why but i havn’t seen it in a very long time (months, maybe more than 12 months).
Tightness of the tool should have no bearing on it but maybe the grounding of the machine makes more sense…
That said it is important to have the tool tight for other reasons. I wish there was a torque setting actually.

I was also just setting up my new Nomad and I found was I had the error on the until all the drivers installed on my computer. that could be why when you went back it was gone. all you drivers must have loaded… just my thought.

Actually, the error is still there. I guess the window just goes away if you wait long enough. Clicking on the error message makes it disappear.

The machine is homing now, but when it measures the tool it generates a different error: “Machine parameters are invalid”. If I use the quick positioning tool, I hit a “Switch hit limit” again.

When I was trying to use the program for the first time, I got a popup message from my firewall asking if it could connect to a network. I just cancelled the popup. Maybe it prevented the software from installing more stuff and that’s what’s causing my problems?

That is all very strange… Have you contacted Carbide 3D technical support.

I have and I still have to hear from them. A bit disappointing.

Hmm have you tried giving them a call. They have always been very helpfull with me and my friend BlackJack and I’m in New Zealand at the bottom of the world!

I decided to ignore the errors and what I think is malfunctioning of Carbide Motion. I went ahead and could finish my first project. I"ll post a picture when the lighting conditions are better.

Well that’s sort of good then.

Since support hasn’t contacted me yet, this is a video of my troubles:

I would cycle power on the Nomad and reconnect with Carbide motion.
Here’s the steps:
Power off the Nomad.
Close carbide motion.
Remove USB cable.
Power on Nomad
Reconnect USB
Open Carbide motion and connect.

The video is very helpful,
Thank you for your patience.

1 Like

I followed the procedure and it changes nothing.
I don’t think this is related, but when I was installing CM on Windows 10, I got a firewall pop-up telling me to Allow Carbide to communicate on these networks, I clcked Cancel.
I still get the same “Machine parameters are invalid” after tool measurement. And of course, fast positioning doesn’t work. Even if I can jog the machine manually, I want to ged rid of these messages and be able to do fast positioning. Any more ideas?

You should allow all the carbide3d software install requests. Its not clear to me if you did try reinstalling with all permissions. Can you post your settings window in carbide motion?

The thing is that when I reinstall, I don’t get the firewall question anymore. I imagine that even after an uninstall there are things floating around in configuration files and the registry. I don’t use Windows much, so I wouldn’t know.

Here are my settings:

Try control panel/windows firewall and allow it

Thank you Mark, that worked. I allowed CM access to all networks. I reinstalled the program and the problem persists…

If Carbide3d Support just connected to my computer, we might sort this out more quickly.

Connect the nomad, then open a log (settings > log), then hit the MDI button. In the text field type $# and hit send. The log will populate with machine data. Paste it here so we can take a look at the parameters.

Aha. There’s a wrong value in the G59 field. Open a log again, and in the MDI type the following (you can copy/paste), including the forward slash:

/G10L2P6X-123.815Y-107.850Z-127.000 and hit send. Verify that the G59 shows -123.815, -107.850, -127.000 in the log. Do a homing routine again and the Invalid Parameters message should be gone.

1 Like