Need help with BitSetter Failure

So I ran a job this morning with my BitSetter and had no issues. Loaded my ¼" probing blank, and tried to initialize, but this happened.

How do I fix this?

Looks very similar to this

Check you don’t have soft limits enabled ($20=1)?

1 Like

Thanks for the reply, @Julien, but that link is dead (for me at least).

I wouldn’t even know how to enable soft limits, and not sure how it would have happened in between jobs…

@johnesher Can you share your grbl settings?

@neilferreri I’m very certainly willing if you might explain how I would…

Settings–>Show Log
Then click in the MDI and send $$
You should see a string of settings starting with $.
@Julien and his secret thread suggested your $20 might be 1.

Sorry for the broken link, I meant this thread:

It may or may not be the same, but it’s easy enough to check: as @neilferreri said you can open the MDI tab, type “$20=0” (without the quotes) and click Send, then retry machine Initialization and see if it changes anything to your problem.

I agree it’s quite unlikely that it changed between jobs, this is just to cover your bases, to not spend time searching for another reason in case it would turn out to be just that setting.

[GC:G0 G54 G17 G21 G90 G94 M5 M9 M56 T0 F0 S0]

So $20=0

But I did disable the BitSetter and manually zeroed because I had to run the job. Would that make any difference?

Mmh. Just to clarify, did you just type “$$” in the MDI or did you also try my “$20=0” line in there ?
With things as they are now (with $20 set to 0), did you have a chance to re-enable the BitSetter and retry if the problem is still there ?
There should be no impact of temporarily disabling the BitSetter, that’s fine.

If the problem is still there when the BitSetter is enabled, my next moves would be

  • to jog to that same place above the BitSetter and try to jog Z down manually from CM, see if any error pops up.
  • to reproduce the problem with the log window open, and copy/paste here the content of that window right after the problem happens, there might be a clue in there.
1 Like

Just typed $$, didn’t send any config change.

I did just turn on my machine and re-enabled the BitSetter, send the configs, and it worked fine. Good, but I’d rather have known what happened for certain.

Guess it’s back to work and we’ll see how it goes today.

1 Like

Ok, so for some reason your $20 setting must have be set to 1 when the problem happened. Do you use a laser by any chance ?

1 Like

No, not yet…twenty characters

Ok, I was asking because sometimes switching back and forth between software for different uses of the machine involves macros that set/reset GRBL parameters to different values.
If you did not change anything in your usage of the machine, then I have no idea what could have set that $20 param to 1…but hopefully it will be ok now.

This topic was automatically closed after 30 days. New replies are no longer allowed.