New owner Set up errors

Hopefully you are working with support. Usually your problem sounds like a mechanical one or a configuration one.

I’ve tried but support has never answered their phone. I leave a message and I haven’t heard from anyone. It’s quite worrisome to be honest.

Thank you all for you feed back. You have been wonderful. For sure.

I am having the same exact problems. Brand new machine, recently assembled. Same error messages. Was emailing with support yesterday and one email today but no responses since this morning. Tried calling 6-7 times today with no answer. The blue LED lights in the control panel underneath the Homing switch plugs are illuminated constantly when the machine is powered on. Mike with Carbide 3D support said this is not right but I have no resolution. I’m about ready to ship this thing back to them

I’ve put you in for a phone call in the support queue and we’ll do our best to ring you back as quickly as we can during Chicago–California business hours tomorrow.

If the blue LEDs are illuminated, that typically means a homing switch is activated. If you’re not making it past the Z-axis homing during initialization then I suspect that the Z-axis homing switch may be faulty. With the machine on, don’t initialize the machine - try unplugging the homing switches one at a time to see if the blue light turns off.


I unplugged all of the homing switches today and then powered on the machine. The blue lights flickered and then remained off. I then plugged the homing switches in one at a time. Each time I plugged a switch in (no matter if it was the X, Y, or Z) the associated blue light came on and stayed on. I also tested the limit switches by placing a metal ruler against them. When doing that, each red light comes on when the ruler is placed against it. It seems like the limit switches are recognizing when they are touching the ruler but the blue lights never go off in the control board. I read on another forum that the fix was a new riser board (not sure if that’s the right term, but where the switches plug in on the control panel). Hoping to hear from customer support tomorrow to get this resolved


Hmm… I have an early ‘19 2.4e board with the Omron plunger style homing switches so maybe functions differ. [Thread where I posted pics when I was trouble shooting my switches] (X Limit Switch Broken. Where to buy new?)

CS should square you away

1 Like

Did you ever get a fix for your problem?

Update: just spoke with support on the phone. They are sending a replacement riser board. Hopefully that fixes the issue. I’ll provide an update in a few days when it comes in.

@Kiddww Can you get a good pic of the connections? It sounds like your GND and Signal lines might be switched…if that’s the case, you’ll see what you’re seeing. The switch will appear to respond, but will always output a low signal. If that’s the case, it may be that the switch connectors are not wired correctly.

Update: Carbide3D overnighted a replacement PCB riser board. I received it today and it fixed the problem. It seems the original was wired wrong from the factory. Once I spoke to someone in support it was an extremely fast response.


Can you still please post some pics?
Those of us with old boards have no idea what a riser board is. I imagine it’s to distribute 5v to all the proximity switches. Were the connectors put on backwards? Like I said, the sensor led will still light up, but the signal will always be low if the signal and ground pins are swapped. Super easy to do with the brown, black, blue wires.
Anyway, it’ll help the next guy if you post some pics.

This is a photo of the new riser board installed with the Homing switches plugged in


This is a pic of the original one. The only difference between the two that I can tell is that the white plastic parts of the plugs on the board are on the bottom in the original, and on the top in the new one.


Yup, so that reversed the two pins (looks like green and blue? Black?).
Thanks for sharing!
Glad you’re up and running!


Yes sir I Am so sorry I did not see this response sooner. But yes. We double and trio pole checked all of these and we still cannot move past the z accesses on the connection test

Update on the situation:
They sent a new circuit board and now the machine is working beautifully!

Thank you!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.