No spindle control in carbide motion

I just hooked up a 2.2 water cooled spindle and VFD with the PMW wire to link the VFD to my shapeoko. I followed / read a bunch of the guides on this page and as far as I know I have it hooked up and the VFD programmed correctly, I hope.

when I go into carbide motion and hit the start spindle button I got a window that said “please spindle 10000”. That window stopped popping up, but my G code report looks like this -

N0 M3S10000
ok
N0 G4P2
ok
N0 G4P0.5
ok
$#
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
$G
[GC:G0 G54 G17 G21 G90 G94 M3 M9 M56 T0 F0 S10000]
ok
N0 M5
ok
N0 G4P0.005
ok
N0 G4P0.005
ok
$h
ok
N0 G4P0.005
ok
M56P0
ok
N0 M3S1000
ok
N0 M5
ok
N0 M3S1000
ok
N0 M5
ok


Im brand new at all of this so I appreciate any help, I spent the whole day trying to look it up first before I came here to ask, gave it the ol’ college try for sure.

Baby steps.

What are your $32 and $33 settings?

from what I can see in the report, I don’t have a $33 setting. I’ve altered the $30 and $31 speeds.

$$
$0=10
$1=255
$2=0
$3=2
$4=0
$5=0
$6=0
$10=255
$11=0.020
$12=0.010
$13=0
$20=0
$21=0
$22=1
$23=0
$24=100.000
$25=2000.000
$26=25
$27=3.000
$30=24000
$31=3000
$32=0
$100=40.000
$101=40.000
$102=320.000
$110=10000.000
$111=10000.000
$112=1300.000
$120=500.000
$121=500.000
$122=100.000
$130=845.000
$131=850.000
$132=150.000
ok
$#
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
$G
[GC:G0 G54 G17 G21 G90 G94 M3 M9 M56 T0 F0 S10000]
ok

Ok, good. I forget that they changed in 1.1…

Nest step. You said you took the PWM wire. How about the ground (GND?) pin wire.

I needed to make sure that my ground wire between the GRBL board and my speed control board was common.

yep both are connected to the vfd

Are you able to control the speed from the VFD?

Could you list which threads you’ve looked at? Have you looked at Julien’s VFD thread

yes to both. That’s the main page I’ve been using. If i rewire and reprogram, I am able to run the vfd and spindle, but I have not got it to connect to the computer.

You first need to figure out whether it’s something on the Shapeoko/controller side, or on the VFD side.

  • Initialize and home the machine, open the Log window, go to the MDI tab, and enter M3S12000: check what voltage you get between PWM and GND at the controller side. If you don’t read ~2.5V, something’s wrong in the GRBL params or wiring (depending on where you probe for voltage). Send M5 and the voltage should drop to ~0V.

  • if you do have correct voltages being generated upon M3 commands at the controller level, then do the same check at the VFD side (likely at “VI” and “ACM” if you have a Huanyang VFD). To will ensure that the wiring is ok all the way to the VFD.

  • if you do have correct PWM/VI voltage at the VFD input, then it’s probably one of the VFD settings that’s not configured correctly to accept an external voltage input as the source for controlling the spindle speed. Can you confirm what VFD you have and what settings you modified from factory settings ?

Don’t use CM’s spindle start/stop: I have not double checked but from your log it seems like it sends M3S1000 commands, which is consistent with the fact that the Shapeoko’s default GRBL params have $30=1000, but since you have a spindle now and therefore modified $30 to 24000, M3S1000 will generated a very low voltage value. I can’t remember what GRBL does when the commanded RPM is below the $31 value. Anyway, you’ll have better control by entering the M3 commands manually in the MDI, while your are debugging the setup.

2 Likes

Julien
I got a fresh start this morning, I removed and reconnected the pins for the PWM and GND to make sure that wasn’t the problem.

When I run the M3S12000 command, I get a window that says “spindle change required. Please spindle to 12000 RPM” with a resume button. With the window open I’m getting a reading of only 2.2V from the PWM and gnd on the vfd terminals. I have the PD070 set to 1. This is the only thing that isn’t exactly as it should be from what I can see so far.

M5 does give me a 0 voltage reading, but I also get a window that says “spindle change required. please turn off spindle.” and a N0 M5 code in the report.

I followed your guide for the VFD settings, most of it was default configured as you had it, except for the PD settings to switch the vfd control to the grbl board and PD144 was only set to 1440 by default.

thanks for all the help everyone!

oh and I forgot to mention, I also have the pin set to VI and a jumper going from FOR to DCM. I’ve seen a few posts with setups that did and did not have the jumper installed.

When I take the jumper from FOR to DCM off, the display blinks. With the jumper, the lights are steady.

Can you try prepending the command with a slash character when using the MDI ? This tells CM to pass the command as is without interpreting it locally. I can’t test right now but I think that should get rid of the popups.

Do you mean the 2.2V ? That’s a perfectly normal value, since you set the min RPM to 3000 ($31), so GRBL’s effective RPM range is 3000 to 24000, therefore it maps 0-5V to 3000-24000RPM => when you set it to 12.000RPM, it generates a PWM of (12000 -3000) / (24000 - 3000) * 5V = 2.15V, roughly what you see.

By the way, if you have a watercooled spindle, you can set $31 to 0 and it will work fine too. The non-zero min RPM is for air-cooled spindles that require a minimal speed to have their fan do their job.

What this does is forcing the FORward rotation direction. It’s also controllable by PD params, so some folks may rely on those params only, that works too.

So at this point, what does and does not work for you ?

I went back and cycled through every setting on the VFD. I didn’t change any values, but it worked magically after I did that. I don’t know what I did, but it works and that’s the win I needed for today lol.

Thank you so much, I’m thankful for all the community support here!

2 Likes