Not sending correct speed command

I recently installed a VFD and spindle, I re-ran machine setup to select VFD Spindle. If I send manual commands the speed functions correctly. However, after loading a g-code file to test functionaility the G-code (actual file) calls for M3S18000 but CM sends M3S24000.

During testing I did notice that if I did not force the desired manual command it would often default to M3S24000 even if I had typed /m3 s16000.

.nc and log file
squaretest.zip (2.7 KB)

What version of CC and CM are you using. For a while lower versions of CC would tell you to set to 24,000 RPM regardless of what the gcode said. The current versions of CC is v744 for both PC and Mac and CM is 636. So if not on these versions download from carbide3d.com.

If already on those versions then post your file so we can help figure this out.

Are you using the C3D Spindle and VFD or an aftermarket setup?

Going to assume 744 was meant to be 774.

I kept digging through the forums and finally found what I was growing to be suspicious of. It appears when reconfiguring the machine the .json file is not overwritten, so if bitrunner was enabled the flag remains true even if it is disabled and spindle control is enabled. Since bitrunner is on/off without speed control the results now make sense. Answer was to change the flag to false in the config and all is well now.

Found the answer in this post:

Solved: config.json file does not update bitrunner to false if previously installed. Manually edit the file.