Ok to leave nomad on for days at a time?

Could be a real basic question. I’m totally new to CNC. Sometimes on long jobs I want to watch the toolpaths on, I pause carbide motion for hours or even days at a time.

Is it bad for the nomad In any way to leave it turned on and paused for long periods of time?

Thanks!
Matt

Please don’t.

Stepper motors work their hardest when holding position (a competitor actually had a timer in their software which expired the warranty after it was left on for a certain number of hours).

Break up jobs into smaller tasks instead.

4 Likes

Good to know that you should power down your CNC when not in use, while I do, I never saw this written anywhere I can remember.

2 Likes

Thanks will! Appreciate it.

Whilst not exactly the same scenario how long can one be left running for? For example I have a job I’m working on shortening that says 36hours. I saw a post on instagram of someone taking a job on that was 52 hours on a nomad. Is this damaging or fine as in continual use?

The machines were meant to be used — the big thing is holding position is endless repetition which is the most difficult/wearing for the machines to do — operating/cutting around the working area distributes the wear, and doesn’t involve constantly spinning the magnets between two alternating positions as holding position does.

4 Likes

That makes a lot of sense.

Cheers Will.

Yep, a stepper remaining stationary is just a heat generator. There is always a design trade with steppers between heat generation verse steady state load holding ability; presumably the holding current is always equal to or below the continuous current limit on the stepper but this might not always be true.

That said, I’ve ran a few +20 hour programs on my Nomad and it’s happy as a clam afterwards. Are the steppers warm? Yep. Does it make sense to shut off a machine that isn’t in use? Also yes.

1 Like

[JOKE MODE ON]
Now we only need a ScreenNomad Saver utility that would detect long periods of inactivity, and start moving axes around to reduce the strain on the motors and minimize power consumption.
That would feel very 1998! :slight_smile:
[JOKE MODE OFF]

3 Likes

Hmmm, I have left the steppers on for a while (I once accidentally left it on all night :frowning: )

$SLP will put grbl into sleep mode which will disable the steppers.

But you will need to reset/re-home to get out of sleep.
(You’ve likely lost your current position when the steppers disabled)

I’ve found that the reset button on the controller will reset but that seems to be a hard reset of the controller.

How do I send a ctrl-X (soft reset) in carbide motion?
Is it possible? I know @Julien will answer that CNCjs lets you send soft resets :slight_smile:

Feature request: add a Sleep/Reset button? What about a timer we can set so that if we leave Carbide Motion idle for an hour it auto sleeps?

I often leave the machine on for a few hours while working mainly because the one button that turns on the machine also turns on the enclosure lights too…

$SLP/soft-reset/re-home is not too terrible a workflow for me…
Shapeoko non-HDZ users need to be careful when the Z drops.

I also read somewhere that $SLP will go to the parking position if it is set. Haven’t tried that yet.

3 Likes

Hey, I had no idea this $SLP command existed, I really need to re-read that GRBL doc from cover to cover one day.

I double checked the CM keyboard shortcuts and there is apparently (unsurprisingly) no shortcut for Ctrl-X. The only way with CM would be to go to the MDI and try to send it from there, so…out of curiosity I tried (on my Shapeoko),

  • sending “^X” does nothing (CM probably filters that)
  • adding a / as mentioned in the MDI window to send directly to GRBL does send ^X, but produces this:

(2128): <- [GC:G0 G54 G17 G21 G90 G94 M5 M9 M56 T0 F0 S0]
(2127): -> $G
(2126): -> gc_parser_state
(2125): <- ok
(2124): <- [PRB:0.000,0.000,0.000:0]
(2123): <- [TLO:0.000]
(2122): <- [G92:0.000,0.000,0.000]
(2121): <- [G30:0.000,0.000,0.000]
(2120): <- [G28:-4.996,-4.996,-5.000]
(2119): <- [G59:0.000,0.000,0.000]
(2118): <- [G58:0.000,0.000,0.000]
(2117): <- [G57:0.000,0.000,0.000]
(2116): <- [G56:0.000,0.000,0.000]
(2115): <- [G55:0.000,0.000,0.000]
(2114): <- [G54:0.000,0.000,0.000]
(2113): -> $#
(2112): -> gc_get_offsets
(2111): <- <Idle|MPos:0.000,0.000,0.000|Bf:14,128|FS:0,0>
(2110): -> gc_sync
(2109): <- error:1
(2108): -> ^X
(2107): -> gc_not_motion

I don’t know, I may not be sending the right ASCII characters, tried with both AltGr+9 to produce the “^” char, and with the actual “^” key, same result.

Anyway, I suspect that Carbide will not like to add an auto-SLP after a given timeout, there is WAY too much risk to mess a multi-hour job for someone :slight_smile: (imagine being 10h into your 14h cut, and CM decides to go to sleep…)

Honestly, the simplest solution seems to be to rewire the machine power supply to a different plug/switch than your enclosure lights (I know I did)

Oh, I almost forgot : “CNCjs lets you send soft resets” :slight_smile:

1 Like

^X means Control-X, code value 23. CM does not appear to pass this through (I just tried with a Nomad)

I use PuTTY for most direct com needs.

4 Likes