Problem using CC Pro for a 45 degree cut

Hi all,
I was considering CC Pro to use with my Onefinity. Unfortunately the very first thing, of cutting a 45 degree edge seems to fail miserably. As you can see in the picture, it just cuts straight through. Can anyone tell me what’s wrong with my file or with what I am doing? I’ve expected this to be straight forward. I’m exporting the simple model as dxf from Rhino3d.
Thanks for your help and best,
Florian


testBoard.c2d (21.8 KB)
testBoard2.dxf (169.2 KB)

The preview functionality cannot, from reading elsewhere, render the vee and simply renders the full diameter of the cutter instead. The physical cut itself may well be correct, but that is from intuition or knowledge rather than the preview helping you. From what I’ve read, there is no workaround for this aside from using the vcarve toolpath, which may or may not suite your task

1 Like

In order to render in 3D a 45 degree edge one needs to either:

  • model in 3D using the Pro features
  • use a V carving

The latter is better for joinery, see:

and c.f.,

https://willadams.gitbook.io/design-into-3d/blind-miter-and-hidden-spline

Hi Will,
I indeed read that post. That’s not an option. I’ve been trying to do it in the Pro trial now, but don’t even get a toolpath at all. Are you able to create the cut? If yes, could you attach the file? Otherwise I guess my file cannot be handled properly.
Thanks and best,
Florian

Your file is open geometry:

Carbide Create will not properly preview a V endmill assigned to a contour toolpath (or a pocket) — it only will properly preview if one assigns a V carving toolpath. One can cut the file, but one has to do it w/o a preview in Carbide Create — you could preview in a 3rd party previewer.

To re-work the file in Carbide Create — draw up the geometry of the V cut:

Draw in a rectangle from end–end of a line:

change the dimensions appropriately:

Drag into registration and adjust the length and corner type/size:

Assign a suitable V carve toolpath:

(note that it was necessary to slightly increase the length along X of the geometry — filing a bug report on that now)

Thanks Will. The file is a dxf export of a closed polysurface in Rhino3D, hence a solid. I’ve attached the Rhino file for your reference. I guess the programs are unfortunately not really compatible. This was just a very simple usecase. There’s unfortunately no way I can build my complex shapes manually.
Best and happy easter holidays,
Florian

testBoard.zip (13.8 KB)

I’m afraid I’ve no experience w/ Rhino 3D — curious about it, but have never had occasion to use it.

I’ve been trying to work out similar challenges in creating 3D models and matching toolpaths — still haven’t found a suitable option.

For your work, as I noted, it would work to assign the toolpaths:

write out the G-Code, then preview in a tool such as CAMotics:

I’ve just run into exactly this problem… the 90degree cutter renders fine when using advanced vcarve but if I just make it follow a contour it shows up as a square ended mill. I just wanted to do a simple chamfer on the outside of my work.

Keep in mind that it doesn’t really matter what the preview shows in CC.

If you run a profile cut on a contour with a 90 V-Bit in the machine, so long as you don’t cut deeper than half the tool’s width, you’ll get your simple 45 degree chamfer. Or stick a ball mill in there for a reverse fillet.

If you’re doubtful, you can use Camotics or https://ncviewer.com/ for a final preview to give your confidence a boost.

2 Likes